Bug 865686 - [abrt] owncloud-client-1.0.5-5.fc17: QWidget::~QWidget: Process /usr/bin/owncloud was killed by signal 11 (SIGSEGV)
[abrt] owncloud-client-1.0.5-5.fc17: QWidget::~QWidget: Process /usr/bin/ownc...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mirall (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joseph Marrero
Fedora Extras Quality Assurance
abrt_hash:9599f54005ad06c17ac2f42ec1f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 02:57 EDT by markusN
Modified: 2012-12-29 01:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-29 01:28:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.30 KB, text/plain)
2012-10-12 02:57 EDT, markusN
no flags Details
File: environ (3.19 KB, text/plain)
2012-10-12 02:57 EDT, markusN
no flags Details
File: backtrace (63.62 KB, text/plain)
2012-10-12 02:57 EDT, markusN
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-12 02:57 EDT, markusN
no flags Details
File: cgroup (131 bytes, text/plain)
2012-10-12 02:57 EDT, markusN
no flags Details
File: maps (65.85 KB, text/plain)
2012-10-12 02:58 EDT, markusN
no flags Details
File: dso_list (14.23 KB, text/plain)
2012-10-12 02:58 EDT, markusN
no flags Details
File: open_fds (357 bytes, text/plain)
2012-10-12 02:58 EDT, markusN
no flags Details
File: var_log_messages (1.87 KB, text/plain)
2012-10-12 02:58 EDT, markusN
no flags Details

  None (edit)
Description markusN 2012-10-12 02:57:48 EDT
Version-Release number of selected component:
owncloud-client-1.0.5-5.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        owncloud
crash_function: QWidget::~QWidget
kernel:         3.5.6-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (9 frames)
: #0 QWidget::~QWidget at kernel/qwidget.cpp:1630
: #1 QSystemTrayIconSys::~QSystemTrayIconSys at util/qsystemtrayicon_x11.cpp:214
: #2 QSystemTrayIconPrivate::remove_sys at util/qsystemtrayicon_x11.cpp:354
: #3 QSystemTrayIcon::~QSystemTrayIcon at util/qsystemtrayicon.cpp:152
: #5 QObjectPrivate::deleteChildren at kernel/qobject.cpp:1908
: #6 QObject::~QObject at kernel/qobject.cpp:927
: #7 QApplication::~QApplication at kernel/qapplication.cpp:1095
: #8 ~QtSingleApplication at /usr/src/debug/mirall-1.0.5/src/3rdparty/qtsingleapplication/qtsingleapplication.h:37
: #9 Mirall::Application::~Application at /usr/src/debug/mirall-1.0.5/src/mirall/application.cpp:172
Comment 1 markusN 2012-10-12 02:57:51 EDT
Created attachment 625810 [details]
File: core_backtrace
Comment 2 markusN 2012-10-12 02:57:54 EDT
Created attachment 625811 [details]
File: environ
Comment 3 markusN 2012-10-12 02:57:56 EDT
Created attachment 625812 [details]
File: backtrace
Comment 4 markusN 2012-10-12 02:57:58 EDT
Created attachment 625813 [details]
File: limits
Comment 5 markusN 2012-10-12 02:57:59 EDT
Created attachment 625814 [details]
File: cgroup
Comment 6 markusN 2012-10-12 02:58:01 EDT
Created attachment 625815 [details]
File: maps
Comment 7 markusN 2012-10-12 02:58:04 EDT
Created attachment 625816 [details]
File: dso_list
Comment 8 markusN 2012-10-12 02:58:06 EDT
Created attachment 625817 [details]
File: open_fds
Comment 9 markusN 2012-10-12 02:58:07 EDT
Created attachment 625818 [details]
File: var_log_messages
Comment 10 Joseph Marrero 2012-10-14 03:22:45 EDT
New Version of mirall/owncloudclient and owncloud-csync has been released, currently I am testing it in my machine, In a about two days it should be in the testing repositories. 

SO far all sagfault errors have been corrected, the bad news is that the new sync client only works with owncloud server 4.5 and up.

So if you are in a owncloud server < 4.5 you should stick with the current owncloud client until the 1.1 version works with the older servers or you upgrade to 4.5 owncloud.
Comment 11 markusN 2012-10-14 05:35:09 EDT
Looking forward to it since the current owncloud client creates a lot of
*_conflict-* files which I have to remove on both server (owncloud server 4.5)
and my local machine(s) with:

find $HOME/ownCloud/ -name '*_conflict-*' -exec rm -f {} \;

Hope that this is addressed, too, in the new client release.
Comment 12 Fedora Update System 2012-10-14 19:11:04 EDT
mirall-1.1.0-1.fc17,owncloud-csync-0.60.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mirall-1.1.0-1.fc17,owncloud-csync-0.60.0-1.fc17
Comment 13 Fedora Update System 2012-10-14 19:17:28 EDT
mirall-1.1.0-1.fc18,owncloud-csync-0.60.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mirall-1.1.0-1.fc18,owncloud-csync-0.60.0-1.fc18
Comment 14 Fedora Update System 2012-10-15 13:36:03 EDT
Package mirall-1.1.0-1.fc18, owncloud-csync-0.60.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mirall-1.1.0-1.fc18 owncloud-csync-0.60.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16122/mirall-1.1.0-1.fc18,owncloud-csync-0.60.0-1.fc18
then log in and leave karma (feedback).
Comment 15 markusN 2012-10-15 18:22:56 EDT
(In reply to comment #12)
> mirall-1.1.0-1.fc17,owncloud-csync-0.60.0-1.fc17 has been submitted as an
> update for Fedora 17.
> https://admin.fedoraproject.org/updates/mirall-1.1.0-1.fc17,owncloud-csync-0.
> 60.0-1.fc17

I tried with

yum --enablerepo=updates-testing update mirall owncloud-csync
Loaded plugins: langpacks, presto, refresh-packagekit, tidy-cache
Package(s) mirall available, but not installed.
Package(s) owncloud-csync available, but not installed.
No Packages marked for Update

Because I have:

owncloud-csync-plugin-owncloud-0.50.8-9.fc17.x86_64
owncloud-client-1.0.5-5.fc17.x86_64
owncloud-csync-libs-0.50.8-9.fc17.x86_64

Any hints? Thanks.
Comment 16 Joseph Marrero 2012-10-15 18:37:38 EDT
yum --enablerepo=updates-testing update owncloud*
the * implies that anything related will be updated to the testing update

also you can do:

yum --enablerepo=updates-testing update owncloud-csync-plugin-owncloud owncloud-client owncloud-csync-libs


the name of the packages have not changed.

mirall and owncloud are the same app with different theme and mirall has more features like syncing folders inside your computer, at least in the last version. In this version they seem to do exactly the same.
Future versions may only provide owncloud-client

I have contacted upstream about this.
Comment 17 Joseph Marrero 2012-10-15 18:53:14 EDT
I am pushing a new version *-2 fixing a dependency error please kindly wait until this makes it to testing or just install doing:

yum --enablerepo=updates-testing install owncloud-csync-plugin-owncloud owncloud-client owncloud-csync-libs mirall-common
Comment 18 markusN 2012-10-16 13:52:13 EDT
(In reply to comment #17)
> I am pushing a new version *-2 fixing a dependency error please kindly wait
> until this makes it to testing or just install doing:
> 
> yum --enablerepo=updates-testing install owncloud-csync-plugin-owncloud
> owncloud-client owncloud-csync-libs mirall-common

after removing manually "libocsync0-0.60.0-17.1.x86_64" I could 
successfully install the new packages (so that will be the
missing dependency link).

Thanks for your efforts!
Comment 19 markusN 2012-10-16 14:25:03 EDT
Sorry for no good news, the update from testing still crashes. 
Reported as bug #867083
Comment 20 Joseph Marrero 2012-10-19 09:01:51 EDT
New version released upstream you should have it by Sunday/monday in the testing repos.

> The most important changes:
>
> * [GUI] Allow changing folder name in single folder mode
> * [GUI] Windows: Add license to installer
> * [GUI] owncloud ?logwindow will bring up the log window in an already running instance
> * [Fixes] Make sure SSL errors are always handled
> * [Fixes] Allow special characters in folder alias
> * [Fixes] Proper workaround for Menu bug in Ubuntu
> * [Fixes] csync: Fix improper memory cleanup which could cause memory leaks and crashes
> * [Fixes] csync: Fix memory leak
> * [Fixes] csync: Allow single quote (?) in file names
> * [Fixes] csync: Remove stray temporary files

I hope this fixes the new crashes
Comment 21 Fedora Update System 2012-10-19 22:35:32 EDT
owncloud-csync-0.60.1-1.fc17,mirall-1.1.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.1-1.fc17,mirall-1.1.1-1.fc17
Comment 22 Fedora Update System 2012-10-19 22:37:51 EDT
owncloud-csync-0.60.1-1.fc18,mirall-1.1.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.1-1.fc18,mirall-1.1.1-1.fc18
Comment 23 Fedora Update System 2012-12-08 22:46:11 EST
owncloud-csync-0.60.3-1.fc18,mirall-1.1.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.3-1.fc18,mirall-1.1.3-1.fc18
Comment 24 Fedora Update System 2012-12-20 21:52:06 EST
owncloud-csync-0.60.4-1.fc17,mirall-1.1.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.4-1.fc17,mirall-1.1.4-1.fc17
Comment 25 Fedora Update System 2012-12-29 01:28:26 EST
owncloud-csync-0.60.4-1.fc17, mirall-1.1.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.