Bug 867083 - [abrt] owncloud-client-1.1.0-1.fc17: owncloud_open: Process /usr/bin/owncloud was killed by signal 6 (SIGABRT)
[abrt] owncloud-client-1.1.0-1.fc17: owncloud_open: Process /usr/bin/owncloud...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mirall (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joseph Marrero
Fedora Extras Quality Assurance
abrt_hash:0c7af4f589b0f577430453f7e96...
:
: 868493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 14:23 EDT by markusN
Modified: 2012-12-29 01:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-29 01:27:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (5.17 KB, text/plain)
2012-10-16 14:23 EDT, markusN
no flags Details
File: environ (3.19 KB, text/plain)
2012-10-16 14:23 EDT, markusN
no flags Details
File: backtrace (52.93 KB, text/plain)
2012-10-16 14:23 EDT, markusN
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-16 14:24 EDT, markusN
no flags Details
File: cgroup (130 bytes, text/plain)
2012-10-16 14:24 EDT, markusN
no flags Details
File: maps (66.26 KB, text/plain)
2012-10-16 14:24 EDT, markusN
no flags Details
File: dso_list (14.44 KB, text/plain)
2012-10-16 14:24 EDT, markusN
no flags Details
File: var_log_messages (1.56 KB, text/plain)
2012-10-16 14:24 EDT, markusN
no flags Details
File: open_fds (1.28 KB, text/plain)
2012-10-16 14:24 EDT, markusN
no flags Details

  None (edit)
Description markusN 2012-10-16 14:23:50 EDT
Description of problem:
I started the owncloud client and after a few minutes (on several GB of data) it crashed. Working over wifi if that matters.

Version-Release number of selected component:
owncloud-client-1.1.0-1.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        owncloud
crash_function: owncloud_open
kernel:         3.6.1-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #5 owncloud_open at /usr/src/debug/ocsync-0.60.0/modules/csync_owncloud.c:1312
: #6 csync_vio_open at /usr/src/debug/ocsync-0.60.0/src/vio/csync_vio.c:231
: #7 _csync_push_file at /usr/src/debug/ocsync-0.60.0/src/csync_propagate.c:205
: #8 _csync_new_file at /usr/src/debug/ocsync-0.60.0/src/csync_propagate.c:611
: #9 _csync_propagation_file_visitor at /usr/src/debug/ocsync-0.60.0/src/csync_propagate.c:1259
: #11 _rbtree_subtree_walk at /usr/src/debug/ocsync-0.60.0/src/std/c_rbtree.c:152
: #24 c_rbtree_walk at /usr/src/debug/ocsync-0.60.0/src/std/c_rbtree.c:169
: #25 csync_propagate_files at /usr/src/debug/ocsync-0.60.0/src/csync_propagate.c:1383
: #26 csync_propagate at /usr/src/debug/ocsync-0.60.0/src/csync.c:509
: #27 Mirall::CSyncThread::startSync at /usr/src/debug/mirall-1.1.0/src/mirall/csyncthread.cpp:331
Comment 1 markusN 2012-10-16 14:23:54 EDT
Created attachment 628313 [details]
File: core_backtrace
Comment 2 markusN 2012-10-16 14:23:56 EDT
Created attachment 628315 [details]
File: environ
Comment 3 markusN 2012-10-16 14:23:59 EDT
Created attachment 628317 [details]
File: backtrace
Comment 4 markusN 2012-10-16 14:24:01 EDT
Created attachment 628319 [details]
File: limits
Comment 5 markusN 2012-10-16 14:24:03 EDT
Created attachment 628321 [details]
File: cgroup
Comment 6 markusN 2012-10-16 14:24:05 EDT
Created attachment 628324 [details]
File: maps
Comment 7 markusN 2012-10-16 14:24:07 EDT
Created attachment 628326 [details]
File: dso_list
Comment 8 markusN 2012-10-16 14:24:09 EDT
Created attachment 628328 [details]
File: var_log_messages
Comment 9 markusN 2012-10-16 14:24:11 EDT
Created attachment 628329 [details]
File: open_fds
Comment 10 Joseph Marrero 2012-10-19 09:01:01 EDT
New version released upstream you should have it by Sunday/monday in the testing repos.

> The most important changes:
>
> * [GUI] Allow changing folder name in single folder mode
> * [GUI] Windows: Add license to installer
> * [GUI] owncloud ?logwindow will bring up the log window in an already running instance
> * [Fixes] Make sure SSL errors are always handled
> * [Fixes] Allow special characters in folder alias
> * [Fixes] Proper workaround for Menu bug in Ubuntu
> * [Fixes] csync: Fix improper memory cleanup which could cause memory leaks and crashes
> * [Fixes] csync: Fix memory leak
> * [Fixes] csync: Allow single quote (?) in file names
> * [Fixes] csync: Remove stray temporary files

I hope this fixes the new crashes
Comment 11 Fedora Update System 2012-10-19 22:35:05 EDT
owncloud-csync-0.60.1-1.fc17,mirall-1.1.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.1-1.fc17,mirall-1.1.1-1.fc17
Comment 12 Fedora Update System 2012-10-19 22:37:30 EDT
owncloud-csync-0.60.1-1.fc18,mirall-1.1.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.1-1.fc18,mirall-1.1.1-1.fc18
Comment 13 markusN 2012-10-20 06:15:12 EDT
While the dependencies are handled correctly now, still SIGSEGV (signal 6) for mirall after a while of syncing. Reported as new bug #868493
Comment 14 markusN 2012-10-20 12:16:07 EDT
*** Bug 868493 has been marked as a duplicate of this bug. ***
Comment 15 Joseph Marrero 2012-10-20 16:36:06 EDT
The negative karma was based on 1.1.0 or 1.1.1?
Because 1.1.1 is not yet in testing.
Comment 16 markusN 2012-10-20 18:37:27 EDT
(In reply to comment #15)
> The negative karma was based on 1.1.0 or 1.1.1?

On owncloud-client-1.1.0-1.fc17...

> Because 1.1.1 is not yet in testing.

.. right, sorry for the confusion. Will stay tuned
for owncloud-client-1.1.1.
Comment 17 Fedora Update System 2012-10-21 01:56:33 EDT
Package owncloud-csync-0.60.1-1.fc18, mirall-1.1.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing owncloud-csync-0.60.1-1.fc18 mirall-1.1.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16538/owncloud-csync-0.60.1-1.fc18,mirall-1.1.1-1.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-12-08 22:46:18 EST
owncloud-csync-0.60.3-1.fc18,mirall-1.1.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.3-1.fc18,mirall-1.1.3-1.fc18
Comment 19 Fedora Update System 2012-12-20 21:51:31 EST
owncloud-csync-0.60.4-1.fc17,mirall-1.1.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.4-1.fc17,mirall-1.1.4-1.fc17
Comment 20 Fedora Update System 2012-12-29 01:27:49 EST
owncloud-csync-0.60.4-1.fc17, mirall-1.1.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.