Bug 865710 - errai demo examples in the errai distribution do not have versions of gwt-maven-plugin specified
errai demo examples in the errai distribution do not have versions of gwt-mav...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Errai (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 2.1.0
Assigned To: Pavel SLegr
Karel Piwko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 04:36 EDT by Stefan Miklosovic
Modified: 2015-08-02 19:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:34:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Miklosovic 2012-10-12 04:36:32 EDT
Description of problem:

Demo examples in the errai distribution do not have version of the gwt-maven-plugin specified which results of taking the lastest version of the gwt-maven-plugin from the central (currently 2.5.0-rc1). Involving of this plugin version of the gwt-maven-plugin to the building process of all demos causes that examples are unbuildable.

Version-Release number of selected component (if applicable):
2.1.0.CR2 demos

How reproducible:
Always until version of the gwt-plugin is not specified directly in the project's pom.xml

Steps to Reproduce:
1.
2.
3.
  
Actual results:
unsuccessful build of all projects

Expected results:
successful build of all projects

Additional info:
Comment 2 Stefan Miklosovic 2012-10-12 06:06:07 EDT
This fix caused the next error - while trying to import the whole project to the JBDS as an existing maven project, the pom.xml of the parent project can not be parsed because of existing <version> tag in the configuration section of the lifecycle plugin which replaced former <versionRange> tag. The <version> tag is not allowed to be present. Go back to the <versionRange> and correct versioning appropriately, suggesting something like 

<versionRange>[2.3.0,${gwt.version}]</versionRange>

(In reply to comment #1)
> fixed with:
> http://git.app.eng.bos.redhat.com/?p=errai/errai.git;a=commit;
> h=76c67a442f61393a16b0cc9292fb8a0f2c7230ef
Comment 4 Stefan Miklosovic 2012-10-18 09:20:52 EDT
I am hereby verifying that all examples of errai in the jboss-wfk-2.1.0.ER2/demo/errai-2.1.0.Final-redhat-1 are buildable with the success after the fixing commit, however their actuall deployment of all demos in the distribution, not only jpa ones, to the EAP 6.0.0.GA is erroneous. This issue is covered in the bug #865415, comment (1).

(1) https://bugzilla.redhat.com/show_bug.cgi?id=865415#c6
Comment 5 Karel Piwko 2012-11-30 10:34:18 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.