Bug 865744 - [RFE]shutdown event options "on_crash" does not work for Windows guest
[RFE]shutdown event options "on_crash" does not work for Windows guest
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.10
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 06:05 EDT by chencong
Modified: 2013-01-08 23:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 03:02:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chencong 2012-10-12 06:05:26 EDT
Description of problem:
shutdown event options "on_crash" in xm domain config does not work for all Windows guests.

Version:
xen-3.0.3-142.el5

Steps of Reproduce:
1. change the xm domain config options:
on_crash, with values: destroy, restart, preserve, rename-restart
respectively.
2. create a windows guest.
3. trigger the guest crash by send the SysRq key to guest:
#xm sysrq $domain B

Actual results:
1. When mark "Automatically restart" checkbox in guest
("System Properites" > "Advanced" -> "Startup and Recovery Settings"> "System failure"), the guest will reboot no matter which values in xmdomain config file setup.
when it is not mark, the guest will hang after crash.

Expected results:
1. The guest should response to on_crash option.

Additional info:
1. Also try to make windows guest crash in another way, we crash the windows XP guest inside the windows using the method in bug 861273, and get same result.

2. as xen source code show:
/$xen_source/tools/xenstat/libxenstat/src/xenstat.c
unsigned int xenstat_domain_crashed(xenstat_domain * domain) {
return ((domain->state & DOMFLAGS_SHUTDOWN) DOMFLAGS_SHUTDOWN)
&& (((domain->state >> DOMFLAGS_SHUTDOWNSHIFT)
& DOMFLAGS_SHUTDOWNMASK) SHUTDOWN_crash);
}
This may be a problem caused by different domain info standard between linux guest and windows guest.

3. During the late phase of Xen, this is a low priority task, may be not repaired, but we still think it is good to be record the problem.

4.The issue is already discussed in upstream, see link:
http://lists.xen.org/archives/html/xen-devel/2009-02/msg00866.html

Note You need to log in before you can comment on or make changes to this bug.