Bug 865868 - USB Clerk will not install if virt-viewer is installed.
USB Clerk will not install if virt-viewer is installed.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: usb-clerk-win (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Uri Lublin
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 13:00 EDT by Bill Sanford
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 14:47:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-10-12 13:00:55 EDT
Description of problem:
With a Windows 7 (32-bit) client, I launch a VM from the RHEV-M si20 User Portal. I then get prompted for the ActiveX and the Virt-Viewer download. Everything is fine. I then close IE and reopen "As Administrator" to install USB Clerk and all I get is the Virt-Viewer VM Launch. I close IE and then uninstall the Virt-Viewer from the Control Panel in the client and reopen IE "As Administrator" and the USB Clerk in now prompted to install.

Version-Release number of selected component (if applicable):
RHEV-M si20

How reproducible:
100%

Steps to Reproduce:
1. See above.
2.
3.
  
Actual results:
Virt-Viewer will inhibit USB Clerk from installing.

Expected results:
Virt-Viewer will not inhibit USB Clerk from installing.

Additional info:
Comment 1 Arnon Gilboa 2012-10-14 06:45:23 EDT
Uri, elmarco, is usbclerk installed/updated only if virt-viewer is installed/updated?
Comment 2 Uri Lublin 2012-10-14 07:54:47 EDT
If the user has admin privileges, the virt-viewer installer also installs usbclerk (by calling usbclerk installer).
If the user does not have admin privileges, the virt-viewer installer does not install usbclerk.
Note that an admin user can install usbclerk by running usbclerk-setup.exe directly. It is located under the "bin" directory where virt-viewer was installed.
Comment 3 David Jaša 2012-10-15 04:16:05 EDT

*** This bug has been marked as a duplicate of bug 857087 ***
Comment 4 Bill Sanford 2012-10-15 08:52:15 EDT
David, this is not about checking if the service will run, this is about running IE as Administrator and USB Clerk not being installed.
Comment 6 Uri Lublin 2013-07-14 04:51:17 EDT
(Following Comment #1 and Comment #2)
After the first step, spice active-x and virt-viewer are installed. When running as administrator, RHEV-M notices that spice-active-x is installed and requests spice-active-x to launch remote-viewer. There is no need at this point to download the cab file.
After virt-viewer (and spice-active-x) are removed from the client machine, and running as administrator, the cab file is being downloaded again and spice-active-x + virt-viewer + usbclerk are installed.

As mentioned in Comment #2, there is no need to uninstall + reinstall. Administrators can simply run usbclerk-setup.exe to install usbclerk.
Comment 7 David Blechter 2013-07-15 14:47:23 EDT
close based on comments 1,2 and 6

Note You need to log in before you can comment on or make changes to this bug.