Bug 866015 - [abrt]: WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:533 iwl_dvm_send_cmd+0x130/0x140 [iwldvm](): TAINTED P
[abrt]: WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:533 iwl_d...
Status: CLOSED DUPLICATE of bug 866013
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:8f0ae4ce5352d29288890ba2016...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 06:02 EDT by russianred
Modified: 2012-10-18 07:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 07:43:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description russianred 2012-10-13 06:02:51 EDT
Description of problem:
Occured after latest updates using yum, update from 3.5.6 to 3.6.1 kernel

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.1-1.fc17.x86_64 root=/dev/mapper/luks-4ff3ebf6-a7e5-4a52-b54b-8342d3200bcd ro rd.md=0 rd.dm=0 rd.luks.uuid=luks-4ff3ebf6-a7e5-4a52-b54b-8342d3200bcd KEYTABLE=us rd.lvm.lv=vg_sl500/lv_swap rd.lvm.lv=vg_sl500/lv_root LANG=en_US.UTF-8 SYSFONT=True rd.luks.uuid=luks-0b55fd6c-dde9-4f52-a1e3-5e4e36886df4 rhgb quiet nouveau.modeset=0 rd.driver.blacklist=nouveau
kernel:         3.6.1-1.fc17.x86_64
kernel_tainted_long: Proprietary module has been loaded.

backtrace:
:WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:533 iwl_dvm_send_cmd+0x130/0x140 [iwldvm]()
:Hardware name: 2746A75
:iwl_trans_send_cmd bad state = 0
:Modules linked in: lockd sunrpc bnep bluetooth ip6t_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables nvidia(PO) uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media snd_hda_codec_hdmi snd_hda_codec_conexant arc4 iwldvm mac80211 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm r8169 iwlwifi coretemp kvm_intel asus_laptop i2c_core kvm snd_page_alloc cfg80211 sparse_keymap input_polldev mii iTCO_wdt iTCO_vendor_support rfkill snd_timer snd soundcore serio_raw lpc_ich mfd_core microcode uinput xts gf128mul dm_crypt video
:Pid: 1025, comm: wpa_supplicant Tainted: P           O 3.6.1-1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105b84f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8105b946>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa02be8c0>] iwl_dvm_send_cmd+0x130/0x140 [iwldvm]
: [<ffffffffa02c2af6>] iwl_send_add_sta+0xd6/0x120 [iwldvm]
: [<ffffffffa02c345e>] iwl_add_station_common+0x16e/0x290 [iwldvm]
: [<ffffffffa02b9472>] iwlagn_mac_sta_add.isra.10+0x92/0xf0 [iwldvm]
: [<ffffffffa02ba21f>] iwlagn_mac_sta_state+0x28f/0x330 [iwldvm]
: [<ffffffffa0209de9>] sta_info_insert_finish+0xb9/0x750 [mac80211]
: [<ffffffff81618f06>] ? __schedule+0x3c6/0x7a0
: [<ffffffff81617fdd>] ? mutex_lock+0x1d/0x50
: [<ffffffffa02cbdac>] ? iwlagn_bss_info_changed+0x1bc/0x5c0 [iwldvm]
: [<ffffffffa020a7fe>] sta_info_insert_rcu+0xae/0xd0 [mac80211]
: [<ffffffffa020a82e>] sta_info_insert+0xe/0x10 [mac80211]
: [<ffffffffa0240411>] ieee80211_prep_connection+0x241/0x570 [mac80211]
: [<ffffffffa0245320>] ieee80211_mgd_auth+0x200/0x280 [mac80211]
: [<ffffffffa021b148>] ieee80211_auth+0x18/0x20 [mac80211]
: [<ffffffffa0097cd2>] __cfg80211_mlme_auth+0x152/0x180 [cfg80211]
: [<ffffffffa0097d9a>] cfg80211_mlme_auth+0x9a/0xd0 [cfg80211]
: [<ffffffffa008c429>] nl80211_authenticate+0x219/0x260 [cfg80211]
: [<ffffffff81536f70>] genl_rcv_msg+0x250/0x2d0
: [<ffffffff81536d20>] ? genl_rcv+0x40/0x40
: [<ffffffff81536891>] netlink_rcv_skb+0xa1/0xb0
: [<ffffffff81536d05>] genl_rcv+0x25/0x40
: [<ffffffff815361ed>] netlink_unicast+0x19d/0x220
: [<ffffffff81536548>] netlink_sendmsg+0x2d8/0x390
: [<ffffffff814f598c>] sock_sendmsg+0xbc/0xf0
: [<ffffffff814f5eb7>] ? sock_recvmsg+0xd7/0x110
: [<ffffffff8112ba6d>] ? __generic_file_aio_write+0x1cd/0x3d0
: [<ffffffff814f5d6c>] __sys_sendmsg+0x3ac/0x3c0
: [<ffffffff811a3808>] ? __d_free+0x48/0x70
: [<ffffffff811a388d>] ? d_free+0x5d/0x70
: [<ffffffff811a4c6d>] ? d_kill+0xbd/0x110
: [<ffffffff811ac339>] ? mntput_no_expire+0x49/0x130
: [<ffffffff811ac446>] ? mntput+0x26/0x40
: [<ffffffff8118fc7e>] ? __fput+0x16e/0x240
: [<ffffffff814f7c09>] sys_sendmsg+0x49/0x90
: [<ffffffff816226e9>] system_call_fastpath+0x16/0x1b
Comment 1 Josh Boyer 2012-10-15 05:43:07 EDT
Can you recreate this without the nvidia module loaded?
Comment 2 Stanislaw Gruszka 2012-10-16 06:39:20 EDT
Please add this iwlwifi module debug option:

echo "options iwlwifi debug=0x0803" > /etc/modprobe.d/iwlwifi.conf

and install this kernel, with additional patch:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4591540

Then try to reproduce the problem and provide output of dmesg:

dmesg > dmesg.txt

(attach dmesg.txt file here).
Comment 3 Stanislaw Gruszka 2012-10-18 07:43:57 EDT

*** This bug has been marked as a duplicate of bug 866013 ***

Note You need to log in before you can comment on or make changes to this bug.