Bug 866013 - [abrt]: WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:607 iwlagn_mac_flush+0x1a3/0x1b0 [iwldvm](): TAINTED P
[abrt]: WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:607 iwlag...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:3abfc1137278e825b39ab2a78d1...
:
: 861753 866015 867661 868438 869186 887638 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 05:55 EDT by russianred
Modified: 2012-12-16 16:32 EST (History)
27 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 09:30:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (177.23 KB, text/plain)
2012-10-16 15:56 EDT, russianred
no flags Details

  None (edit)
Description russianred 2012-10-13 05:55:22 EDT
Description of problem:
Updated from 3.5.6 to 3.6.6 kernel

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.1-1.fc17.x86_64 root=/dev/mapper/luks-4ff3ebf6-a7e5-4a52-b54b-8342d3200bcd ro rd.md=0 rd.dm=0 rd.luks.uuid=luks-4ff3ebf6-a7e5-4a52-b54b-8342d3200bcd KEYTABLE=us rd.lvm.lv=vg_sl500/lv_swap rd.lvm.lv=vg_sl500/lv_root LANG=en_US.UTF-8 SYSFONT=True rd.luks.uuid=luks-0b55fd6c-dde9-4f52-a1e3-5e4e36886df4 rhgb quiet nouveau.modeset=0 rd.driver.blacklist=nouveau
kernel:         3.6.1-1.fc17.x86_64
kernel_tainted_long: Proprietary module has been loaded.

backtrace:
:WARNING: at drivers/net/wireless/iwlwifi/dvm/../iwl-trans.h:607 iwlagn_mac_flush+0x1a3/0x1b0 [iwldvm]()
:Hardware name: 2746A75
:iwl_trans_wait_tx_queue_empty bad state = 0
:Modules linked in: fuse lockd sunrpc bnep bluetooth ip6t_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media nvidia(PO) arc4 iwldvm snd_hda_codec_hdmi snd_hda_codec_conexant mac80211 snd_hda_intel coretemp snd_hda_codec iTCO_wdt iTCO_vendor_support lpc_ich snd_hwdep iwlwifi snd_seq snd_seq_device mfd_core snd_pcm i2c_core r8169 asus_laptop kvm_intel kvm cfg80211 snd_page_alloc mii microcode sparse_keymap rfkill snd_timer snd soundcore serio_raw input_polldev uinput xts gf128mul dm_crypt video
:Pid: 1062, comm: wpa_supplicant Tainted: P           O 3.6.1-1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105b84f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8105b946>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff814c932d>] ? led_set_brightness+0x4d/0x60
: [<ffffffffa0207a88>] ? __ieee80211_start_scan+0xa8/0x4e0 [mac80211]
: [<ffffffffa029a593>] iwlagn_mac_flush+0x1a3/0x1b0 [iwldvm]
: [<ffffffffa020fb86>] __ieee80211_recalc_idle+0x236/0x2f0 [mac80211]
: [<ffffffffa020fd93>] ieee80211_recalc_idle+0x33/0x60 [mac80211]
: [<ffffffffa0207afd>] __ieee80211_start_scan+0x11d/0x4e0 [mac80211]
: [<ffffffff811798cd>] ? __kmalloc+0x14d/0x1a0
: [<ffffffffa0208af9>] ieee80211_request_scan+0x39/0x60 [mac80211]
: [<ffffffffa02141be>] ieee80211_scan+0x6e/0x90 [mac80211]
: [<ffffffffa0089005>] nl80211_trigger_scan+0x485/0x610 [cfg80211]
: [<ffffffff81536f70>] genl_rcv_msg+0x250/0x2d0
: [<ffffffff81536d20>] ? genl_rcv+0x40/0x40
: [<ffffffff81536891>] netlink_rcv_skb+0xa1/0xb0
: [<ffffffff81536d05>] genl_rcv+0x25/0x40
: [<ffffffff815361ed>] netlink_unicast+0x19d/0x220
: [<ffffffff81536548>] netlink_sendmsg+0x2d8/0x390
: [<ffffffff814f598c>] sock_sendmsg+0xbc/0xf0
: [<ffffffff814f5eb7>] ? sock_recvmsg+0xd7/0x110
: [<ffffffff815363a0>] ? netlink_sendmsg+0x130/0x390
: [<ffffffff814f5d6c>] __sys_sendmsg+0x3ac/0x3c0
: [<ffffffff811a26b1>] ? core_sys_select+0x2a1/0x350
: [<ffffffff811a388d>] ? d_free+0x5d/0x70
: [<ffffffff811a4c6d>] ? d_kill+0xbd/0x110
: [<ffffffff811ac339>] ? mntput_no_expire+0x49/0x130
: [<ffffffff811ac446>] ? mntput+0x26/0x40
: [<ffffffff8118fc7e>] ? __fput+0x16e/0x240
: [<ffffffff814f7c09>] sys_sendmsg+0x49/0x90
: [<ffffffff816226e9>] system_call_fastpath+0x16/0x1b
Comment 1 russianred 2012-10-13 05:57:21 EDT
Updated from 3.5.6 to 3.6.1 kernel

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Josh Boyer 2012-10-15 05:44:08 EDT
Can you recreate this without the nvidia module loaded?
Comment 3 Stanislaw Gruszka 2012-10-16 06:39:03 EDT
Please add this iwlwifi module debug option:

echo "options iwlwifi debug=0x0803" > /etc/modprobe.d/iwlwifi.conf

and install this kernel, with additional patch:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4591540

Then try to reproduce the problem and provide output of dmesg:

dmesg > dmesg.txt

(attach dmesg.txt file here).
Comment 4 russianred 2012-10-16 12:17:22 EDT
For Josh: Same problem happens without nvidia module loaded. Made a test with fresh install of Fedora XFCE, no additional software installed. Ran yum update, latest kernel installed. When logging in, same bug is reported and wifi stops working.

Stan: let me try and i'll post results asap.
Comment 5 russianred 2012-10-16 15:56:14 EDT
Created attachment 915506 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 6 Stanislaw Gruszka 2012-10-17 02:38:28 EDT
Next time please provide debug logs as file attachment.
Comment 7 Stanislaw Gruszka 2012-10-17 03:56:09 EDT
What iwlwifi device do you have (lspci -vnn) ?
Comment 8 russianred 2012-10-17 04:09:10 EDT
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
	Subsystem: Intel Corporation WiFi Link 5100 AGN [8086:1211]
	Flags: bus master, fast devsel, latency 0, IRQ 48
	Memory at fe3fe000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [e0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number ...
	Kernel driver in use: iwlwifi
Comment 9 Emmanuel Grumbach 2012-10-17 16:46:22 EDT
Hi,

can you please try this one?
http://git.kernel.org/?p=linux/kernel/git/jberg/mac80211.git;a=commitdiff;h=3a40414f826a8f1096d9b94c4a53ef91b25ba28d

Thanks
Comment 10 Stanislaw Gruszka 2012-10-18 05:04:55 EDT
I lunched kernel build with above patch here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4602595
Please test when it finish to compile.
Comment 11 Emmanuel Grumbach 2012-10-18 05:30:57 EDT
Thanks Stan.
From private discussions with the submitter (russianred@gmail.com), I came to the conclusion that the issue he is seeing is because his AP is configured on channel 13 Wide mode.
So the Johannes's fix is very likely to help.

Stan, can you please tell me if that helps for the other bugs too?
Thanks
Comment 12 Stanislaw Gruszka 2012-10-18 05:41:32 EDT
I'll ask reporters on bugzillas ...
Comment 13 russianred 2012-10-18 07:02:37 EDT
kernel-3.6.2-5.iwlwifi_v2.fc17.x86_64.rpm fixed the problem.

Thanks to all of you.
Comment 14 Stanislaw Gruszka 2012-10-18 07:43:57 EDT
*** Bug 866015 has been marked as a duplicate of this bug. ***
Comment 15 Stanislaw Gruszka 2012-10-18 08:39:18 EDT
Josh, please apply patch from comment 9 as fix for this bug.
Comment 16 Josh Boyer 2012-10-18 08:55:02 EDT
Applied to F16-F18.
Comment 17 Josh Boyer 2012-10-18 09:30:54 EDT
*** Bug 867661 has been marked as a duplicate of this bug. ***
Comment 18 togeil 2012-10-21 05:31:23 EDT
Wireless driver crashes while booting. I'm using a lenovo R400 notebook. Last working kernel version is 3.5.6-1.fc17.i686.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 19 Stanislaw Gruszka 2012-10-22 03:16:30 EDT
*** Bug 868438 has been marked as a duplicate of this bug. ***
Comment 20 Stanislaw Gruszka 2012-10-22 04:57:40 EDT
*** Bug 861753 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2012-10-22 14:39:39 EDT
kernel-3.6.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.3-1.fc17
Comment 22 aten 2012-10-22 18:23:58 EDT
wifi was trying to connect to AP and could not. Suddenly abrt has been triggered.  

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 23 Fedora Update System 2012-10-22 21:55:07 EDT
Package kernel-3.6.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.3-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16669/kernel-3.6.3-1.fc17
then log in and leave karma (feedback).
Comment 24 Josh Boyer 2012-10-23 08:42:19 EDT
*** Bug 869186 has been marked as a duplicate of this bug. ***
Comment 25 Fedora Update System 2012-10-23 17:57:51 EDT
kernel-3.6.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.3-3.fc18
Comment 26 Tomas Dolezal 2012-10-30 13:43:04 EDT
probably after trying to connect to eduroam wifi network

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 27 japa-fi 2012-10-31 12:31:52 EDT
(In reply to comment #23)
> Package kernel-3.6.3-1.fc17:
> * should fix your issue,

Tested, solved the issue for my (lenovo T400 Intel(R) Ultimate N WiFi Link 5300 AGN), left feedback/karma.
Comment 28 Fedora Update System 2012-11-01 09:23:36 EDT
kernel-3.6.5-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.5-2.fc16
Comment 29 mertensb.mazda 2012-11-03 07:33:09 EDT
I disabled the option HT20/40 Coexistence on my D-Link DIR-857 and rebooted the router.

About a minute later I was prompted to reenter the passphrase for my wireless network.

At this point I noticed the crash.


Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 30 Eduardo 2012-11-03 14:22:53 EDT
I installed kernel-3.6.3-1.fc17 and does not seem to fix the issue. Dmesg output is 
[12664.071943] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[12664.075375] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0
[12664.114895] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

IPV6INIT=no in ifcfg-wlan0, but if I change to yes, same result
network manager is disabled
Comment 31 Luke Hutchison 2012-11-07 04:27:10 EST
Was playing YouTube video, streaming audio over Bluetooth.

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 32 Kahlil Hodgson 2012-11-07 18:34:31 EST
Eating my breakfast while typing one-handed.  Don't really think that was the cause though

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 33 Stanislaw Gruszka 2012-11-08 09:06:44 EST
Applied patch fix problem for some of you. Those who still have problem on 3.6.5-2.fc16 or kernel-3.6.3-1.fc17 or kernel-3.6.3-3.fc18 or later, please open a new bug report, or if your original bug report was closed as duplicate of this one, reopen it. Thanks.
Comment 34 Josh Boyer 2012-11-08 09:30:39 EST
This has all been pushed to stable.  Bodhi isn't closing bugs for some reason.
Comment 35 Jesse Kahtava 2012-11-20 20:42:47 EST
I'm running 3.6.6-1.fc17.x86_64 and this problem persists...
Comment 36 Emmanuel Grumbach 2012-11-21 01:49:51 EST
can you please attach a *full* log?
In this bug I saw different issues. When you say *this problem* this doesn't mean anything
Comment 37 Stanislaw Gruszka 2012-11-21 03:54:17 EST
And first open a new bug for this, see comment 33 .
Comment 38 Felix Kaechele 2012-12-16 16:32:39 EST
*** Bug 887638 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.