Bug 866028 - BootLoaderError: failed to set new efi boot target
BootLoaderError: failed to set new efi boot target
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:783b9750e1cde0bc3f77f3ed549...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 07:12 EDT by Dmitry Ursegov
Modified: 2013-12-19 14:04 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 14:04:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (936.18 KB, text/plain)
2012-10-13 07:12 EDT, Dmitry Ursegov
no flags Details
File: environ (882 bytes, text/plain)
2012-10-13 07:12 EDT, Dmitry Ursegov
no flags Details
File: type (9 bytes, text/plain)
2012-10-13 07:12 EDT, Dmitry Ursegov
no flags Details
File: storage.log (483.99 KB, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: version (2 bytes, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: program.log (82.28 KB, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: product (6 bytes, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: anaconda.log (53.47 KB, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: packaging.log (142 bytes, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: cmdline_file (106 bytes, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: release (33 bytes, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: messages (257.04 KB, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details
File: other involved packages (32 bytes, text/plain)
2012-10-13 07:13 EDT, Dmitry Ursegov
no flags Details

  None (edit)
Description Dmitry Ursegov 2012-10-13 07:12:46 EDT
Description of problem:
Install fedora rawhide 11.10.2012 on Macbook air mid 2012 (5.2). Choose automatic disk partitioning.

Version-Release number of selected component:
anaconda-18.14-1.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1617, in add_efi_boot_target
:    raise BootLoaderError("failed to set new efi boot target")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1622, in install
:    self.add_efi_boot_target()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1652, in install
:    super(MacEFIGRUB, self).install()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1638, in write
:    self.install()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2205, in writeBootLoader
:    storage.bootloader.write()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 122, in doInstall
:    writeBootLoader(storage, payload, instClass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:BootLoaderError: failed to set new efi boot target
Comment 1 Dmitry Ursegov 2012-10-13 07:12:52 EDT
Created attachment 626498 [details]
File: anaconda-tb
Comment 2 Dmitry Ursegov 2012-10-13 07:12:54 EDT
Created attachment 626499 [details]
File: environ
Comment 3 Dmitry Ursegov 2012-10-13 07:12:56 EDT
Created attachment 626500 [details]
File: type
Comment 4 Dmitry Ursegov 2012-10-13 07:13:00 EDT
Created attachment 626501 [details]
File: storage.log
Comment 5 Dmitry Ursegov 2012-10-13 07:13:01 EDT
Created attachment 626502 [details]
File: version
Comment 6 Dmitry Ursegov 2012-10-13 07:13:04 EDT
Created attachment 626503 [details]
File: program.log
Comment 7 Dmitry Ursegov 2012-10-13 07:13:05 EDT
Created attachment 626504 [details]
File: product
Comment 8 Dmitry Ursegov 2012-10-13 07:13:08 EDT
Created attachment 626505 [details]
File: anaconda.log
Comment 9 Dmitry Ursegov 2012-10-13 07:13:09 EDT
Created attachment 626506 [details]
File: hashmarkername
Comment 10 Dmitry Ursegov 2012-10-13 07:13:11 EDT
Created attachment 626507 [details]
File: packaging.log
Comment 11 Dmitry Ursegov 2012-10-13 07:13:13 EDT
Created attachment 626508 [details]
File: cmdline_file
Comment 12 Dmitry Ursegov 2012-10-13 07:13:15 EDT
Created attachment 626509 [details]
File: release
Comment 13 Dmitry Ursegov 2012-10-13 07:13:18 EDT
Created attachment 626510 [details]
File: messages
Comment 14 Dmitry Ursegov 2012-10-13 07:13:20 EDT
Created attachment 626511 [details]
File: other involved packages
Comment 15 Alex Murray 2012-11-26 05:56:23 EST
Tried installing F18 Beta RC1 using default partitioning with LVM on my MacBook Pro 9,1

Package: anaconda-18.29.2-1.fc18.x86_64
OS Release: Fedora release 18
Comment 16 Dmitry Ursegov 2012-11-26 06:01:18 EST
So, what is your result?
Comment 17 Dmitry Ursegov 2012-11-26 06:08:34 EST
Sorry, please ignore the comment.
Comment 18 Alex Murray 2012-11-26 06:10:40 EST
It didn't work - ie. after rebooting and holding down alt / option no Fedora partition was recognised - I then tried re-installing using the same options but got a slightly different bug - https://bugzilla.redhat.com/show_bug.cgi?id=880143 - so instead of failing to set new EFI boot target, this time it failed to remove the old one - so far I haven't yet rebooted (am writing this from within the live environment still) but will see if it is bootable this time....
Comment 19 Alex Murray 2012-11-26 22:18:15 EST
Nope that also failed - as noted on bug #880143 am going to try a non LVM install to see if that works any better.
Comment 20 Alex Murray 2012-11-26 22:26:36 EST
So this is probably similar to bug #873629 - basically there is some invalid looking entry(s) in the EFI boot manager table so efibootmgr bails with an error - any ideas how to clean these entries up?
Comment 21 Dmitry Ursegov 2012-11-27 03:08:59 EST
Since this works fine in F17, I think we just need to find the regression.
Comment 22 Alex Murray 2012-11-27 04:37:30 EST
I think the problem is that the more recent kernels are stricter about what is considered an invalid variable and so they disallow things they were previously allowed in F17 http://lkml.indiana.edu/hypermail/linux/kernel/1205.0/01460.html

The real question is whether it's detecting false positives or not, ie. Perhaps the entries are valid but the kernel now thinks they are invalid.
Comment 23 Alex Murray 2012-11-27 08:02:33 EST
After more investigation it seems this is probably a dupe of bug #873629 since it looks like the problem is not in anaconda but in either efibootmgr / kernel.
Comment 24 Mads Kiilerich 2012-12-03 15:58:26 EST
A new efibootmgr that doesn't crash would prevent this issue, but it would be nice if anaconda also was more resilient. A failing efibootmgr is not fatally fatal. It is usually possible to boot the system anyway ... but it become much harder when the installer crashes before creating grub.cfg.

A failing efibootmgr invocation should IMO only cause a heavy warning.
Comment 25 Dale Macartney 2012-12-12 08:10:17 EST
Error encountered whilst trying to install Fedora 18 Beta (x86_64) DVD. Error occurs whilst booting natively and EFI boot options from DVD, but also after booting DVD via rEFIT

Package: anaconda-18.29.2
OS Release: Fedora release 18-Beta

Note You need to log in before you can comment on or make changes to this bug.