Bug 880143 - BootLoaderError: failed to remove old efi boot entry
Summary: BootLoaderError: failed to remove old efi boot entry
Keywords:
Status: CLOSED DUPLICATE of bug 873629
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e347d95262719d2d1c731e59872...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-26 11:06 UTC by Alex Murray
Modified: 2012-11-27 13:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-27 13:00:33 UTC


Attachments (Terms of Use)
File: anaconda-tb (1.07 MB, text/plain)
2012-11-26 11:06 UTC, Alex Murray
no flags Details
File: environ (887 bytes, text/plain)
2012-11-26 11:06 UTC, Alex Murray
no flags Details
File: type (9 bytes, text/plain)
2012-11-26 11:06 UTC, Alex Murray
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-26 11:06 UTC, Alex Murray
no flags Details
File: storage.log (433.60 KB, text/plain)
2012-11-26 11:06 UTC, Alex Murray
no flags Details
File: version (2 bytes, text/plain)
2012-11-26 11:06 UTC, Alex Murray
no flags Details
File: program.log (211.12 KB, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: executable (14 bytes, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: product (6 bytes, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: anaconda.log (11.89 KB, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: packaging.log (142 bytes, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: cmdline_file (106 bytes, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: release (33 bytes, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: messages (283.40 KB, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details
File: other involved packages (32 bytes, text/plain)
2012-11-26 11:07 UTC, Alex Murray
no flags Details

Description Alex Murray 2012-11-26 11:06:17 UTC
Description of problem:
Tried installing F18 Beta RC1 on new Macbook Pro 9,1 with automatic partitioning and LVM

Version-Release number of selected component:
anaconda-18.29.2-1.fc18.x86_64

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.29.2 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1639, in remove_efi_boot_target
:    raise BootLoaderError("failed to remove old efi boot entry")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1668, in install
:    self.remove_efi_boot_target()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1704, in install
:    super(MacEFIGRUB, self).install()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1688, in write
:    self.install()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2310, in writeBootLoader
:    storage.bootloader.write()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 134, in doInstall
:    writeBootLoader(storage, payload, instClass)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:BootLoaderError: failed to remove old efi boot entry

Comment 1 Alex Murray 2012-11-26 11:06:39 UTC
Created attachment 651881 [details]
File: anaconda-tb

Comment 2 Alex Murray 2012-11-26 11:06:41 UTC
Created attachment 651882 [details]
File: environ

Comment 3 Alex Murray 2012-11-26 11:06:44 UTC
Created attachment 651883 [details]
File: type

Comment 4 Alex Murray 2012-11-26 11:06:48 UTC
Created attachment 651884 [details]
File: ifcfg.log

Comment 5 Alex Murray 2012-11-26 11:06:56 UTC
Created attachment 651885 [details]
File: storage.log

Comment 6 Alex Murray 2012-11-26 11:06:58 UTC
Created attachment 651886 [details]
File: version

Comment 7 Alex Murray 2012-11-26 11:07:03 UTC
Created attachment 651887 [details]
File: program.log

Comment 8 Alex Murray 2012-11-26 11:07:05 UTC
Created attachment 651888 [details]
File: executable

Comment 9 Alex Murray 2012-11-26 11:07:07 UTC
Created attachment 651889 [details]
File: product

Comment 10 Alex Murray 2012-11-26 11:07:10 UTC
Created attachment 651890 [details]
File: anaconda.log

Comment 11 Alex Murray 2012-11-26 11:07:13 UTC
Created attachment 651891 [details]
File: hashmarkername

Comment 12 Alex Murray 2012-11-26 11:07:15 UTC
Created attachment 651892 [details]
File: packaging.log

Comment 13 Alex Murray 2012-11-26 11:07:17 UTC
Created attachment 651893 [details]
File: cmdline_file

Comment 14 Alex Murray 2012-11-26 11:07:20 UTC
Created attachment 651894 [details]
File: release

Comment 15 Alex Murray 2012-11-26 11:07:26 UTC
Created attachment 651895 [details]
File: messages

Comment 16 Alex Murray 2012-11-26 11:07:29 UTC
Created attachment 651896 [details]
File: other involved packages

Comment 17 Alex Murray 2012-11-27 03:17:34 UTC
Between this bug and bug #866028 I am unable to successfully install F18 Beta RC1 on this machine - also it seems strange that the first time I tried installing I got but #866028 but then a second try and I got this one instead - shouldn't it be deterministic and fail the same in both cases? Since in both cases I chose to use Automatic Partitioning with LVM and to create space by deleting some existing partitions... Will try a non-LVM (aka raw ext4 partitions) install tonight and see if that works any better.

Comment 18 Alex Murray 2012-11-27 03:49:05 UTC
Actually looks more like an invalid EFI boot table entry problem - like in bug #873629 - will see if perhaps resetting the NVRAM fixes it...

Comment 19 Alex Murray 2012-11-27 10:16:03 UTC
Resetting the NVRAM + PRAM didn't help in my case... so either Apple's EFI Firmware does have invalid variables in it OR the latest kernel's are flagging valid variables as invalid...

Comment 20 Alex Murray 2012-11-27 13:00:14 UTC
Am duping this against bug #873629 since it looks like the problem is in efibootmgr / kernel not anaconda.

Comment 21 Alex Murray 2012-11-27 13:00:33 UTC

*** This bug has been marked as a duplicate of bug 873629 ***


Note You need to log in before you can comment on or make changes to this bug.