Bug 866057 - firefox 16.0.1 missing dependency nspr >=4.9.2
firefox 16.0.1 missing dependency nspr >=4.9.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 866081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 10:20 EDT by rmknox
Modified: 2013-01-22 15:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:01:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rmknox 2012-10-13 10:20:53 EDT
Description of problem: firefox wont start

[knox@knox ~]$ firefox
/usr/lib/firefox/firefox: symbol lookup error: /usr/lib/xulrunner/libxul.so: undefined symbol: PR_SetCurrentThreadName
[knox@knox ~]$ 

Version-Release number of selected component (if applicable):
firefox.i686    16.0.1-1.fc16        @updates
kernel linux 3.4.11-1.fc16.i686

How reproducible:
100%
Steps to Reproduce:
1.if i start from graphical environment it does not start
2.if i start from command line it gives message above
3.
  
Actual results:


Expected results:


Additional info:
I preupgraded from f14 to f16 a few weeks ago
ever since firefox has been erratic - hangs - either forever or for long times
now it wont start
i used yum to reinstall firefox - still wont start
appears that /usr/lib/xulrunner/libxul.so may be damaged?
maybe firefox overwrote it?
when i use readelf it shows the desired entry in the symbol table - maybe it has been corrupted?

[knox@knox ~]$ readelf -es /usr/lib/xulrunner/libxul.so | grep PR_S
    27: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetPollableEvent
   114: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_Sleep
   329: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetError
   745: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetEnv
   858: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetCurrentThreadName
  1278: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetThreadPrivate
  1337: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_Seek64
  1434: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetFDInheritable
  1483: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_Seek
  1783: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetSocketOption
  2030: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_StringToNetAddr
  2332: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SecondsToInterval
  2335: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetNetAddr
  2758: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_SetThreadPriority
  2782: 00000000     0 FUNC    GLOBAL DEFAULT  UND PR_Sync
I would use yum to reinstall the correct part of the X windows system but I dont know what to reinstall

I have a copy of libxul.so on my last weekly full disk backup
I could get it and replace the current file - but am a bit cautious about doing this

In any case I will use chrome and/or seamonkey when I want to go onto the web

If you can tell me what to reinstall i could use yum to reinstall whatever larger package contains libxul.so - on the theory that firefox may have corrupted it

all other programs seem to run  ok except for thunderbird - for which i have a bug report on file
Comment 1 udo 2012-10-13 13:46:54 EDT
Updating FireFox and xulrunner to latest did not help but gave a similar error for FF as well. :-/
Comment 2 udo 2012-10-13 13:56:24 EDT
Also we get a downgrade to FF 12 so that is not so nice either when we came from FF 15.
Comment 3 udo 2012-10-13 13:59:55 EDT
Same for thunderbird.
Who designed this?
We can't even simply downgrade one version. :-/
Comment 4 udo 2012-10-13 14:09:06 EDT
Updating nspr as well helps.
Comment 5 rmknox 2012-10-13 17:39:41 EDT
the following may not be important - but since i don't know

1- back in the day - a sysgen tailored to a specific config. When i ran the pre ugrade from f14 to f16 i did on a lesser machine than i am running now. did it on a pent 4 1 gb with rage pci vga card. am now on a duo cpu e4500@2,2 ghz with a pcie nvidia adapter and associated driver. did so in the belief that modern op sys tailors itself to the machine at boot time (within limits).

2 - after the upgrade (~ 2wks ago) ff worked - but experienced delays (so does thunderbird ) . a day or so ago i changed the video cable from a vga cable to a dvi - d single. screen is so much better now - i didn't realize how much the flat panel screens need the dvi cable.  the next time i booted  i had the ff prob. i then went back to the vga cable - still had the problem. assumed it was  coincidence - but when you assume you ... i have a dvi-d dual cable on order - will report if it changes things
Comment 6 Elad Alfassa 2012-10-14 05:34:45 EDT
*** Bug 866081 has been marked as a duplicate of this bug. ***
Comment 7 Elad Alfassa 2012-10-14 05:35:28 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Michael Ben-Gershon 2012-10-14 13:55:30 EDT
(In reply to comment #4)
> Updating nspr as well helps.

I have tried that, but I still get the same error when starting firefox. I definitely have the latest version of nspr installed:

Linux-mybg (15:54) > rpm -qa firefox xulrunner nspr
nspr-4.9.2-1.fc16.x86_64
nspr-4.9.2-1.fc16.i686
xulrunner-16.0.1-1.fc16.x86_64
firefox-16.0.1-1.fc16.x86_64
Comment 9 udo 2012-10-14 13:57:51 EDT
`ldconfig -v|grep nspr` output?
Comment 10 Michael Ben-Gershon 2012-10-14 15:13:14 EDT
(In reply to comment #9)
> `ldconfig -v|grep nspr` output?

Linux-root (21:11) /home/mybg # ldconfig -v | grep nspr
	libnspr4.so -> libnspr4.so
	libnspr4.so -> libnspr4.so
Comment 11 udo 2012-10-15 00:42:10 EDT
That looks good, the nspr files ar found.
What is the error if you start firefox frrom a terminal?
Same as before?
Comment 12 Michael Ben-Gershon 2012-10-15 03:14:41 EDT
Yes:

/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/xulrunner/libxul.so: undefined symbol: PR_SetCurrentThreadName
Comment 13 Fedora Update System 2012-10-16 09:47:44 EDT
xulrunner-16.0.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-16.0.1-2.fc17
Comment 14 Fedora Update System 2012-10-16 09:48:05 EDT
xulrunner-16.0.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-16.0.1-2.fc18
Comment 15 Fedora Update System 2012-10-16 09:48:27 EDT
xulrunner-16.0.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xulrunner-16.0.1-2.fc16
Comment 16 Fedora Update System 2012-10-16 13:39:58 EDT
Package xulrunner-16.0.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xulrunner-16.0.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16209/xulrunner-16.0.1-2.fc18
then log in and leave karma (feedback).
Comment 17 rmknox 2012-10-16 15:39:15 EDT
will do
Comment 18 rmknox 2012-10-21 09:48:44 EDT
No package xulrunner-16.0.1-2.fc18 available.
Comment 19 Elad Alfassa 2012-10-21 10:02:58 EDT
(In reply to comment #18)
> No package xulrunner-16.0.1-2.fc18 available.

You are running Fedora 16, and trying to follow the Fedora 18 instructions.

su -c 'yum update --enablerepo=updates-testing xulrunner-16.0.1-2.fc16'

is what you should run.
Comment 20 rmknox 2012-10-21 23:25:38 EDT
#! /bin/bash
sudo yum update --enablerepo=updates-testing xulrunner-16.0.1-2.fc18

is what I ran per the directions dated 10-16
Comment 21 rmknox 2012-10-22 15:20:21 EDT
...fc16 worked - thanks
Comment 22 rmknox 2012-10-22 15:24:32 EDT
went to other site to add karma - not at all clear how to do so - I tried but it did not show up
Comment 23 Michael Ben-Gershon 2012-10-24 06:04:41 EDT
xulrunner-16.0.1-2.fc16 did not help on my system!
Comment 24 Fedora Update System 2012-12-14 08:15:24 EST
xulrunner-17.0.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-3.fc18
Comment 25 Fedora Update System 2012-12-14 08:15:53 EST
xulrunner-17.0.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-2.fc16
Comment 26 Fedora Update System 2012-12-14 08:16:16 EST
xulrunner-17.0.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-3.fc17
Comment 27 Fedora Update System 2012-12-20 11:01:15 EST
xulrunner-16.0.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2013-01-05 01:58:11 EST
xulrunner-17.0.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2013-01-11 19:22:09 EST
xulrunner-17.0.1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.