Bug 866115 - ValueError: ('invalid size specification', '0 b')
ValueError: ('invalid size specification', '0 b')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:1fad293eff01a7e66ed77310ec5...
:
: 865900 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Betappc
  Show dependency treegraph
 
Reported: 2012-10-14 00:19 EDT by Clyde E. Kunkel
Modified: 2012-10-24 23:41 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 23:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (155.07 KB, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: product (6 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: type (9 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: storage.log (38.97 KB, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: version (11 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: environ (764 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: anaconda.log (3.63 KB, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: syslog (62.59 KB, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: cmdline_file (116 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: release (24 bytes, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details
File: program.log (18.10 KB, text/plain)
2012-10-14 00:19 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2012-10-14 00:19:08 EDT
Description of problem:
VM with virtual disk /dev/sdg3 used with previous RCs.  Clicked continue in device section screen and error...

Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 99, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 117, in size_str
:    return str(Size(spec=spec)).upper()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 157, in _set_free_space_labels
:    disk_free_text = size_str(disk_free)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 237, in refresh
:    self._set_free_space_labels(disks_size, disk_free, fs_free)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 627, in on_continue_clicked
:    dialog.refresh(required_space, disks_size, disk_free, fs_free, self.autopart)
:ValueError: ('invalid size specification', '0 b')
Comment 1 Clyde E. Kunkel 2012-10-14 00:19:11 EDT
Created attachment 626781 [details]
File: anaconda-tb
Comment 2 Clyde E. Kunkel 2012-10-14 00:19:12 EDT
Created attachment 626782 [details]
File: product
Comment 3 Clyde E. Kunkel 2012-10-14 00:19:14 EDT
Created attachment 626783 [details]
File: type
Comment 4 Clyde E. Kunkel 2012-10-14 00:19:15 EDT
Created attachment 626784 [details]
File: ifcfg.log
Comment 5 Clyde E. Kunkel 2012-10-14 00:19:17 EDT
Created attachment 626785 [details]
File: storage.log
Comment 6 Clyde E. Kunkel 2012-10-14 00:19:18 EDT
Created attachment 626786 [details]
File: version
Comment 7 Clyde E. Kunkel 2012-10-14 00:19:20 EDT
Created attachment 626787 [details]
File: environ
Comment 8 Clyde E. Kunkel 2012-10-14 00:19:22 EDT
Created attachment 626788 [details]
File: anaconda.log
Comment 9 Clyde E. Kunkel 2012-10-14 00:19:23 EDT
Created attachment 626789 [details]
File: syslog
Comment 10 Clyde E. Kunkel 2012-10-14 00:19:26 EDT
Created attachment 626790 [details]
File: hashmarkername
Comment 11 Clyde E. Kunkel 2012-10-14 00:19:27 EDT
Created attachment 626791 [details]
File: packaging.log
Comment 12 Clyde E. Kunkel 2012-10-14 00:19:29 EDT
Created attachment 626792 [details]
File: cmdline_file
Comment 13 Clyde E. Kunkel 2012-10-14 00:19:31 EDT
Created attachment 626793 [details]
File: release
Comment 14 Clyde E. Kunkel 2012-10-14 00:19:32 EDT
Created attachment 626794 [details]
File: program.log
Comment 15 Daniel Belton 2012-10-14 22:28:29 EDT
clicked on drive to install Fedora 18 to, then clicked continue

Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 16 Daniel Belton 2012-10-14 22:34:05 EDT
Started installer, clicked on the install language, clicked continue. Selected the partitioning spoke, selected drive to install to, then clicked continue, then the nice box comes up "Unknown error has occurred"

Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 17 Jan Sedlák 2012-10-15 08:06:54 EDT
Tried to install F18 from Live desktop onto newly created Virtual machine (2048 MB RAM, 16 GB HDD, no filesystem or whavever). Anaconda started and this error message poped out.

Package: anaconda-18.16-1.fc18.x86_64
OS Release: Fedora release 18
Comment 18 Jan Sedlák 2012-10-15 08:13:56 EDT
It hadn't appeared while anaconda started - I have selected my disk in Partition spoke, clicked on "continue" and THEN it happened.
Comment 19 Kamil Páral 2012-10-15 08:23:27 EDT
Proposing as Beta blocker:
 The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data 
https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria
Comment 20 Adam Williamson 2012-10-15 11:47:13 EDT
Discussed at 2012-10-15 QA meeting acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-10-15/fedora-qa.2012-10-15-15.00.log.txt . Accepted as a blocker per criterion cited in comment #19.
Comment 21 Chris Lumens 2012-10-15 16:14:34 EDT
I broke it, I bought it.
Comment 22 Chris Lumens 2012-10-15 16:27:36 EDT
Does updates=http://clumens.fedorapeople.org/866115.img fix this?
Comment 23 Jesse Keating 2012-10-15 16:38:44 EDT
*** Bug 865900 has been marked as a duplicate of this bug. ***
Comment 24 Clyde E. Kunkel 2012-10-15 21:10:32 EDT
(In reply to comment #22)
> Does updates=http://clumens.fedorapeople.org/866115.img fix this?

Fixes for me.  Thanks.
Comment 25 Daniel Belton 2012-10-15 23:44:56 EDT
(In reply to comment #22)
> Does updates=http://clumens.fedorapeople.org/866115.img fix this?

Fixes it here on my system as well.
Comment 26 satellitgo 2012-10-16 17:17:33 EDT
try to format EFI formatted l i t d USB

Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 27 satellitgo 2012-10-16 17:24:14 EDT
(In reply to comment #26)
> try to format dd USB iso 9660 fs
> 
> Package: anaconda-18.16
> OS Release: Fedora release 18-Beta-TC4
Comment 28 satellitgo 2012-10-16 17:31:20 EDT
3.6 GB USB with EFI Guid Partition fat 32 subpartiton happens when try to reclaim space page continue button is clicked

Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 29 Adam Williamson 2012-10-17 14:38:18 EDT
Discussed at 2012-10-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-17/f18beta-blocker-review-4.2012-10-17-16.00.log.txt . anaconda team, this is another commonly-hit bug for testers, it'd be great to get this reviewed and applied ASAP. thanks!
Comment 30 Petr Schindler 2012-10-18 09:20:02 EDT
1. In main hub I chose Instalation destination
2. without choosing anything I clicked on 'Done"
3. It shows then that 'No disk is selected'. I clicked on Instalation destination again. 
4. I chose disk and click on continue. 
5. Bug appeared


Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 31 Adam Williamson 2012-10-22 20:54:37 EDT
Chris, is this MODIFIED for 18.19 or 18.20? You didn't set fixed in version. thanks!
Comment 32 Adam Williamson 2012-10-24 14:32:39 EDT
Discussed at the 2012-10-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-24/f18beta-blocker-review-5.2012-10-24-16.01.log.txt .

AFAICS the fix for this is http://git.fedorahosted.org/cgit/anaconda.git/commit/pyanaconda/storage/size.py?id=7063bcc931f35f23f7d56fc30181aae9d37a2782 , committed 2012-10-16. That was actually prior to 18.17 being built, so it should be fixed in TC5 and TC6. Can anyone who could reproduce this please re-test with TC6 and verify that it's fixed? If so, this bug could be closed.
Comment 33 Clyde E. Kunkel 2012-10-24 23:19:20 EDT
Yes, it is fixed.  Closing since I reported it.
Comment 34 Adam Williamson 2012-10-24 23:41:04 EDT
Thanks Clyde!

Note You need to log in before you can comment on or make changes to this bug.