Bug 866120 - Brightness keys stop working when kernel boots after grub
Brightness keys stop working when kernel boots after grub
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 02:08 EDT by Jacek Pliszka
Modified: 2013-03-14 02:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 08:19:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jacek Pliszka 2012-10-14 02:08:16 EDT
Description of problem:

Brightness keys work when grub menu is displayed at the beginning of the boot.
After that they stop working and brightness stays as set at the boot menu. In gnome pressing them shows window with increasing/decreasing brightness but the actual screen brightness stays the same.

I can change the value of /sys/class/backlight/acpi_video0/brightness
but the actual screen brightness does not change.


Version-Release number of selected component (if applicable):

kernel 3.6.1-1.fc17.x86_64
xorg-x11-drv-nouveau-0.0.16-37.20120306gitf5d1cd2.fc17.x86_64

How reproducible:

Always

Steps to Reproduce:
1. press brighness keys fn+F9/F10
2. 
3.
  
Actual results:

Window with brightness bar shows and the brightness bar does change
while the actual brightness does not.

Expected results:

The actual screen brightness changes.

Additional info:

HP Elitebook 8560w, nouveau driver,GF106 [Quadro 2000M] graphics
Comment 1 xapeiron 2012-11-01 10:20:01 EDT
After updating kernel to 3.6.3 I have same problem with brightness settings.

--
kernel 3.6.3-1.fc17.x86_64
xorg-x11-drv-nvidia-304.60-1.fc17

--
Additional info:

Dell XPSM1330, nvidia driver, GeForce8400M GS graphics
Comment 2 Josh Boyer 2013-03-12 15:16:38 EDT
Are you still seeing this with 3.7.9 or 3.8.2 in updates-testing?
Comment 3 Jacek Pliszka 2013-03-12 19:29:35 EDT
I don't see it with 3.7.9 and nvidia drivers keys work fine.

Haven't checked nouveau though.
Comment 4 Sentiono Leowinata 2013-03-13 05:13:58 EDT
Linux sentiono 3.8.2-206.fc18.x86_64 #1 SMP Fri Mar 8 15:03:34 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Even I upgraded to latest kernel, the brightness keys do not work. They showed on screen that the bar changes. However, actual brightness does not change at all.

I monitored this screen brightness issue since F18 first release and was informed that this will be fixed in 3.8.x .. but now after 2 updates on kernel 3.8.x (3.8.1-201 and 3.8.2-206), it still does not work.

Acer Travelmate 8481TG, Optimus, GT520M 1Gb and Intel.
Comment 5 Josh Boyer 2013-03-13 08:19:47 EDT
Jacek, thanks for letting us know.

Sentiono, please open a new bug in f18 for your issue.
Comment 6 Sentiono Leowinata 2013-03-14 02:37:33 EDT
Did reported on Bug 891148 - backlight brightness adjusting does not work 

Thanks.

Note You need to log in before you can comment on or make changes to this bug.