Bug 866274 - cannot register to SAM using activationkey
cannot register to SAM using activationkey
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks: 867042 867043
  Show dependency treegraph
 
Reported: 2012-10-14 21:20 EDT by Mike Burns
Modified: 2013-08-20 12:37 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Bug Fix
Doc Text:
Previously, registering the Red Hat Enterprise Virtualization Hypervisor system to Subscription Asset Manager (SAM) constantly failed due to a missing organisation option. The option to specify an organisation when registering to SAM has been added in this fix but is only supported in auto-installation.
Story Points: ---
Clone Of:
: 867042 (view as bug list)
Environment:
Last Closed: 2013-02-28 11:33:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0556 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2013-02-28 16:29:06 EST

  None (edit)
Description Mike Burns 2012-10-14 21:20:30 EDT
Description of problem:
Currently, registering to SAM via activation key does not work due to a missing org option.

Version-Release number of selected component (if applicable):
ovirt-node-2.5.0-6.el6

How reproducible:
Always

Steps to Reproduce:
1.autoinstall with rhn_type=sam rhn_url=XXXX rhn_ca_cert=XXXX rhn_activationkey=XXXX
2.
3.
  
Actual results:
RHN reg fails due to missing --org option

Expected results:
able to install

Additional info:
Comment 1 Mike Burns 2012-10-14 21:32:57 EDT
http://gerrit.ovirt.org/8539
Comment 6 haiyang,dong 2012-10-28 23:33:44 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

Tried:
autoinstall with rhn_type=sam rhn_url=XXXX rhn_ca_cert=XXXX rhn_org=ACME_Corporation rhn_activationkey=XXXX

Autoinstall rhev-h and register to SAM using activationkey success,

so this bug has been fixed
Comment 8 errata-xmlrpc 2013-02-28 11:33:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.