Bug 866309 - firefox doesn't start
firefox doesn't start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 00:53 EDT by Ravindu
Modified: 2013-01-12 09:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 05:12:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravindu 2012-10-15 00:53:55 EDT
Description of problem:
  firefox doesn't start ,gives the error
 /usr/lib/firefox/firefox: symbol lookup error: /usr/lib/xulrunner/libxul.so: undefined symbol: PR_SetCurrentThreadName


Version-Release number of selected component (if applicable):16


How reproducible:every time


Steps to Reproduce:
1.open firefox
Comment 1 Fedora Update System 2012-10-16 09:47:38 EDT
xulrunner-16.0.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-16.0.1-2.fc17
Comment 2 Fedora Update System 2012-10-16 09:47:56 EDT
xulrunner-16.0.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-16.0.1-2.fc18
Comment 3 Fedora Update System 2012-10-16 09:48:19 EDT
xulrunner-16.0.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xulrunner-16.0.1-2.fc16
Comment 4 Fedora Update System 2012-10-16 13:39:50 EDT
Package xulrunner-16.0.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xulrunner-16.0.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16209/xulrunner-16.0.1-2.fc18
then log in and leave karma (feedback).
Comment 5 Dean 2012-10-18 09:21:13 EDT
I have updated the xulrunner-16.0.1-2.fc17.i686 but still get the error message "/usr/lib/firefox/firefox: symbol lookup error: /usr/lib/xulrunner/libxul.so: undefined symbol: PR_SetCurrentThreadName" from the terminal.

xulrunner.i686                  16.0.1-2.fc17                   @updates-testing
firefox.i686                    16.0.1-1.fc17                   @updates
Fedora release 17 (Beefy Miracle)
Comment 6 Martin Stransky 2012-10-18 09:44:17 EDT
Please attach output of:

$ldd /usr/lib/firefox/firefox
$ldd /usr/lib/xulrunner/libxul.so
$rpm -q nss nspr
Comment 7 Dean 2012-10-18 09:56:18 EDT
As requested

ldd /usr/lib/firefox/firefox
	linux-gate.so.1 =>  (0xb7793000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x418e2000)
	libvpx.so.1 => /lib/libvpx.so.1 (0x429bb000)
	libdl.so.2 => /lib/libdl.so.2 (0x418db000)
	librt.so.1 => /lib/librt.so.1 (0x4192b000)
	libstdc++.so.6 => /lib/libstdc++.so.6 (0x41e7a000)
	libm.so.6 => /lib/libm.so.6 (0x418fe000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x41c96000)
	libc.so.6 => /lib/libc.so.6 (0x41727000)
	/lib/ld-linux.so.2 (0x41704000)

ldd /usr/lib/xulrunner/libxul.so
	linux-gate.so.1 =>  (0xb77f4000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xb5e7d000)
	libmozjs.so => /usr/lib/xulrunner/libmozjs.so (0xb5ad5000)
	libssl3.so => /lib/libssl3.so (0xb5a9a000)
	libsmime3.so => /lib/libsmime3.so (0xb5a6e000)
	libnss3.so => /lib/libnss3.so (0xb592a000)
	libnssutil3.so => /lib/libnssutil3.so (0xb590b000)
	libXrender.so.1 => /lib/libXrender.so.1 (0xb5901000)
	libfreetype.so.6 => /lib/libfreetype.so.6 (0xb5861000)
	libfontconfig.so.1 => /lib/libfontconfig.so.1 (0xb582c000)
	libmozsqlite3.so => /usr/lib/xulrunner/libmozsqlite3.so (0xb57a3000)
	libjpeg.so.62 => /lib/libjpeg.so.62 (0xb574c000)
	libz.so.1 => /lib/libz.so.1 (0xb5736000)
	libhunspell-1.3.so.0 => /lib/libhunspell-1.3.so.0 (0xb56d0000)
	libasound.so.2 => /lib/libasound.so.2 (0xb55ea000)
	librt.so.1 => /lib/librt.so.1 (0xb55e1000)
	libplds4.so => /lib/libplds4.so (0xb55db000)
	libplc4.so => /lib/libplc4.so (0xb55d5000)
	libnspr4.so => /lib/libnspr4.so (0xb5598000)
	libmozalloc.so => /usr/lib/xulrunner/libmozalloc.so (0xb5595000)
	libdbus-glib-1.so.2 => /lib/libdbus-glib-1.so.2 (0xb556f000)
	libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xb5525000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0xb54d5000)
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb53ad000)
	libX11.so.6 => /lib/libX11.so.6 (0xb5275000)
	libXext.so.6 => /lib/libXext.so.6 (0xb5263000)
	libpangoft2-1.0.so.0 => /lib/libpangoft2-1.0.so.0 (0xb5233000)
	libpangocairo-1.0.so.0 => /lib/libpangocairo-1.0.so.0 (0xb5225000)
	libpango-1.0.so.0 => /lib/libpango-1.0.so.0 (0xb51db000)
	libcairo.so.2 => /lib/libcairo.so.2 (0xb5122000)
	libgtk-x11-2.0.so.0 => /lib/libgtk-x11-2.0.so.0 (0xb4c79000)
	libatk-1.0.so.0 => /lib/libatk-1.0.so.0 (0xb4c58000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0xb4b01000)
	libgdk-x11-2.0.so.0 => /lib/libgdk-x11-2.0.so.0 (0xb4a43000)
	libgdk_pixbuf-2.0.so.0 => /lib/libgdk_pixbuf-2.0.so.0 (0xb4a1e000)
	libXt.so.6 => /lib/libXt.so.6 (0xb49bf000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0xb49bc000)
	libstartup-notification-1.so.0 => /lib/libstartup-notification-1.so.0 (0xb49b1000)
	libvpx.so.1 => /lib/libvpx.so.1 (0xb492e000)
	libdl.so.2 => /lib/libdl.so.2 (0xb4929000)
	libstdc++.so.6 => /lib/libstdc++.so.6 (0xb483d000)
	libm.so.6 => /lib/libm.so.6 (0xb4812000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb47f5000)
	libc.so.6 => /lib/libc.so.6 (0xb4643000)
	/lib/ld-linux.so.2 (0x41704000)
	libexpat.so.1 => /lib/libexpat.so.1 (0xb4619000)
	libffi.so.5 => /lib/libffi.so.5 (0xb4611000)
	libxcb.so.1 => /lib/libxcb.so.1 (0xb45ef000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0xb45ea000)
	libpixman-1.so.0 => /lib/libpixman-1.so.0 (0xb454f000)
	libpng15.so.15 => /lib/libpng15.so.15 (0xb4522000)
	libXfixes.so.3 => /lib/libXfixes.so.3 (0xb451c000)
	libselinux.so.1 => /lib/libselinux.so.1 (0xb44fa000)
	libresolv.so.2 => /lib/libresolv.so.2 (0xb44e1000)
	libXinerama.so.1 => /lib/libXinerama.so.1 (0xb44dc000)
	libXi.so.6 => /lib/libXi.so.6 (0xb44cc000)
	libXrandr.so.2 => /lib/libXrandr.so.2 (0xb44c3000)
	libXcursor.so.1 => /lib/libXcursor.so.1 (0xb44b8000)
	libXcomposite.so.1 => /lib/libXcomposite.so.1 (0xb44b4000)
	libXdamage.so.1 => /lib/libXdamage.so.1 (0xb44b0000)
	libSM.so.6 => /lib/libSM.so.6 (0xb44a6000)
	libICE.so.6 => /lib/libICE.so.6 (0xb448c000)
	libxcb-util.so.0 => /lib/libxcb-util.so.0 (0xb4485000)
	libX11-xcb.so.1 => /lib/libX11-xcb.so.1 (0xb4482000)
	libXau.so.6 => /lib/libXau.so.6 (0xb447e000)
	libuuid.so.1 => /lib/libuuid.so.1 (0xb4477000)

rpm -q nss nspr
nss-3.13.5-1.fc17.i686
nspr-4.9.2-1.fc17.i686
Comment 8 Martin Stransky 2012-10-19 03:59:32 EDT
And what does say:

$nm -D /lib/libnspr4.so | grep "SetCurrentThreadName"
Comment 9 Dean 2012-10-19 04:21:08 EDT
42b048d0 T PR_SetCurrentThreadName
Comment 10 Martin Stransky 2012-10-19 04:32:50 EDT
Hm, I have no idea why it fails to start, you clearly have right library with the missing symbol inside.

You can regenrate your ld cache:

#ldconfig

and you also can debug ld.so dynamic linker:

$export LD_DEBUG=all
$export LD_DEBUG_OUTPUT=some_file.txt
$firefox 

and investigate the created files for the PR_SetCurrentThreadName symbol.
Comment 11 Ravindu 2012-10-20 12:04:34 EDT
i downloaded firefox from  http://www.mozilla.org/en-US/firefox/new/  and that worked fine ,only the firefox provided with yum fails to start , so i don't think its a problem with xulrunner
Comment 12 Martin Stransky 2012-10-22 03:08:18 EDT
It's because we ship binary parts of firefox in xulrunner package. And does the xulrunner start for you?
Comment 13 Dean 2012-10-22 06:38:56 EDT
I can also get the downloaded firefox to work fine, its only the yum firefox that fails. I don't have any other issues, thunderbird and all works fine.
Comment 14 Ravindu 2012-10-23 04:02:42 EDT
yep xulrunner starts
Comment 15 Martin Stransky 2012-10-30 07:50:36 EDT
Please test the new update at https://admin.fedoraproject.org/updates/FEDORA-2012-17028/firefox-16.0.2-1.fc17,xulrunner-16.0.2-1.fc17 and if it does not help please provide the logs from comment 10.
Comment 16 Dean 2012-10-30 17:03:27 EDT
It still did not work.. I will email you direct with the log files created.
Comment 17 Martin Stransky 2012-10-31 08:10:27 EDT
Yes, it's because you have an old nspr in your firefox folder (/usr/lib/firefox) - probably from your mozilla binary tarball. Uninstall the firefox package, remove /usr/lib/firefox directory and install the firefox again.
Comment 18 Dean 2012-11-02 10:34:21 EDT
Thanks, that worked. Strange I did not install the tarball version until after the fedora one stopped working. Thanks.
Comment 19 Ravindu 2012-11-03 10:30:52 EDT
deleted every thing in /usr/lib/firefox and extracted the firefox tar.bz2 to it,every thing is working perfect now :)
Comment 20 Martin Stransky 2012-11-06 05:12:04 EST
Okay, closing.
Comment 21 Fedora Update System 2012-12-14 08:15:15 EST
xulrunner-17.0.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-3.fc18
Comment 22 Fedora Update System 2012-12-14 08:15:47 EST
xulrunner-17.0.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-2.fc16
Comment 23 Fedora Update System 2012-12-14 08:16:11 EST
xulrunner-17.0.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-3.fc17
Comment 24 Fedora Update System 2013-01-05 01:58:00 EST
xulrunner-17.0.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2013-01-11 19:21:59 EST
xulrunner-17.0.1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.