Bug 866367 - Cannot change settings in control-center as root
Cannot change settings in control-center as root
Status: CLOSED DUPLICATE of bug 865530
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 04:20 EDT by Honza Horak
Modified: 2012-10-15 04:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 04:47:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2012-10-15 04:20:25 EDT
Description of problem:
I was following setup steps in 
https://fedoraproject.org/wiki/QA:Testcase_Power_Management_tuned_off_idle

In "gnome-control-center screen" run as *root* I tried to un-check "Dim screen to save power" or change "Lock screen after" and always got error message into console:

** (gnome-control-center:3556): WARNING **: failed to commit changes to dconf: The connection is closed

Version-Release number of selected component (if applicable):
control-center-3.6.1-1.fc18.x86_64

How reproducible:
every-time

Steps to Reproduce:
1. run gnome-control-center screen from console as root
2. try to un-check "Dim screen to save power" or change "Lock screen after"
  
Actual results:
error messages in console and options are unable to be changed.

Expected results:
options are able to be changed

Additional info:
It works fine when doing it as ordinary user.
Comment 1 Honza Horak 2012-10-15 04:21:30 EDT
$ rpm -q gnome-settings-daemon
gnome-settings-daemon-3.6.1-2.fc18.x86_64
Comment 2 Bastien Nocera 2012-10-15 04:47:04 EDT
Don't run gnome-control-center as root. Don't run your session as root.

*** This bug has been marked as a duplicate of bug 865530 ***

Note You need to log in before you can comment on or make changes to this bug.