This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 866441 - TypeError: 'NoneType' object is not iterable
TypeError: 'NoneType' object is not iterable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-meh (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-15 07:32 EDT by Kamil Páral
Modified: 2012-11-09 07:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-09 07:42:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
traceback screenshot (14.34 KB, image/png)
2012-10-15 07:32 EDT, Kamil Páral
no flags Details
anaconda.log (2.09 KB, text/plain)
2012-10-15 07:33 EDT, Kamil Páral
no flags Details
anaconda-yum.conf (325 bytes, text/plain)
2012-10-15 07:33 EDT, Kamil Páral
no flags Details
ifcfg.log (641 bytes, text/plain)
2012-10-15 07:33 EDT, Kamil Páral
no flags Details
packaging.log (1.19 KB, text/plain)
2012-10-15 07:33 EDT, Kamil Páral
no flags Details
program.log (31.25 KB, text/plain)
2012-10-15 07:33 EDT, Kamil Páral
no flags Details
storage.log (53.78 KB, text/plain)
2012-10-15 07:33 EDT, Kamil Páral
no flags Details
syslog (72.45 KB, text/plain)
2012-10-15 07:33 EDT, Kamil Páral
no flags Details
X.log (55.62 KB, text/plain)
2012-10-15 07:34 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-10-15 07:32:33 EDT
Created attachment 627337 [details]
traceback screenshot

Description of problem:
I saw this once on a primary anaconda console (see screenshot). Anaconda-tb-* file was created, but it is empty (related or another problem?). The problem was NOT reported by integrated exception reported, I saw it accidentally. If I hadn't been looking at tty1, I wouldn't have known about it (I haven't tried to actually start the installation, so I don't know whether it would have succeeded or not).

Version-Release number of selected component (if applicable):
F18 Beta TC4 DVD i386
anaconda 18.16

How reproducible:
scarcely

Steps to Reproduce:
1. boot DVD
2. look at tty1
Comment 1 Kamil Páral 2012-10-15 07:33:38 EDT
Created attachment 627338 [details]
anaconda.log
Comment 2 Kamil Páral 2012-10-15 07:33:41 EDT
Created attachment 627339 [details]
anaconda-yum.conf
Comment 3 Kamil Páral 2012-10-15 07:33:44 EDT
Created attachment 627340 [details]
ifcfg.log
Comment 4 Kamil Páral 2012-10-15 07:33:49 EDT
Created attachment 627341 [details]
packaging.log
Comment 5 Kamil Páral 2012-10-15 07:33:52 EDT
Created attachment 627342 [details]
program.log
Comment 6 Kamil Páral 2012-10-15 07:33:55 EDT
Created attachment 627343 [details]
storage.log
Comment 7 Kamil Páral 2012-10-15 07:33:58 EDT
Created attachment 627344 [details]
syslog
Comment 8 Kamil Páral 2012-10-15 07:34:01 EDT
Created attachment 627345 [details]
X.log
Comment 9 Kamil Páral 2012-10-15 07:37:01 EDT
This might and might not be a Beta blocker. Developer feedback is required whether this negatively influences anaconda or not. But it might infringe this criterion:

 The installer must be able to report failures to Bugzilla and local disk, with appropriate information included 
https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria

There was a crash, but the user wasn't notified nor offered to report it. Does crash in python-meh means that the integrated bug reporting tool stops working?
Comment 10 Kamil Páral 2012-10-15 07:42:37 EDT
It's a probably race-condition, I saw it again in after a few boot attempts.
Comment 11 Vratislav Podzimek 2012-10-15 10:58:49 EDT
This traceback was caused by some exception with no stack, which is something I have never seen before, but obviously can happen.
Comment 12 Adam Williamson 2012-10-15 11:57:01 EDT
Discussed at 2012-10-15 QA meeting acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-10-15/fedora-qa.2012-10-15-15.00.log.txt . Agreed that this is a worrying bug but we need more details on what's going on before we can decide blocker status. I wonder if it's the NM bug kamil seems to be hitting quite regularly, and this is just what happens when it happens *early* (the time he hits it seems to vary from run to run).
Comment 13 Kamil Páral 2012-10-15 12:29:31 EDT
Vratislav, please check whether this can be related to bug 866434 (recent regression in Beta TC4). I haven't seen this issue in TC3 and prior.

Also, can you tell us whether this is something that could disable the internal bug reporting tool (i.e. a dialog would not pop up for any following errors)? How severe this issue is?
Comment 14 Vratislav Podzimek 2012-10-15 12:59:03 EDT
(In reply to comment #13)
> Vratislav, please check whether this can be related to bug 866434 (recent
> regression in Beta TC4). I haven't seen this issue in TC3 and prior.
I think it is not related, because bug 866434 is about traceback that has stack and is correctly handled by python-meh. This bug is however about some traceback, that has no stack at all (could be division by zero or something like that).

> 
> Also, can you tell us whether this is something that could disable the
> internal bug reporting tool (i.e. a dialog would not pop up for any
> following errors)? How severe this issue is?
Python defends itself by disabling custom exception handler that raises exception when handling another one. So if a traceback with no stack appears and python-meh raises exception reported in this bug, Python no longer uses it for exception handling.
Comment 15 Vratislav Podzimek 2012-10-15 13:00:35 EDT
Please try this updates image:
http://vpodzime.fedorapeople.org/no_stack_updates.img
Comment 16 Kamil Páral 2012-10-16 04:59:02 EDT
(In reply to comment #14)
> > Also, can you tell us whether this is something that could disable the
> > internal bug reporting tool (i.e. a dialog would not pop up for any
> > following errors)? How severe this issue is?
> Python defends itself by disabling custom exception handler that raises
> exception when handling another one. So if a traceback with no stack appears
> and python-meh raises exception reported in this bug, Python no longer uses
> it for exception handling.

In other words, once this issue happens, no exception dialog is popped up, and also it prevents the dialog from appearing for any future exceptions. That means it really hits the aforementioned criterion.
Comment 17 Kamil Páral 2012-10-16 04:59:54 EDT
(In reply to comment #15)
> Please try this updates image:
> http://vpodzime.fedorapeople.org/no_stack_updates.img

This fixes the issue, a GUI dialog appears with exception with no stack. I also verified that exceptions with stack did not regress, they display as usual.
Comment 18 Adam Williamson 2012-10-17 14:16:37 EDT
Discussed at 2012-10-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-17/f18beta-blocker-review-4.2012-10-17-16.00.log.txt . We agreed this is a conditional violation of the criterion "The installer must be able to report failures to Bugzilla and local disk, with appropriate information included" - when an exception with no stack occurs, it breaks the crash reporting functionality. In the end we decided this likely isn't occurring enough to strictly constitute a blocker (we applied the 'would we hold release for this if today was the go/no-go and this was the last bug' test, and felt this is the kind of issue that would probably get fudged). It is rejected as a blocker but accepted as NTH as anything that impacts crash reporting is significant for beta test purposes.
Comment 19 Fedora Update System 2012-10-25 07:01:33 EDT
python-meh-0.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-meh-0.18-1.fc18
Comment 20 Fedora Update System 2012-10-26 15:32:01 EDT
Package python-meh-0.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-meh-0.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16873/python-meh-0.18-1.fc18
then log in and leave karma (feedback).
Comment 21 Kamil Páral 2012-11-09 07:42:30 EST
python-meh-0.18-1.fc18 pushed stable, closing.

Note You need to log in before you can comment on or make changes to this bug.