Bug 866442 - AttributeError: 'module' object has no attribute 'Firewall'
AttributeError: 'module' object has no attribute 'Firewall'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:34667e7422f82136a6337198270...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 07:35 EDT by Joost Ringoot
Modified: 2012-10-16 08:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 13:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: environ (2.22 KB, text/plain)
2012-10-15 07:35 EDT, Joost Ringoot
no flags Details
File: type (9 bytes, text/plain)
2012-10-15 07:35 EDT, Joost Ringoot
no flags Details
File: exnFileName (38 bytes, text/plain)
2012-10-15 07:35 EDT, Joost Ringoot
no flags Details
File: product (8 bytes, text/plain)
2012-10-15 07:35 EDT, Joost Ringoot
no flags Details
File: hashmarkername (23 bytes, text/plain)
2012-10-15 07:35 EDT, Joost Ringoot
no flags Details
File: version (7 bytes, text/plain)
2012-10-15 07:35 EDT, Joost Ringoot
no flags Details
File: release (33 bytes, text/plain)
2012-10-15 07:36 EDT, Joost Ringoot
no flags Details

  None (edit)
Description Joost Ringoot 2012-10-15 07:35:47 EDT
Description of problem:
system-config-kickstart crashed at launch

Version-Release number of selected component:
system-config-kickstart-2.8.8-2.fc17.noarch

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python2  /bin/system-config-kickstart
kernel:         3.6.1-1.fc17.x86_64

description:
:The following was filed automatically by system-config-kickstart:
:system-config-kickstart @VERSION@ exception report
:Traceback (most recent call last):
:  File "/bin/system-config-kickstart", line 105, in <module>
:    ksGui.run()
:  File "/usr/share/system-config-kickstart/kickstartGui.py", line 200, in run
:    self.firewall_class = firewall.Firewall(xml, self.ksHandler)
:AttributeError: 'module' object has no attribute 'Firewall'
Comment 1 Joost Ringoot 2012-10-15 07:35:50 EDT
Created attachment 627346 [details]
File: environ
Comment 2 Joost Ringoot 2012-10-15 07:35:52 EDT
Created attachment 627347 [details]
File: type
Comment 3 Joost Ringoot 2012-10-15 07:35:54 EDT
Created attachment 627348 [details]
File: exnFileName
Comment 4 Joost Ringoot 2012-10-15 07:35:56 EDT
Created attachment 627349 [details]
File: product
Comment 5 Joost Ringoot 2012-10-15 07:35:57 EDT
Created attachment 627350 [details]
File: hashmarkername
Comment 6 Joost Ringoot 2012-10-15 07:35:59 EDT
Created attachment 627351 [details]
File: version
Comment 7 Joost Ringoot 2012-10-15 07:36:01 EDT
Created attachment 627352 [details]
File: release
Comment 8 Joost Ringoot 2012-10-15 07:48:47 EDT
Additional Note: it took me a while to report this, due to a bug in anaconda, which prevented report-gtk to complete it's job, see  :
https://bugzilla.redhat.com/show_bug.cgi?id=741647
Comment 9 Joost Ringoot 2012-10-15 07:54:45 EDT
This is just a smal test.
I expect this to generate a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=741647 


Package: system-config-kickstart-2.8.8-2.fc17.noarch
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Joost Ringoot 2012-10-15 07:59:51 EDT
err, in comment 9.  I meant https://bugzilla.redhat.com/show_bug.cgi?id=866442 o' course.
Comment 11 Chris Lumens 2012-10-15 10:30:17 EDT
system-config-kickstart is unlikely to see any attention until post-F18.  bug 741647 is not a bug in anaconda.
Comment 12 Chris Lumens 2012-10-15 13:08:49 EDT
And I'm not planning on reusing this code anyway.
Comment 13 Joost Ringoot 2012-10-16 04:52:47 EDT
"until post-F18"? does that mean that there will be no working system-config-kickstart for F17 nor for F18.
Comment 14 Steve Tyler 2012-10-16 08:40:03 EDT
Isn't this bug a duplicate of
Bug 820748 - system-config-kickstart is broken 
?

They both have:
AttributeError: 'module' object has no attribute 'Firewall'

Note You need to log in before you can comment on or make changes to this bug.