This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 866448 - [RFE] rhevm-cli: show command should retrieve sdk collection.get() method's args dynamically
[RFE] rhevm-cli: show command should retrieve sdk collection.get() method's a...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-cli (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.0
Assigned To: Ravi Nori
Oded Ramraz
infra
: FutureFeature
: 950388 977910 (view as bug list)
Depends On:
Blocks: 1062434
  Show dependency treegraph
 
Reported: 2012-10-15 07:53 EDT by Michael Pasternak
Modified: 2014-03-31 11:04 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-engine-cli-3.4.0.5-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 11:04:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 24710 None None None Never
oVirt gerrit 24973 None None None Never

  None (edit)
Description Michael Pasternak 2012-10-15 07:53:29 EDT
show command should retrieve sdk collection.get() method's args dynamically,
currently hardcoded id/name options being used.
Comment 1 Michael Pasternak 2012-10-15 07:55:07 EDT
these days use-case is api.disks.get() where search-by-name paradigm broken
by engine and used 'alias' instead of 'name'
Comment 5 Michael Pasternak 2013-04-10 04:26:27 EDT
*** Bug 950388 has been marked as a duplicate of this bug. ***
Comment 7 Michael Pasternak 2013-12-31 04:02:49 EST
*** Bug 977910 has been marked as a duplicate of this bug. ***
Comment 10 Juan Hernández 2014-02-24 11:16:00 EST
Ravi, please backport to 3.4.
Comment 11 Juan Hernández 2014-02-27 09:26:41 EST
The packages containing the fix for this issue are available here:

http://jhernand.fedorapeople.org/rpms/ovirt-engine-cli/3.4.0.5-1
Comment 12 Sandro Bonazzola 2014-03-31 11:04:38 EDT
This is an automated message: moving to Closed CURRENT_RELEASE since oVirt 3.4.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.