Bug 866516 - hostname is "None" with no networking device
hostname is "None" with no networking device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-15 10:36 EDT by Kamil Páral
Modified: 2012-11-23 06:34 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-18.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 23:55:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-ks.cfg (698 bytes, text/plain)
2012-10-15 10:37 EDT, Kamil Páral
no flags Details
anaconda.ifcfg.log (2.61 KB, text/plain)
2012-10-15 10:37 EDT, Kamil Páral
no flags Details
anaconda.log (30.91 KB, text/plain)
2012-10-15 10:37 EDT, Kamil Páral
no flags Details
anaconda.packaging.log (38.92 KB, text/plain)
2012-10-15 10:37 EDT, Kamil Páral
no flags Details
anaconda.program.log (28.70 KB, text/plain)
2012-10-15 10:37 EDT, Kamil Páral
no flags Details
anaconda.storage.log (152.25 KB, text/plain)
2012-10-15 10:37 EDT, Kamil Páral
no flags Details
syslog (82.88 KB, text/plain)
2012-10-15 10:37 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-10-15 10:36:15 EDT
Description of problem:
I did a minimal installation of F18 Beta TC4. The resulting system's hostname is "None". Not really a good hostname.

Version-Release number of selected component (if applicable):
F18 Beta TC4
anaconda 18.16

How reproducible:
I guess 100%

Steps to Reproduce:
1. boot DVD
2. select minimal install
3. go
Comment 1 Kamil Páral 2012-10-15 10:37:15 EDT
Created attachment 627465 [details]
anaconda-ks.cfg
Comment 2 Kamil Páral 2012-10-15 10:37:19 EDT
Created attachment 627466 [details]
anaconda.ifcfg.log
Comment 3 Kamil Páral 2012-10-15 10:37:24 EDT
Created attachment 627467 [details]
anaconda.log
Comment 4 Kamil Páral 2012-10-15 10:37:27 EDT
Created attachment 627468 [details]
anaconda.packaging.log
Comment 5 Kamil Páral 2012-10-15 10:37:30 EDT
Created attachment 627469 [details]
anaconda.program.log
Comment 6 Kamil Páral 2012-10-15 10:37:33 EDT
Created attachment 627470 [details]
anaconda.storage.log
Comment 7 Kamil Páral 2012-10-15 10:37:36 EDT
Created attachment 627471 [details]
syslog
Comment 8 Morten Stevens 2012-10-17 05:29:41 EDT
(In reply to comment #0)
> Description of problem:
> I did a minimal installation of F18 Beta TC4. The resulting system's
> hostname is "None". Not really a good hostname.

Same problem here.
Comment 9 Kamil Páral 2012-10-17 08:36:10 EDT
I found out that this applies only if you have no networking device. Bug 865009 caused that sometimes this was applied also to systems where you have a networking device, but NM just crashed.
Comment 10 Kamil Páral 2012-10-17 08:36:44 EDT
It might also apply to systems where you have a networking device, but you have no network connection. I haven't tested that.
Comment 11 Mukundan Ragavan 2012-10-17 08:57:01 EDT
I did installation using netinstall with a wired connection and I get the hostname as "None".

So, I think the hostname is set to "None" regardless of whether networking device is present or not.
Comment 12 Miroslav Vadkerti 2012-10-18 03:44:17 EDT
I just experienced the same behavior as in Comment 11. Netinstall with wired connection and the hostname is "None"
Comment 13 Radek Vykydal 2012-10-18 04:25:15 EDT
Happens also when network spoke is visited in GUI. Patch sent to list.

Updates image (for TC4, should probably work for TC5 too):
http://rvykydal.fedorapeople.org/updates.866516.img
Comment 14 Morten Stevens 2012-10-18 11:06:13 EDT
Another question in this context: Why is it not possible to set the hostname manually in fedora/anaconda 18-x?
Comment 15 Fedora Update System 2012-10-19 21:31:41 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 16 Mukundan Ragavan 2012-10-19 21:37:35 EDT
This issue seems to be "fixed" in the TC5 image - anaconda 18.18.

The default hostname is set to "localhost" instead of "None".
Comment 17 Fedora Update System 2012-10-19 23:50:19 EDT
Package anaconda-18.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16528/anaconda-18.19-1.fc18
then log in and leave karma (feedback).
Comment 18 Kamil Páral 2012-10-22 10:06:45 EDT
Still broken in anaconda 18.19. A machine with no NIC still defaults to None hostname (minimal installation done).
Comment 19 Radek Vykydal 2012-10-30 10:59:10 EDT
Yep, still broken for installations that present pre-hub standalone network spoke (i.e. network is not brought up automatically by dracut or NM). These cases should be fixed by patch for bug 868535.
Comment 20 Adam Williamson 2012-11-22 23:55:42 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(868535 is closed.)
Comment 21 Kamil Páral 2012-11-23 06:34:09 EST
Verified fixed in anaconda 18.29.2.

Note You need to log in before you can comment on or make changes to this bug.