Bug 868535 - AttributeError: 'NoneType' object has no attribute 'get'
AttributeError: 'NoneType' object has no attribute 'get'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
abrt_hash:1035de789d3350bd60b0f160997...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-20 13:31 EDT by Mukundan Ragavan
Modified: 2012-11-08 03:57 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-18.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 03:57:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (334.72 KB, text/plain)
2012-10-20 13:31 EDT, Mukundan Ragavan
no flags Details
File: product (6 bytes, text/plain)
2012-10-20 13:31 EDT, Mukundan Ragavan
no flags Details
File: type (9 bytes, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: ifcfg.log (2.51 KB, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: storage.log (112.93 KB, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: version (11 bytes, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: environ (780 bytes, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: anaconda.log (4.12 KB, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: syslog (143.48 KB, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: packaging.log (4.42 KB, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: release (24 bytes, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details
File: program.log (33.64 KB, text/plain)
2012-10-20 13:32 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Mukundan Ragavan 2012-10-20 13:31:48 EDT
Description of problem:
Activated network and went back to the hub. Anaconda crashed.

Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 569, in kickstartNetworkData
:    if not ifcfg.get("ESSID"):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 942, in apply
:    nd = kickstartNetworkData(hostname=hostname)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
:    action.apply()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 323, in _on_spoke_clicked
:    self._runSpoke(spoke)
:AttributeError: 'NoneType' object has no attribute 'get'
Comment 1 Mukundan Ragavan 2012-10-20 13:31:57 EDT
Created attachment 630501 [details]
File: anaconda-tb
Comment 2 Mukundan Ragavan 2012-10-20 13:31:59 EDT
Created attachment 630502 [details]
File: product
Comment 3 Mukundan Ragavan 2012-10-20 13:32:00 EDT
Created attachment 630503 [details]
File: type
Comment 4 Mukundan Ragavan 2012-10-20 13:32:04 EDT
Created attachment 630504 [details]
File: ifcfg.log
Comment 5 Mukundan Ragavan 2012-10-20 13:32:09 EDT
Created attachment 630505 [details]
File: storage.log
Comment 6 Mukundan Ragavan 2012-10-20 13:32:11 EDT
Created attachment 630506 [details]
File: version
Comment 7 Mukundan Ragavan 2012-10-20 13:32:13 EDT
Created attachment 630507 [details]
File: environ
Comment 8 Mukundan Ragavan 2012-10-20 13:32:14 EDT
Created attachment 630508 [details]
File: anaconda.log
Comment 9 Mukundan Ragavan 2012-10-20 13:32:17 EDT
Created attachment 630509 [details]
File: syslog
Comment 10 Mukundan Ragavan 2012-10-20 13:32:19 EDT
Created attachment 630510 [details]
File: hashmarkername
Comment 11 Mukundan Ragavan 2012-10-20 13:32:21 EDT
Created attachment 630511 [details]
File: packaging.log
Comment 12 Mukundan Ragavan 2012-10-20 13:32:23 EDT
Created attachment 630512 [details]
File: cmdline_file
Comment 13 Mukundan Ragavan 2012-10-20 13:32:24 EDT
Created attachment 630513 [details]
File: release
Comment 14 Mukundan Ragavan 2012-10-20 13:32:26 EDT
Created attachment 630514 [details]
File: program.log
Comment 15 satellitgo 2012-10-29 14:04:59 EDT
testing re-entering network spoke after configuring wlan0  per bug 871132

Package: anaconda-18.19
OS Release: Fedora release 18-Beta-TC6
Comment 16 Mukundan Ragavan 2012-10-29 14:30:51 EDT
When using wired connection, anaconda did not crash with version 18.21 on smoke12 iso.
Comment 17 Adam Williamson 2012-10-29 15:09:16 EDT
This looks to be wireless specific, from the traceback. It's trying to check something about the ESSID.
Comment 18 Adam Williamson 2012-10-29 15:09:39 EDT
Radek, can you advise more on the circumstances of this bug? Does it look bad enough to be a Beta blocker?
Comment 19 Mukundan Ragavan 2012-10-29 22:10:29 EDT
Setup WPA2-Personal and connected to it.

Clicked on Done to return to the hub. Anaconda crashed.


Package: anaconda-18.21
OS Release: Fedora release 18
Comment 20 Radek Vykydal 2012-10-30 10:26:46 EDT
This concerns all cases when network is configured (brought up) in pre-hub network standalone spoke. Proposing as Beta blocker, fix coming soon.
Comment 21 Tom Lane 2012-10-30 13:05:17 EDT
I'm seeing this one too - it looks like it is trying to fetch ESSID even when there's no working network config at all, let alone a wireless one.
Comment 22 Adam Williamson 2012-10-30 14:17:48 EDT
what triggers the 'pre-hub network standalone spoke' exactly? under what circumstances do you see that?
Comment 23 Tom Lane 2012-10-30 16:41:35 EDT
Disconnect wired-ethernet cable for instance.  Or shut off your DHCP service.  Anything so that network autoconfig won't work.
Comment 24 Adam Williamson 2012-10-30 17:59:25 EDT
I doubt that's the whole story. Surely it also has to be in a context where network access is needed...e.g. you booted from a kernel/initramfs pair, or passed updates=(remote location) or ks=(remote location), or - possibly - just that you booted the netinst ISO...
Comment 25 Tom Lane 2012-10-30 18:38:44 EDT
Yeah, I'm using the netinst ISO.  Isn't that pretty standard practice?  It's certainly been my preferred way to install Fedora since F10 or so.  Otherwise, you get to download a whole DVD (which you likely don't want everything on) and then *re* download a significant fraction of the same packages at your first "yum update".
Comment 26 Adam Williamson 2012-10-30 19:03:01 EDT
Sure. It's just important that for blocker evaluation we have a precise understanding of the trigger conditions for a bug.
Comment 27 Radek Vykydal 2012-10-31 04:56:01 EDT
(In reply to comment #26)

> Sure. It's just important that for blocker evaluation we have a precise
> understanding of the trigger conditions for a bug.

Let me recap a bit with use cases:

DVD install, cable not plugged in -> pre-hub network spoke is present
a) connect to wifi using AP containing spaces -> bug 869106
b) connect to wifi using AP without spaces or plug cable with dhcp in
   1) visit network spoke from hub -> this bz
   2) proceed without visiting network spoke from hub -> bug 866516 (bug 870684)

DVD install, cable without DHCP plugged in -> no pre-hub network spoke (incorrect) - bug 871129

All the bugs mentioned above should be fixed in 19.22 (plus bug 871429).
Comment 28 Adam Williamson 2012-10-31 12:47:08 EDT
Discussed at 2012-10-31 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-31/f18beta-blocker-review-6.2012-10-31-16.00.log.txt .

This whole area is confusing and we weren't entirely sure of the impact of this bug, so we weren't confident in accepting it as a blocker, but we accept it as NTH as it clearly has an impact on the viability of network installs. We agreed to leave the blocker question open so it can be revisited if it becomes a problem, but our expectation is this fix will be in 18.22 and the issue will be rendered moot.
Comment 29 Fedora Update System 2012-10-31 22:51:23 EDT
anaconda-18.22-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.22-1.fc18
Comment 30 Fedora Update System 2012-11-01 14:26:59 EDT
Package anaconda-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17432/anaconda-18.22-1.fc18
then log in and leave karma (feedback).
Comment 31 Fedora Update System 2012-11-02 00:05:54 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 32 Fedora Update System 2012-11-02 21:05:20 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 33 Adam Williamson 2012-11-05 12:10:42 EST
Discussed at 2012-11-05 QA meeting acting as a blocker review meeting. We didn't try very hard to determine blocker status, as this ought to be fixed already, and since there have been no dupes with 18.22+ and Tom reported in another bug that his tests are generally working better, we think it probably is.

Can those who could reproduce this bug test with Beta TC7 or later and confirm that it's fixed now? Thanks!
Comment 34 Mukundan Ragavan 2012-11-05 14:25:53 EST
I can confirm that this is no longer a problem with TC7.  

I am able to even change networks with TC7 - go from wired to wireless or vice versa. No crashes to report.
Comment 35 Fedora Update System 2012-11-05 20:40:30 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 36 Jindrich Novy 2012-11-06 03:30:27 EST
Selecting SSID for wifi installation in anaconda, F18 TC6

Package: anaconda-18.19
OS Release: Fedora release 18-Beta-TC6
Comment 37 Adam Williamson 2012-11-06 19:14:03 EST
verified per comment #34.
Comment 38 Fedora Update System 2012-11-06 21:12:30 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 39 Fedora Update System 2012-11-07 13:48:26 EST
Package anaconda-18.26-1.fc18, lorax-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.26-1.fc18 lorax-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17714/lorax-18.22-1.fc18,anaconda-18.26-1.fc18
then log in and leave karma (feedback).
Comment 40 Adam Williamson 2012-11-07 18:59:56 EST
Back to VERIFIED.
Comment 41 Adam Williamson 2012-11-08 03:57:36 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.