Bug 866527 - please package the perl bindings
please package the perl bindings
Status: CLOSED DUPLICATE of bug 450912
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: distribution (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: mrg-program-list
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 10:53 EDT by Petr Matousek
Modified: 2013-01-04 10:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 16:37:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Matousek 2012-10-15 10:53:29 EDT
Description of problem:
Qpid 0.18 includes Perl bindings to qpid messaging but these aren't being packaged for MRG. 

Now that the package is upstream (please see Bug 709948) and the perl client support shall be added in current release, we should go ahead and pull it downstream as well.

Version-Release number of selected component (if applicable):
qpid-cpp-0.18-2
qpid-cpp-mrg-0.18-2

Expected results:
To have a perl-qpid subpackage (or something similar).

Additional info:
Files that should be included:

 * cqpid_perl.pm      (<>/qpid/cpp/bindings/qpid/perl/)
 * the perl examples  (<>/qpid/cpp/bindings/qpid/examples/perl/)
 + new Perl API/layer that provides a more Perl-specific API (namespace "qpid::messaging").
Comment 1 Irina Boverman 2012-10-17 16:37:37 EDT

*** This bug has been marked as a duplicate of bug 450912 ***

Note You need to log in before you can comment on or make changes to this bug.