Bug 866572 - ipa-adtrust-install checks for /usr/bin/smbpasswd, which is not required
ipa-adtrust-install checks for /usr/bin/smbpasswd, which is not required
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
: 867677 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 11:59 EDT by Steeve Goveas
Modified: 2015-05-13 03:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipa-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:28:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steeve Goveas 2012-10-15 11:59:28 EDT
Description of problem:
ipa-adtrust-install cli does check for /usr/bin/smbpasswd file. This file is not required to be checked for the cli to work.

Version-Release number of selected component (if applicable):
ipa-server-trust-ad-3

How reproducible:
always

Steps to Reproduce:
[root@rasalghul ~]# rpm -qa | grep samba samba-winbind-4.0.0-153.fc18.rc2.x86_64 samba-common-4.0.0-153.fc18.rc2.x86_64 samba-python-4.0.0-153.fc18.rc2.x86_64 samba-winbind-clients-4.0.0-153.fc18.rc2.x86_64 samba-libs-4.0.0-153.fc18.rc2.x86_64 samba-4.0.0-153.fc18.rc2.x86_64

[root@rasalghul ~]# yum install freeipa-server-trust-ad Package freeipa-server-trust-ad-3.0.0-2.fc18.x86_64 already installed and latest version Nothing to do

[root@rasalghul ~]# ipa-adtrust-install

The log file for this installation can be found in /var/log/ipaserver-install.log ============================================================================== This program will setup components needed to establish trust to AD domains for the FreeIPA Server.

This includes:

    Configure Samba
    Add trust related objects to FreeIPA LDAP server 

To accept the default shown in brackets, press the Enter key.

<type 'file'> was not found on this system Please install the 'samba' packages and start the installation again Aborting installation.

[root@rasalghul ~]# ls -l /usr/sbin/smbd /usr/bin/net /usr/bin/smbpasswd ls: cannot access /usr/bin/smbpasswd: No such file or directory -rwxr-xr-x. 1 root root 888336 Oct 10 18:54 /usr/bin/net -rwxr-xr-x. 1 root root 62640 Oct 10 18:54 /usr/sbin/smbd


Actual results:


Expected results:
ipa-adtrust-install should not check for /usr/bin/smbpasswd file

Additional info:
Comment 2 Martin Kosek 2012-10-16 03:04:05 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3181
Comment 4 Martin Kosek 2012-10-18 03:20:11 EDT
*** Bug 867677 has been marked as a duplicate of this bug. ***
Comment 6 Steeve Goveas 2012-11-07 03:35:07 EST
[root@ratchet ~]# ipa-adtrust-install
....
Configuring cross-realm trusts for IPA server requires password for user 'admin'.
This user is a regular system account used for IPA server administration.

admin password: 

Configuring CIFS
  [1/18]: stopping smbd
  [2/18]: creating samba domain object
  [3/18]: creating samba config registry
  [4/18]: writing samba config file
  [5/18]: adding cifs Kerberos principal
  [6/18]: adding cifs principal to S4U2Proxy targets
  [7/18]: adding admin(group) SIDs
  [8/18]: adding RID bases
  [9/18]: updating Kerberos config
'dns_lookup_kdc' already set to 'true', nothing to do.
  [10/18]: activating CLDAP plugin
  [11/18]: activating sidgen plugin and task
  [12/18]: activating extdom plugin
  [13/18]: configuring smbd to start on boot
  [14/18]: adding special DNS service records
  [15/18]: restarting Directory Server to take MS PAC and LDAP plugins changes into account
  [16/18]: adding fallback group
  [17/18]: setting SELinux booleans
  [18/18]: starting CIFS services
Done configuring CIFS.

=============================================================================
Setup complete
....

[root@ratchet ~]# rpm -qa | grep ipa-server
ipa-server-3.0.0-106.20121106T0229zgit881fc3a.el6.x86_64
ipa-server-selinux-3.0.0-106.20121106T0229zgit881fc3a.el6.x86_64
ipa-server-trust-ad-3.0.0-106.20121106T0229zgit881fc3a.el6.x86_64

[root@ratchet log]# rpm -qa | grep samba
samba4-libs-4.0.0-43.el6.rc4.x86_64
samba4-common-4.0.0-43.el6.rc4.x86_64
samba4-winbind-clients-4.0.0-43.el6.rc4.x86_64
samba4-4.0.0-43.el6.rc4.x86_64
samba4-python-4.0.0-43.el6.rc4.x86_64
samba4-winbind-4.0.0-43.el6.rc4.x86_64
Comment 9 errata-xmlrpc 2013-02-21 04:28:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0528.html

Note You need to log in before you can comment on or make changes to this bug.