Bug 867677 - ipa-adtrust-install checks for /usr/bin/smbpasswd, which is not required
Summary: ipa-adtrust-install checks for /usr/bin/smbpasswd, which is not required
Keywords:
Status: CLOSED DUPLICATE of bug 866572
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-18 03:52 UTC by Dmitri Pal
Modified: 2012-10-18 07:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-18 07:20:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dmitri Pal 2012-10-18 03:52:33 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/3175

{{{
[root@rasalghul ~]# rpm -qa | grep samba
samba-winbind-4.0.0-153.fc18.rc2.x86_64
samba-common-4.0.0-153.fc18.rc2.x86_64
samba-python-4.0.0-153.fc18.rc2.x86_64
samba-winbind-clients-4.0.0-153.fc18.rc2.x86_64
samba-libs-4.0.0-153.fc18.rc2.x86_64
samba-4.0.0-153.fc18.rc2.x86_64

[root@rasalghul ~]# yum install freeipa-server-trust-ad 
Package freeipa-server-trust-ad-3.0.0-2.fc18.x86_64 already installed and latest version
Nothing to do

[root@rasalghul ~]# ipa-adtrust-install

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will setup components needed to establish trust to AD domains for
the FreeIPA Server.

This includes:
  * Configure Samba
  * Add trust related objects to FreeIPA LDAP server

To accept the default shown in brackets, press the Enter key.

<type 'file'> was not found on this system
Please install the 'samba' packages and start the installation again
Aborting installation.

[root@rasalghul ~]# ls -l /usr/sbin/smbd /usr/bin/net /usr/bin/smbpasswd
ls: cannot access /usr/bin/smbpasswd: No such file or directory
-rwxr-xr-x. 1 root root 888336 Oct 10 18:54 /usr/bin/net
-rwxr-xr-x. 1 root root  62640 Oct 10 18:54 /usr/sbin/smbd

}}}

Comment 2 Tomas Babej 2012-10-18 07:15:44 UTC
This is a duplicate of Bug 866572, which has already been resolved.

Comment 3 Martin Kosek 2012-10-18 07:20:11 UTC
Closing as duplicate.

*** This bug has been marked as a duplicate of bug 866572 ***


Note You need to log in before you can comment on or make changes to this bug.