Bug 866584 - udev properties are only shown after re-triggering
udev properties are only shown after re-triggering
Status: CLOSED DUPLICATE of bug 866585
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 12:39 EDT by Fabian Deutsch
Modified: 2016-04-26 09:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 09:40:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-10-15 12:39:27 EDT
Description of problem:
Udev properties are used to e.g. determin the model or vendor of a NIC. After boot, not all udev properties are determined properly.

Version-Release number of selected component (if applicable):
Current

How reproducible:
Always

Steps to Reproduce:
1. Clean install
2. No nic configuration
3. Dro to shell and run:
4. udevadm info --query=all --path/sys/class/net/eth0
  
Actual results:
Some properties are shown, but nothing like e.g. VENDOR_INFO_FROM_DATABASE (or what it is called)

Expected results:
More properties are shown, including e.g. VENDOR_INFO_FROM_DATABASE (or what it is called)

Additional info:
Comment 5 Fabian Deutsch 2012-10-17 02:33:18 EDT
An initial udevadm info after a boot without configured nics:

[root@hp-xw4550-02 admin]# udevadm --debug info --query=all --path=/sys/class/net/eth3
run_command: calling: info
udev_device_new_from_syspath: device 0x7f6f4fc5a6d0 has devpath '/devices/pci0000:00/0000:00:14.4/0000:07:04.0/net/eth3'
P: /devices/pci0000:00/0000:00:14.4/0000:07:04.0/net/eth3
E: UDEV_LOG=6
E: DEVPATH=/devices/pci0000:00/0000:00:14.4/0000:07:04.0/net/eth3
E: INTERFACE=eth3
E: IFINDEX=5
E: SUBSYSTEM=net

[root@hp-xw4550-02 admin]#


Thus properties are not loaded.
udev can be forced to load the properties by running:

# udevadm test /sys/class/net/eth3

The properties will now be available.
Comment 9 Kay Sievers 2012-10-17 08:23:15 EDT
As mentioned on IRC, this setup renames the device while it runs, and it seemed
to be done several times in one and the same event. Also the rules change
during bootup by over-mounting them. Something along all these rather "exotic" setup steps causes some hickup. Sorry, I have no idea what goes wrong here.

It seems, the simplest workaround would be to 'trigger' all network interfaces
again after bootup, and 'settle' again before anything tries to access any udev
device data that is in the process of being mangled that way.
Comment 10 Fabian Deutsch 2012-10-18 01:08:18 EDT
(In reply to comment #9)
> As mentioned on IRC, this setup renames the device while it runs, and it
> seemed
> to be done several times in one and the same event. Also the rules change
> during bootup by over-mounting them. Something along all these rather
> "exotic" setup steps causes some hickup. Sorry, I have no idea what goes
> wrong here.

Just a note here: I could also reproduce this on a default RHEL6 machine (see comment above) which hasn't got this exotic setup.
Comment 11 Mike Burns 2012-10-19 09:40:41 EDT
The base issue in udev can't/won't be solved in RHEL 6.  We handle this issue with the fix in bug 866585

*** This bug has been marked as a duplicate of bug 866585 ***

Note You need to log in before you can comment on or make changes to this bug.