Bug 866698 - abrt - No ~/.xsession-errors (exited with 1)
abrt - No ~/.xsession-errors (exited with 1)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 18:19 EDT by Flóki Pálsson
Modified: 2012-12-20 10:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:22:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
from $ abrt-gui -vvv 2>abrt.txt (231.40 KB, text/plain)
2012-10-15 18:19 EDT, Flóki Pálsson
no flags Details
from abrt gui window (53.62 KB, text/plain)
2012-10-15 18:20 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2012-10-15 18:19:35 EDT
Created attachment 627758 [details]
from $ abrt-gui -vvv  2>abrt.txt

Description of problem:
abrt-gui -vvv fails with 
--- Running collect_xsession_errors ---
No ~/.xsession-errors
(exited with 1)

Version-Release number of selected component (if applicable):
abrt-2.0.15-1.fc18.x86_64


How reproducible:
I have not tryed.

Steps to Reproduce:
1. abrt-2.0.15-1.fc18.x86_64
2. select Source: libreport Problem: Process /usr/bin/report-gtk was killed by signal 11
3.
  
Actual results:
see attachement
...
...
--- Running collect_xsession_errors ---
No ~/.xsession-errors
(exited with 1)

Expected results:
Bug reported to Bugzilla

Additional info:
See athachment
Comment 1 Flóki Pálsson 2012-10-15 18:20:37 EDT
Created attachment 627759 [details]
from abrt gui window
Comment 2 Denys Vlasenko 2012-10-16 06:01:08 EDT
Fixed in git:

commit 1fc8b6c2ba593720f7c20167a11bdc349f98bc63
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Tue Oct 16 11:59:52 2012 +0200

    collect_xsession_errors should not fail if !xsession-errors
Comment 3 Fedora Update System 2012-10-17 06:15:51 EDT
abrt-2.0.16-1.fc17, libreport-2.0.16-1.fc17, btparser-0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-15968/abrt-2.0.16-1.fc17,libreport-2.0.16-1.fc17,btparser-0.20-1.fc17
Comment 4 Fedora Update System 2012-10-17 20:34:07 EDT
Package abrt-2.0.16-1.fc17, libreport-2.0.16-1.fc17, btparser-0.20-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.16-1.fc17 libreport-2.0.16-1.fc17 btparser-0.20-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15968/abrt-2.0.16-1.fc17,libreport-2.0.16-1.fc17,btparser-0.20-1.fc17
then log in and leave karma (feedback).
Comment 5 Flóki Pálsson 2012-10-21 16:58:28 EDT
>You might also want to inform ABRT developers about that so they'll fix their >code to check the new location of the file too.
see Bug 866698 - abrt - No ~/.xsession-errors (exited with 1) (edit)
Comment 6 Flóki Pálsson 2012-10-21 17:37:45 EDT
sorry wrong number in #comment 5
See Bug 868667 - No ~/.xsession-errors 
>Not a bug, the file is there, it was just moved.

>https://mail.gnome.org/archives/commits-list/2012-April/msg11498.html

>You might also want to inform ABRT developers about that so they'll fix their >code to check the new location of the file too.
Comment 7 Fedora Update System 2012-12-20 10:22:40 EST
abrt-2.0.16-1.fc17, libreport-2.0.16-1.fc17, btparser-0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.