Bug 866862 - Cannot save a process if use "&" in property "Task name"
Cannot save a process if use "&" in property "Task name"
Status: CLOSED DUPLICATE of bug 864920
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5 (Show other bugs)
BRMS 5.3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On:
Blocks: 864924
  Show dependency treegraph
 
Reported: 2012-10-16 04:06 EDT by Sona Mala
Modified: 2012-10-24 11:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 11:53:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Record of steps to reproduce (3.86 MB, video/webm)
2012-10-16 04:06 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2012-10-16 04:06:48 EDT
Created attachment 628017 [details]
Record of steps to reproduce

Description of problem:
Cannot save a process when set task property ("Task Name") to string with "&" (for example: A & B)

Version-Release number of selected component (if applicable):
BRMS 5.3.1 ER3, designer 2.3.1-dev

How reproducible:
every time when property "Task Name" contains "&"

Steps to Reproduce:
1. create new BPMN2 asset
2. create proces (Start->Task->End)
3. click on Task, show Property Bar
4. set property "Task Name" to "A & B"
5. validate process (it is  OK)
6. save it
  
Actual results:
Alert "Unable to perform user action due to error(s).
Validate your process before saving, and view server logs to see error details."

Server.log: 
-> ERROR [STDERR] (http-127.0.0.1-8080-31) org.eclipse.emf.ecore.resource.Resource$IOWrappedException: The reference to entity "B" must end with the ';' delimiter.

-> ERROR [org.jbpm.designer.web.profile.impl.JbpmProfileImpl] (http-127.0.0.1-8080-31) java.lang.NullPointerException

Expected results:
The validator catches invalid form of property "Task Name" and save process will be ignore this problem.

Additional info:
Comment 1 Tihomir Surdilovic 2012-10-17 13:26:38 EDT
This should be set as duplicate of 864920 which is already fixed.
Comment 2 Rajesh Rajasekaran 2012-10-24 11:53:39 EDT

*** This bug has been marked as a duplicate of bug 864920 ***

Note You need to log in before you can comment on or make changes to this bug.