Bug 866887 - Anaconda defaults keyboard layout to US for all languages
Anaconda defaults keyboard layout to US for all languages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
: i18n, Regression
: 885784 (view as bug list)
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-16 05:09 EDT by Akira TAGOH
Modified: 2013-01-09 04:06 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-18.37.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-14 22:17:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-10-16 05:09:49 EDT
Description of problem:
When I select Japanese at the language selection window, anaconda shows Asia/Tokyo as the timezone and Japanese as the language right. but the keyboard layout is English. though when I try to change it, the list has English and Japanese. it should appears at first.

Version-Release number of selected component (if applicable):
anaconda-18.16-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1.select Japanese
2.see the keyboard layout
3.
  
Actual results:
English

Expected results:
Japanese

Additional info:
I tried it on Fedora-18-Beta-TC4-x86_64-Live-Desktop.iso. and the desktop language is English though, when I changed it to Japanese and re-log in, the default keyboard layout is still English but no Japanese in the selected list, but anyway. I don't know how it is relevant to this. just FYI
Comment 1 Vratislav Podzimek 2012-10-16 15:23:32 EDT
(In reply to comment #0)
> Description of problem:
> When I select Japanese at the language selection window, anaconda shows
> Asia/Tokyo as the timezone and Japanese as the language right. but the
> keyboard layout is English. though when I try to change it, the list has
> English and Japanese. it should appears at first.
Correct me if I misunderstood your description:

You have selected Japanese as a language and Anaconda correctly set Asia/Tokyo timezone and added Japanese layout. The problem you see is that English layout is first in the list (default) and Japanese is the second one.

Right?

If this is the case, I'm afraid we cannot do anything about it. The reason is that when setting language, we just add matching layout and leave English were it is. If we wanted to (re)move English layout, we would have to warn user and provide a way to skip these actions. Adding language related layout is just a guess and it really is up to users theirselves to set layout settings to the state they want. That's what all the plus, minus, up-arrow, down-arrow and preview buttons are for.

And as for your additional comment:
There was a little change that anaconda's configuration file in /etc/X11/xorg.conf.d/ directory now has "00-" prefix instead of "01-" which means that the other tools (systemd-localed, system-config-keyboard, gnome settings, ...) can generate configuration files overriding settings from the installation. I'm afraid these tools use "00-" too, which is wrong and we cannot do anything about it, because "00" is the lowest value we can use.
Comment 2 Akira TAGOH 2012-10-16 21:52:25 EDT
(In reply to comment #1)
> You have selected Japanese as a language and Anaconda correctly set
> Asia/Tokyo timezone and added Japanese layout. The problem you see is that
> English layout is first in the list (default) and Japanese is the second one.
> 
> Right?

Yes, that's true.

> If this is the case, I'm afraid we cannot do anything about it. The reason
> is that when setting language, we just add matching layout and leave English
> were it is. If we wanted to (re)move English layout, we would have to warn
> user and provide a way to skip these actions. Adding language related layout
> is just a guess and it really is up to users theirselves to set layout
> settings to the state they want. That's what all the plus, minus, up-arrow,
> down-arrow and preview buttons are for.

Aha. so anaconda sets English layout as the default keyboard layout now regardless of what language one select ?
I'm not fully understanding why any warnings and/or actions to skip it is necessary though, at least we had an opportunity to change/select the keyboard layout in the past and there were no warnings about it, plus, it wasn't always English layout.

> And as for your additional comment:
> There was a little change that anaconda's configuration file in
> /etc/X11/xorg.conf.d/ directory now has "00-" prefix instead of "01-" which
> means that the other tools (systemd-localed, system-config-keyboard, gnome
> settings, ...) can generate configuration files overriding settings from the
> installation. I'm afraid these tools use "00-" too, which is wrong and we
> cannot do anything about it, because "00" is the lowest value we can use.

I guess you may misunderstood the case and even if you don't, I don't see why it affects a guess of the keyboard layout in anaconda. anyway, I don't have any files under /etc/X11/xorg.conf.d even when I change the language and the keyboard layout from System Settings on Live. and no Japanese keyboard layout in the list too. I should file a separate bug for that perhaps?
Comment 3 Vratislav Podzimek 2012-10-17 04:18:49 EDT
I forgot to ask the very basic question:
You are describing issues of live installation?

In live installation you have Gnome's, KDE's,... layout configuration tools to set layouts during installation process. Keeping this tools and the Anaconda synchronized would be really hard and therefore, in live installation, if you configure layouts in the installer, this configuration is applied only on the installed system, not in the installation environment. You can use the tools provided by the desktop environment to configure layouts for the installation process.

This change should definitely be described somewhere and also there should probably be a warning on the Keyboard spoke.

On the other hand "non-live" installation should work just like I've described in comment #1. When you choose Japanese as a language, matching layout is appended to the list of layouts (and you can switch to it with Alt+Shift). On the Keyboard spoke you can then change the ordering of layouts, add some additional layouts, remove layouts and whatever you want to do. These changes are applied to both the runtime installation environment and the installed system.
Comment 4 Akira TAGOH 2012-10-17 05:58:15 EDT
(In reply to comment #3)
> I forgot to ask the very basic question:
> You are describing issues of live installation?

Ah, I presumed you see it was on Live as I wrote an iso file what I used.

> In live installation you have Gnome's, KDE's,... layout configuration tools
> to set layouts during installation process. Keeping this tools and the
> Anaconda synchronized would be really hard and therefore, in live
> installation, if you configure layouts in the installer, this configuration
> is applied only on the installed system, not in the installation
> environment. You can use the tools provided by the desktop environment to
> configure layouts for the installation process.

Hmm, it _was_ applied before, when anaconda didn't allow to have a language selector on Live. changing the language on Live Desktop was only way to make anaconda localized. this is why I was expecting it should be. that said IMHO it was a bad idea and good to see we have a language selector on even Live now.

Anyway, that sounds strange to me then, for the issue I wrote in the Additional Information. obviously it affected to anaconda (badly) i.e. it caused missing Japanese keyboard layout from the guessed list.

FWIW I tested some languages but not all on Live installer, I haven't yet seen any languages so far which has non-English keyboard layout. so I tend to think:

(In reply to comment #2)
> Aha. so anaconda sets English layout as the default keyboard layout now
> regardless of what language one select ?

This guess may be correct. then I'm wondering why anaconda doesn't set the guessed keyboard layout as a primary layout.
Comment 5 Vratislav Podzimek 2012-10-17 10:04:43 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > I forgot to ask the very basic question:
> > You are describing issues of live installation?
> 
> Ah, I presumed you see it was on Live as I wrote an iso file what I used.
Yeah, I've overlooked it, sorry.

> 
> > In live installation you have Gnome's, KDE's,... layout configuration tools
> > to set layouts during installation process. Keeping this tools and the
> > Anaconda synchronized would be really hard and therefore, in live
> > installation, if you configure layouts in the installer, this configuration
> > is applied only on the installed system, not in the installation
> > environment. You can use the tools provided by the desktop environment to
> > configure layouts for the installation process.
> 
> Hmm, it _was_ applied before, when anaconda didn't allow to have a language
> selector on Live. changing the language on Live Desktop was only way to make
> anaconda localized. this is why I was expecting it should be. that said IMHO
> it was a bad idea and good to see we have a language selector on even Live
> now.
> 
> Anyway, that sounds strange to me then, for the issue I wrote in the
> Additional Information. obviously it affected to anaconda (badly) i.e. it
> caused missing Japanese keyboard layout from the guessed list.
> 
> FWIW I tested some languages but not all on Live installer, I haven't yet
> seen any languages so far which has non-English keyboard layout. so I tend
> to think:
> 
> (In reply to comment #2)
> > Aha. so anaconda sets English layout as the default keyboard layout now
> > regardless of what language one select ?
> 
> This guess may be correct. then I'm wondering why anaconda doesn't set the
> guessed keyboard layout as a primary layout.
Since I'm not sure I really understand what steps you did and in what order, I'd rather explain you the logic in anaconda's language and keyboard settings in case of live installation:

1.) If you set system language in gnome-control-center (g-c-c) or any other tool before you start the installer, Anaconda should be translated. But language choice in Anaconda is independent on the system language and affects only the installer. Thus selecting language in Anaconda has no effect on the rest of the system (technically said: it just sets LANG variable for the process running anaconda, not the system-wide LANG variable).

2.) If you choose language in Anaconda, the guessed layout is appended to the list of layouts leaving English in the list as the first item (and thus the default layout). This is to prevent layout changes before the user can see what happened. If user wants some other layout to be the default he/she has to change the ordering manually by clicking arrow buttons on the Keyboard spoke (below the list).

I hope this explains also your case.

If you set _system_ language to Japanese, log out, log in and run Anaconda, it may be (should be) translated. But if you choose English in the list of languages (default), no layout is added and Anaconda should run in English (though some Gtk widgets may have problems with language-swiching [e.g. the ON/OFF switch on the Date&Time spoke]).

Please let me know if anything you have seen doesn't work the way I've described in this comment.
Comment 6 Akira TAGOH 2012-10-17 23:33:03 EDT
(In reply to comment #5)
> 1.) If you set system language in gnome-control-center (g-c-c) or any other
> tool before you start the installer, Anaconda should be translated. But
> language choice in Anaconda is independent on the system language and
> affects only the installer. Thus selecting language in Anaconda has no
> effect on the rest of the system (technically said: it just sets LANG
> variable for the process running anaconda, not the system-wide LANG
> variable).

Sure. but not exactly since anaconda has a language selection at first. in this case I would expect to set the default language according to current locale, but anaconda is always set to English here too.

> 2.) If you choose language in Anaconda, the guessed layout is appended to
> the list of layouts leaving English in the list as the first item (and thus
> the default layout). This is to prevent layout changes before the user can
> see what happened. If user wants some other layout to be the default he/she
> has to change the ordering manually by clicking arrow buttons on the
> Keyboard spoke (below the list).

Right. that's good point. so why does anaconda not have a look at the system's keyboard layout rather than defaulting English layout? if both is same, you don't need to worry about it right?

> If you set _system_ language to Japanese, log out, log in and run Anaconda,
> it may be (should be) translated. But if you choose English in the list of
> languages (default), no layout is added and Anaconda should run in English
> (though some Gtk widgets may have problems with language-swiching [e.g. the
> ON/OFF switch on the Date&Time spoke]).

I see the logic. but it's not my case. even though both the system language and the installer language is Japanese, anaconda seems dropped Japanese keyboard layout from the keyboard spoke. and apparently this happens only when the system language is Japanese (I'm not sure for other languages because I don't have non-Japanese keyboard and no matter what language I select, if I don't have, it won't appears on the keyboard spoke right?)
Comment 7 Vratislav Podzimek 2012-10-18 03:48:17 EDT
1)
Well, the good point you suggest is, that both language and keyboard settings should probably be loaded from the runtime system when anaconda starts. I'll look at this.

2)
The other issue you are encountering (Japanese layout not added when the system language is Japanese) is really weird. There should be no difference between cases when system language is English or Japanese. I will look at this too, but I hope it will be fixed by resolving 1).
Comment 8 Jens Petersen 2012-10-18 05:13:16 EDT
I think there is some misunderstanding here about languages and kbds.
Let me see if I can make some comments to clarify:

* Anaconda is defaulting to *US* layout (there is no such thing as
  as English layout)

* Japan layout is also ASCII based so defaulting to both US + JP
  layouts is kind of redundant for most users.

* introducing two default layouts is only really meaningful
  for native keyboards that are non-ASCII, for example Russian, etc?
  For other countries forcing people to use US layout by default
  is unhelpful and makes the post-install UX confusing.

I think what is needed is a list of countries with non-ASCII
keyboards that need both US and native keyboard layout and only
to setup US layout as the default for those - all others
(GB, DE, FR, etc, etc) should just default to their nation
standard keyboard layout IMHO, as anaconda as traditionally
and correctly done.  Just need to take care of a few potential
exceptions like Russian Cyrillic layout, etc.

Forcing everyone to use US layout by default just because
of a few exceptions is not the right solution anyway IMO.
Comment 9 Vratislav Podzimek 2012-10-22 05:35:06 EDT
(In reply to comment #8)
> I think there is some misunderstanding here about languages and kbds.
> Let me see if I can make some comments to clarify:
> 
> * Anaconda is defaulting to *US* layout (there is no such thing as
>   as English layout)
Well, the name of the layout (as X knows it) is "us" and the description is "English (US)"

> 
> * Japan layout is also ASCII based so defaulting to both US + JP
>   layouts is kind of redundant for most users.
> 
> * introducing two default layouts is only really meaningful
>   for native keyboards that are non-ASCII, for example Russian, etc?
>   For other countries forcing people to use US layout by default
>   is unhelpful and makes the post-install UX confusing.
> 
> I think what is needed is a list of countries with non-ASCII
> keyboards that need both US and native keyboard layout and only
> to setup US layout as the default for those - all others
> (GB, DE, FR, etc, etc) should just default to their nation
> standard keyboard layout IMHO, as anaconda as traditionally
> and correctly done.  Just need to take care of a few potential
> exceptions like Russian Cyrillic layout, etc.
I'm sorry, but we are not going to maintain a list of layouts that are "similar enough" to English (US).

> 
> Forcing everyone to use US layout by default just because
> of a few exceptions is not the right solution anyway IMO.
This is not solution invented in Anaconda. When you boot the default system (e.g. installation environment) with no parameters given, the default language is English and default layout is English (US). So, on the first screen in Anaconda English (US) is active layout (in case no keyboard/keymap). Changing it in the background without warning the user is not something we would like to do.

And the main thing -- I really don't see any problem in setting English (US) and a language-matching layout by default when we give user a way to modify the settings and set any layout as his/her default.
Comment 10 Akira TAGOH 2012-10-22 06:07:19 EDT
(In reply to comment #9)
> I'm sorry, but we are not going to maintain a list of layouts that are
> "similar enough" to English (US).

What he were referring here isn't something like that AFAICS. in most cases, users would prefer the guessed layout except the above cases he mentioned. those layouts are designed to type characters in their native language and not capable to type ASCII characters at all. for example, see Bug#474010.

So maybe the logic looks like this:
1. add the guessed layout to the list in the keyboard spoke
2. if it's in the black list (i.e. not supporting well to type ASCII), add English layout to the top

This should perfectly works IMHO.

> This is not solution invented in Anaconda. When you boot the default system
> (e.g. installation environment) with no parameters given, the default
> language is English and default layout is English (US). So, on the first
> screen in Anaconda English (US) is active layout (in case no
> keyboard/keymap). Changing it in the background without warning the user is
> not something we would like to do.

Well, that's true if there are no information around the system to make it improved for better experience. but I don't think there are nothing we can do more as I suggested above :) to summarize, what we are suggesting is NOT to request changing the default anyway, but to provide better default language and better default keyboard layout as far as possible.
Comment 11 Jens Petersen 2012-10-24 04:14:30 EDT
(In reply to comment #9)
> > * Japan layout is also ASCII based so defaulting to both US + JP
> >   layouts is kind of redundant for most users.

BTW this was just given as one common example - not a special case.

> I'm sorry, but we are not going to maintain a list of layouts that are
> "similar enough" to English (US).

All that is needed is a short list of country layouts that do not provide
ASCII input: I think Russia is the most common example and there are
some others (maybe Ukraine, Greece, sr-cyr, etc?).
"US" should be provided as the default layout only for
these cases, and not others.

Defaulting all Western European users (France, Germany, etc)
to US layout seems wrong, and may cause users to create
unexpected passwords, etc.
The same goes for Japan and Korea that use national qwerty variants.

I think most countries not using "US" layout have default layouts
that support ASCII, and therefore do not need the additional "US" layout.
So better to assume that.

> This is not solution invented in Anaconda. When you boot the default system
> (e.g. installation environment) with no parameters given, the default
> language is English and default layout is English (US). So, on the first
> screen in Anaconda English (US) is active layout (in case no
> keyboard/keymap). 

Well previously the first (or second) anaconda screen was keyboard selection...

At least users can use the mouse on the frontpage to select their language if they are not familiar with US layout.

> Changing it in the background without warning the user is
> not something we would like to do.

While I hear what you are saying I still think it would be better to change
layout in anaconda after the frontpage - then users will see the suggested
layout displayed in the hub keyboard section.  Right now it is
not obvious at all from the hub that native layout is available on level3
without going into the kbd spoke.

If people really want "US" they can add it themselves there:
something they could not do before. :-)
Comment 12 Vratislav Podzimek 2012-10-24 04:27:36 EDT
I understand the suggestions. But before I make the necessary changes, I'd like to know the opinion of Chris and Máirín first.
Comment 13 Jens Petersen 2012-11-17 00:14:30 EST
Was there any further update?

At the very least I would suggest changing the hub keyboard section from:

"Keyboard
 English (English (US))"

to displaying:

"Keyboard
 English (US), Japanese"


(please no parens inside parens in UI... :)
Comment 14 Máirín Duffy 2012-11-20 23:54:41 EST
Hey Vratislav,

I know it's late now, so I don't know what timeline you'd look at for accounting for this, but what if we added a checkbox on the language selection screen, at the bottom of the list of languages "Set keyboard to default layout for selected language."

We do have the space to put a checkbox on that screen - it might be an interesting solution if folks notice it - so they are explicitly opting in to change their layout rather than us springing it on them?
Comment 15 Máirín Duffy 2012-11-20 23:55:28 EST
(setting this back to NEEDINFO, I accidentally cleared it. Sorry Jens)
Comment 16 Vratislav Podzimek 2012-11-26 04:31:31 EST
(In reply to comment #14)
> Hey Vratislav,
> 
> I know it's late now, so I don't know what timeline you'd look at for
> accounting for this, but what if we added a checkbox on the language
> selection screen, at the bottom of the list of languages "Set keyboard to
> default layout for selected language."
> 
> We do have the space to put a checkbox on that screen - it might be an
> interesting solution if folks notice it - so they are explicitly opting in
> to change their layout rather than us springing it on them?
This should be an easy fix. I'll send a patch and screenshot to anaconda-patches.
Comment 17 Vratislav Podzimek 2012-11-27 07:41:26 EST
Patch sent to anaconda-patches.
Comment 18 Jens Petersen 2012-12-10 04:49:24 EST
Proposing as a F18 Blocker.

This new behaviour forces a US layout on all users
which is unnecessary and a regression from previous
longstanding Fedora behaviour.
Comment 19 Chris Lumens 2012-12-10 15:33:40 EST
*** Bug 885784 has been marked as a duplicate of this bug. ***
Comment 20 Leslie Satenstein 2012-12-11 13:43:02 EST
Just DVD installed the Dec 8 RC.  I have a French(Canada) keyboard.
To be able to complete the installation, I first delete the English (USA) PC105 layout, then add the French(Canada).  The keymaps are correct for all the gui interfaces, but the terminal mode via ctl-alt-F2..ctl-alt-F6 remain English (USA).  For keyboard switching, I chose menu.

I even test installation via the reverse method. Add the French layout, move it to first position.  If I do that, the English (USA) keyboard persists until I delete the English layout. If I add the English layout after confirming that the French Layout is recognized, the French Keyboard layout remains the default.

What is also missing is the ability to put the Euro character on the E or the 5 key, as is possible with F17.

This problem was also present in the 20 November Beta.
Comment 21 Leslie Satenstein 2012-12-11 13:59:09 EST
I wanted to add some Information that may be pertenant. If I click on the keyboard layout icon, for both the English and the French keyboard, I get the English layout.

Last month I installed the Nov 20th Beta RC1 DVD. I had the same problem until I installed about 400 megs of updates. Then the graphical representation of each of the keyboards was correct.
Comment 22 Fedora Update System 2012-12-11 19:54:39 EST
anaconda-18.37.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
Comment 23 Vratislav Podzimek 2012-12-12 05:04:24 EST
(In reply to comment #21)
> I wanted to add some Information that may be pertenant. If I click on the
> keyboard layout icon, for both the English and the French keyboard, I get
> the English layout.
> 
> Last month I installed the Nov 20th Beta RC1 DVD. I had the same problem
> until I installed about 400 megs of updates. Then the graphical
> representation of each of the keyboards was correct.
The keyboard layout icon/button runs an external dialog provided by the libgnomekbd. Anaconda just passes the layout name to it. If you can reproduce this with some recent image, please file a separate bug against anaconda and I will have a look at it and probably reassing it to libgnomekbd. Thanks!
Comment 24 Kamil Páral 2012-12-12 05:40:48 EST
Short summary for the blocker bug meeting:
The crux of this bug is the following - if you select a language (e.g. Japanese) in the language selection screen, anaconda currently adds matching keyboard layout (Japanese) into the keyboard spoke, but only as the _second_ layout, under English layout. You can of course visit the spoke and adjust the layout priorities. But if you don't, the installed system will have English and Japanese layouts available, with English being active by default.

The reporters want a different behavior, where Japanese keyboard layout is automatically selected as the default (top) layout, if you select Japanese language. Then you don't have to visit the spoke and adjust the priorities.

Vratislav modified Anaconda to include a checkbox on the language screen that implements the requested behavior (the checkbox is unselected by default, which is the former behavior).
Comment 25 Vratislav Podzimek 2012-12-12 05:45:35 EST
(In reply to comment #22)
> anaconda-18.37.1-1.fc18 has been submitted as an update for Fedora 18.
> https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.
> fc18
This anaconda build includes a patch that adds a checkbox below the list of available languages that can be used to get keyboard layout configuration using only the language-default layout. I.e. no English layout on the first place.
Comment 26 Adam Williamson 2012-12-12 12:43:35 EST
Discussed at 2012-12-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-10/f18final-blocker-review-3.2012-12-10-17.13.log.txt . Rejected as a blocker but accepted as NTH: it doesn't violate the criteria but it's an annoyance for non-en-US users that cannot be fixed with an update.
Comment 27 Adam Williamson 2012-12-12 13:14:43 EST
Correction to above: discussed at 2012-12-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-12/f18final-blocker-review-4.2012-12-12-17.01.log.txt , not 12-10.
Comment 28 Fedora Update System 2012-12-12 15:41:23 EST
Package anaconda-18.37.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19991/anaconda-18.37.1-1.fc18
then log in and leave karma (feedback).
Comment 29 Leslie Satenstein 2012-12-13 20:37:41 EST
I am wondering why this checkbox approach is necessary.  In the past (F17 and earlier), we were asked for langauge (I use English), then for keyboard selection.

I put French(Canada) first, and English (USA) second, or I deleted the existing keyboard and placed one, exlusively "the French(Canada) layout". Because it is first, in the keyboard selection list it was the keyboard that was installed for terminal mode. 

I realize that the desire to separate "terminal mode" keyboard selection from GUI keyboard selection(s), but the way it was done in the past was just fine, as long as it is documented with a sentence or two.  

The sentence "Your first keyboard in the list will the default for terminal mode"
and porting that F17 anaconda logic to this keyboard selection area is a good solution and I think, all that is required.
Comment 30 Adam Williamson 2012-12-13 20:48:51 EST
The fix is present in smoke6 and works correctly. If I install in French and check the checkbox, I get French layout during and post install.
Comment 31 Fedora Update System 2012-12-14 22:17:49 EST
anaconda-18.37.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Leslie Satenstein 2012-12-18 09:33:33 EST
Problem still persists. 

Please learn how anaconda for F6 through F17 did it right. The top most keyboard in the list of keyboards is chosen as the default for terminal mode.

Selecting the language of use is different from selecting the keyboard of use.

Also, please note. If we use the new functionality as presented in TC3, which is pushed to stable, the problem is still present, only worse.

There is no back button or undo. If the wrong choice is made via the checkbox function, the only recourse is to reboot and start over.

This is not a solved issue. It should not be closed. The problem persists.
Comment 33 Leslie Satenstein 2012-12-18 09:36:29 EST
Adam' report (comment 30) does not address the problem. I want to work Fedora in English with a Canadian French ca(fr) keyboard.  

When the installation is completed, terminal mode must work in English with the Canadian French keyboard. Currently this is not possible.
Comment 34 Adam Williamson 2012-12-18 17:13:41 EST
leslie, you are talking about a bug which is not this bug. you can't just go around typing comments into vaguely related bugs, that doesn't work. this bug is not the bug for the problem you are describing.
Comment 35 Adam Williamson 2012-12-18 17:14:31 EST
comment #24 describes what this bug covers. you can clearly see it is not the bug for the problem you are describing. there is another bug for the problem you are describing.
Comment 36 Leslie Satenstein 2012-12-19 17:54:50 EST
Adam
The gentleman complained about Japanese English keyboard during kde use.
Within KDE or within Gnome, the solution was easy.  Delete the keyboard that is not wanted. The Desired keyboard will appear first.
Then reinsert the keyboard that was deleted.

With that, within Gnome and KDE, the correct keyboard layout is used.


You are right. 

I am complaining about ca(fr) being the desired keyboard for installation of F18, where the language chosen for installation is English. Prior to clicking to Install, the titles in anaconda GUI show that the ca(fr) was selected.


but on the reboot the terminal mode reacts as the Standard American English PC105 or PC102 keyboard. not the ca(fr) that was chosen.

So, how do I reset the terminal to recognize the ca(fr) keyboard. Which entry in /etc do I look at.
Comment 37 Adam Williamson 2012-12-19 20:02:04 EST
/etc/vconsole.conf .
Comment 38 Adam Williamson 2012-12-19 20:09:41 EST
Huuummmm. I think the source of a lot of confusion here is that different keymaps behave differently.

I just tried with French Canadian and indeed it doesn't seem to work at all: you choose to install in English, then add French (Canadian) layout in the keyboard spoke, move it to the top of the list, complete install, and you get US keyboard layout in the installed system.

French (French) behaves correctly, though. Somehow, different layouts work differently.

I wonder if this is to do with https://bugzilla.redhat.com/show_bug.cgi?id=882212 ?

And I wonder if the people getting different results with 'Czech' are using different Czech variants?

Anyhow, we need to clean this up into correct reports...
Comment 39 Adam Williamson 2012-12-19 20:15:19 EST
sorry, I meant https://bugzilla.redhat.com/show_bug.cgi?id=875567 not 882212.
Comment 40 Vratislav Podzimek 2012-12-21 05:51:38 EST
(In reply to comment #38)
> Huuummmm. I think the source of a lot of confusion here is that different
> keymaps behave differently.
> 
> I just tried with French Canadian and indeed it doesn't seem to work at all:
> you choose to install in English, then add French (Canadian) layout in the
> keyboard spoke, move it to the top of the list, complete install, and you
> get US keyboard layout in the installed system.
> 
> French (French) behaves correctly, though. Somehow, different layouts work
> differently.
Please see https://bugzilla.redhat.com/show_bug.cgi?id=859867#c16 for the explanation.
Comment 41 Adam Williamson 2012-12-21 14:36:20 EST
So I've filed https://bugzilla.redhat.com/show_bug.cgi?id=889562 to cover the case of keymaps which just aren't working for VConsole at all because systemd-localed doesn't do the X->console translation for them. This is the French Canadian case. Lesie, please follow that bug.
Comment 42 Leslie Satenstein 2013-01-02 18:54:43 EST
I an following the bug via 890343
Comment 43 Leslie Satenstein 2013-01-02 18:56:36 EST
What file do I modify in /etc to force Canadian French Keyboard?
Comment 44 Adam Williamson 2013-01-03 22:58:01 EST
/etc/vconsole.conf . change it to read:

KEYMAP=cf
Comment 45 Adam Williamson 2013-01-05 04:31:54 EST
Note that the change which was made in response to this bug has unfortunate consequences for users of Russian-type layouts (discussed briefly above) who check the checkbox:

https://bugzilla.redhat.com/show_bug.cgi?id=892110
Comment 46 Jens Petersen 2013-01-07 05:04:37 EST
See comment 11 in relation to non-latin layouts... I finally noticed the checkbox hack on the language welcome page.

Note You need to log in before you can comment on or make changes to this bug.