Bug 893135 - switching from English to Spanish from the two default created keyboard results in still using English (workaround=remove the English one)
switching from English to Spanish from the two default created keyboard resul...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 12:09 EST by Reartes Guillermo
Modified: 2013-01-09 04:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 04:06:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing the new (RC2) default keyboard configuration for Spanish (43.94 KB, image/png)
2013-01-08 12:09 EST, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-01-08 12:09:35 EST
Created attachment 674971 [details]
screenshot showing the new (RC2) default keyboard configuration for Spanish

Description of problem:

Since RC2, when i select Spanish in the Welcome Screen, anaconda puts two keyboards layout in the Keyboard Spoke. 

An English (first) and a Spanish (second) keyboard are present in the Keyboard Spoke. 

This is NEW behavior. (in RC1 only English was there).

While that is cool, it is expected that the first keyboard to be Spanish and not English.

The issue is that if one moves "up" the Spanish one, anaconda still keeps using the English one, even if one leaves the Keyboard Spoke.

One needs to remove the English keyboard.

Version-Release number of selected component (if applicable):
RC2 (18.37.11)

How reproducible:
always

Steps to Reproduce:
1. boot, select Spanish in the Welcome Screen
2. enter Keyboard Spoke
3. move "up" the Spanish Keyboard
  
Actual results:
English still in use (no ñ)

Expected results:
Spanish (ñ)

Additional info:
Comment 1 Vratislav Podzimek 2013-01-09 04:06:47 EST
You can check the checkbutton below the language selection. That will make Anaconda set just the Spanish layout. The previous behaviour was a bug (see bug #891489). The ordering is discussed in bug #866887 in comments 1-25 or so.

Since the checkbutton is supposed to work the way I've described (thus "fixing" this bug), I'm closing this bug as WORKSFORME. If it fails to work the way I've described, please create a new bug describing what happens.

Note You need to log in before you can comment on or make changes to this bug.