Bug 867039 - [webadmin] Webadmin allows input of CPU pinning for migratable VMs
[webadmin] Webadmin allows input of CPU pinning for migratable VMs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
All All
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Gilad Chaplik
Ido Begun
sla
:
: 868197 (view as bug list)
Depends On:
Blocks: 915537 917401
  Show dependency treegraph
 
Reported: 2012-10-16 11:25 EDT by Ido Begun
Modified: 2016-02-10 15:13 EST (History)
11 users (show)

See Also:
Fixed In Version: sf9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11972 None None None Never
oVirt gerrit 9664 None None None Never

  None (edit)
Description Ido Begun 2012-10-16 11:25:04 EDT
Description of problem:
Currently webadmin allows input of CPU pinning topology on migratable VMs, even though backend ignores the pinning info.
CPU pinning topology field should be grayed out if VM is migratable.


Version-Release number of selected component (if applicable):
rhevm-3.1.0-20.el6ev

How reproducible:
100%

Steps to Reproduce:
Create a VM without checking "Run VM on the selected host (no migration allowed)"
  
Actual results:
Webadmin allows input of CPU pinning info

Expected results:
Webadmin should not allow input of CPU pinning info

Additional info:
Comment 1 Simon Grinberg 2012-10-16 13:48:17 EDT
As far as I recall the agreement was that we do not force non-migrate on such a VM but rather allow it.

From the feature page:
"Live migration may fail, if destination host cannot support the relevant pinning request. "

http://wiki.ovirt.org/wiki/Features/Design/cpu-pinning

If the backend ignores the pining this is the real bug  - is this the case?
If so please change summary accordingly, otherwise please close as not a bug.
Comment 2 Ido Begun 2012-10-18 08:50:25 EDT
The feature page refers only to upstream. According to Doron, migration is disabled for migratable VM's on downstream.
Comment 3 Doron Fediuck 2012-10-21 11:30:00 EDT
UI should enable or disable this selection based on CpuPinningEnabled configuration value, which has to be true in the first place.
Next, CpuPinMigrationEnabled configuration value should be set to True to enable pinning. Otherwise pinning text box should be disabled.

Another valid combination for the pinning text box to be enabled is CpuPinMigrationEnabled set to false, and one of the pin-to-host radio buttons is checked.
Comment 4 Gilad Chaplik 2012-12-23 08:12:08 EST
sent to gerrit (http://gerrit.ovirt.org/#/c/9664/)
Comment 10 Doron Fediuck 2013-01-20 07:51:22 EST
Testing should be done to verify 'CPU Pinning topology' accepts input (editable) only for non-migratable VMs.
These are the conditions to create non-migratable VMs and allow pinning:

CpuPinningEnabled configuration value, which has to be true in the first place.
Next, CpuPinMigrationEnabled configuration value should be set to True to enable pinning. Otherwise pinning text box should be disabled.

Another valid combination for the pinning text box to be enabled is CpuPinMigrationEnabled set to false, and one of the pin-to-host radio buttons is checked.
Comment 11 Ido Begun 2013-01-29 04:59:50 EST
(In reply to comment #10)
> Testing should be done to verify 'CPU Pinning topology' accepts input
> (editable) only for non-migratable VMs.
> These are the conditions to create non-migratable VMs and allow pinning:
> 
> CpuPinningEnabled configuration value, which has to be true in the first
> place.
> Next, CpuPinMigrationEnabled configuration value should be set to True to
> enable pinning. Otherwise pinning text box should be disabled.
> 
> Another valid combination for the pinning text box to be enabled is
> CpuPinMigrationEnabled set to false, and one of the pin-to-host radio
> buttons is checked.

Do we allow a VM with 'Allow VM migration only upon Administrator specific request' checked to be CPU pinned? or only when 'Run VM on the selected host' is checked?

Either way, 'CPU Pinning topology' is editable when the 'specific' host radio button is checked, even if none of the boxes mentioned above are checked (i.e. VM is migratable) (tested on SF4).
Comment 12 Laszlo Hornyak 2013-02-27 03:35:46 EST
*** Bug 868197 has been marked as a duplicate of this bug. ***
Comment 13 Ido Begun 2013-03-03 11:15:36 EST
OK - SF9

The 'CPU Pinning topology' is no longer editable when when 'Run VM on the selected host' is not checked.
Comment 14 Itamar Heim 2013-06-11 05:23:52 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 05:45:00 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.