Bug 868493 - [abrt] owncloud-client-1.1.0-1.fc17: vsnprintf: Process /usr/bin/owncloud was killed by signal 11 (SIGSEGV)
[abrt] owncloud-client-1.1.0-1.fc17: vsnprintf: Process /usr/bin/owncloud was...
Status: CLOSED DUPLICATE of bug 867083
Product: Fedora
Classification: Fedora
Component: mirall (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joseph Marrero
Fedora Extras Quality Assurance
abrt_hash:3b1e02354f76f442ad64ee6f451...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 06:10 EDT by markusN
Modified: 2012-10-20 12:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-20 12:16:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (5.08 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: environ (3.22 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: backtrace (295.21 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: cgroup (130 bytes, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: maps (66.12 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: dso_list (14.44 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: var_log_messages (3.00 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
File: open_fds (1.09 KB, text/plain)
2012-10-20 06:11 EDT, markusN
no flags Details
strace output of owncloud run + crash (36.56 KB, text/plain)
2012-10-20 11:09 EDT, markusN
no flags Details

  None (edit)
Description markusN 2012-10-20 06:10:58 EDT
Description of problem:
While the dependencies are handled correctly now, still SIGSEGV (signal 6) for mirall after a while of syncing on several GB of data over slow network connection.

Version-Release number of selected component:
owncloud-client-1.1.0-1.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        owncloud
crash_function: vsnprintf
kernel:         3.6.1-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 vsnprintf at /usr/include/bits/stdio2.h:78
: #3 csync_log_cb at /usr/src/debug/ocsync-0.60.0/src/csync.c:981
: #4 owncloud_stat at /usr/src/debug/ocsync-0.60.0/modules/csync_owncloud.c:1048
: #5 owncloud_open at /usr/src/debug/ocsync-0.60.0/modules/csync_owncloud.c:1310
: #6 csync_vio_open at /usr/src/debug/ocsync-0.60.0/src/vio/csync_vio.c:231
: #7 _csync_push_file at /usr/src/debug/ocsync-0.60.0/src/csync_propagate.c:205
: #8 _csync_new_file at /usr/src/debug/ocsync-0.60.0/src/csync_propagate.c:611
: #9 _csync_propagation_file_visitor at /usr/src/debug/ocsync-0.60.0/src/csync_propagate.c:1259
: #11 _rbtree_subtree_walk at /usr/src/debug/ocsync-0.60.0/src/std/c_rbtree.c:152
: #23 c_rbtree_walk at /usr/src/debug/ocsync-0.60.0/src/std/c_rbtree.c:169
Comment 1 markusN 2012-10-20 06:11:00 EDT
Created attachment 630396 [details]
File: core_backtrace
Comment 2 markusN 2012-10-20 06:11:02 EDT
Created attachment 630397 [details]
File: environ
Comment 3 markusN 2012-10-20 06:11:09 EDT
Created attachment 630398 [details]
File: backtrace
Comment 4 markusN 2012-10-20 06:11:11 EDT
Created attachment 630399 [details]
File: limits
Comment 5 markusN 2012-10-20 06:11:13 EDT
Created attachment 630400 [details]
File: cgroup
Comment 6 markusN 2012-10-20 06:11:16 EDT
Created attachment 630401 [details]
File: maps
Comment 7 markusN 2012-10-20 06:11:18 EDT
Created attachment 630402 [details]
File: dso_list
Comment 8 markusN 2012-10-20 06:11:20 EDT
Created attachment 630403 [details]
File: var_log_messages
Comment 9 markusN 2012-10-20 06:11:22 EDT
Created attachment 630404 [details]
File: open_fds
Comment 10 markusN 2012-10-20 11:09:13 EDT
I have created an strace dump (only relevant parts, see attachment):

This seems to be the issue:

*** glibc detected *** owncloud: free(): invalid pointer: 0x00007f223352db39 ***

I wonder if I could be helpful by installing the debug package (how?).
Comment 11 markusN 2012-10-20 11:09:57 EDT
Created attachment 630452 [details]
strace output of owncloud run + crash
Comment 12 markusN 2012-10-20 11:12:26 EDT
I just realize an important version difference:

rpm -qa | grep owncloud
owncloud-client-1.1.0-1.fc17.x86_64
owncloud-csync-0.60.0-1.fc17.x86_64
owncloud-csync-plugin-owncloud-0.60.0-1.fc17.x86_64
owncloud-csync-libs-0.60.0-1.fc17.x86_64

But:

http://owncloud.org/sync-clients/
-> The latest version of the client is version 1.1.1, released on october 18, 2012. 

Perhaps the wrong owncloud-client version was packaged, hence this bug?
Comment 13 Joseph Marrero 2012-10-20 12:06:54 EDT
The new version of owncloud-client is already packaged should be in the testing soon. (tomorow perhaps) 

The version you tested 1.1.0 was packaged when it went out. 
but 1.1.1 was released same week.

Please test 1.1.1 as soon is available
thanks.
Comment 14 markusN 2012-10-20 12:16:07 EDT

*** This bug has been marked as a duplicate of bug 867083 ***

Note You need to log in before you can comment on or make changes to this bug.