Bug 867118 - limit bugzilla summary to 255 chars
limit bugzilla summary to 255 chars
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
17
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
:
: 869191 (view as bug list)
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-16 15:50 EDT by Alan Schmidt
Modified: 2016-05-11 14:45 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-02 03:14:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Schmidt 2012-10-16 15:50:47 EDT
Description of problem:
Got an error, and the abrt message popped up in my system tray just like downtown. However, upon submission I get the following message:

Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
Creating a new bug
fatal: RPC failed at server.  The text you entered in the Summary field is too long (268 characters, above the maximum length allowed of 255 characters).
(exited with 1)

Of all the fields I may edit, "summary" is not one of them.

Editing "reason" and "comment" didn't help.

Version-Release number of selected component (if applicable):
abrt-gui-2.0.13-1.fc17.x86_64

How reproducible:
Every time I get this error:

connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.203" is not allowed to own the service "com.redhat.NewPrinterNotification" due to security policies in the configuration file

...which happens every time I log in to KDE via NX.

Steps to Reproduce:
1. Log in to KDE via NX
2. Try to report the kde-printer-applet error that results, using abrt-gui
  
Expected results:
EITHER:
"Summary" would simply be truncated, and the original, too-long summary would be automatically added to "comments"

OR:
"Summary" would be editable whenever the auto-generated summary is too long
Comment 1 Jakub Filak 2012-10-23 05:05:05 EDT
*** Bug 869191 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Filak 2012-10-23 05:09:31 EDT
Blocks field was set according to bug 869191 which has been marked as duplicate of this bug.
Comment 3 Adam Williamson 2012-10-23 22:03:41 EDT
For the record, transferring from the dupe the reason for blocker proposal:

"It happens just for certain cases, but it still violates:
 The installer must be able to report failures to Bugzilla and local disk, with appropriate information included 
https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria

Nominating as a Blocker."
Comment 4 Jakub Filak 2012-10-24 06:25:13 EDT
commit b8b998038844fd14fd21b79f5a86b5b374fcc6e9
Author: Jakub Filak <jfilak@redhat.com>
Date:   Tue Oct 23 13:14:24 2012 +0200

    shorten bz summary if its length exceeds 255 chars
    
    - cut summary on 252 characters and append "..."
    - closes rhbz#867118
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
Comment 5 Fedora Update System 2012-10-24 10:44:50 EDT
abrt-2.0.17-1.fc17,libreport-2.0.17-1.fc17,btparser-0.21-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.17-1.fc17,libreport-2.0.17-1.fc17,btparser-0.21-1.fc17
Comment 6 Adam Williamson 2012-10-24 14:16:37 EDT
Discussed at the 2012-10-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-24/f18beta-blocker-review-5.2012-10-24-16.01.log.txt . Rejected as a Beta blocker as this is only a conditional violation of the criterion and, based on experience, it doesn't seem to happen often enough to really be serious enough to block the Beta. Accepted as NTH as any bug which prevents crash reports getting through is worth fixing.
Comment 7 Fedora Update System 2012-10-24 19:55:11 EDT
Package abrt-2.0.17-1.fc17, libreport-2.0.17-1.fc17, btparser-0.21-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.17-1.fc17 libreport-2.0.17-1.fc17 btparser-0.21-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16846/abrt-2.0.17-1.fc17,libreport-2.0.17-1.fc17,btparser-0.21-1.fc17
then log in and leave karma (feedback).
Comment 8 Adam Williamson 2012-10-24 20:19:00 EDT
We need an F18 update too, for F18 blocker/NTH purposes...
Comment 9 Jakub Filak 2012-10-25 03:46:35 EDT
(In reply to comment #8)
> We need an F18 update too, for F18 blocker/NTH purposes...

I created the F18 update yesterday but I did not add this bug the list of fixed bugs because I'm not sure if this bug should be there ...

https://admin.fedoraproject.org/updates/abrt-2.0.17-2.fc18,libreport-2.0.17-1.fc18,btparser-0.21-1.fc18
Comment 10 Fedora Update System 2012-10-25 04:39:29 EDT
abrt-2.0.17-2.fc18, libreport-2.0.17-1.fc18, btparser-0.21-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.17-2.fc18,libreport-2.0.17-1.fc18,btparser-0.21-1.fc18
Comment 11 Alan Schmidt 2012-10-25 22:30:21 EDT
Issue fixed for me in abrt-2.0.17-1. Left karma pursuant to Comment 7.
Comment 12 Fedora Update System 2012-10-26 15:40:13 EDT
Package abrt-2.0.17-2.fc18, libreport-2.0.17-1.fc18, btparser-0.21-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.17-2.fc18 libreport-2.0.17-1.fc18 btparser-0.21-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16944/abrt-2.0.17-2.fc18,libreport-2.0.17-1.fc18,btparser-0.21-1.fc18
then log in and leave karma (feedback).
Comment 13 Adam Williamson 2012-11-02 03:14:58 EDT
Update was pushed stable, closing.

Note You need to log in before you can comment on or make changes to this bug.