Bug 867145 - tigervnc source RPM missing BuildRequires for xmlto-tex
tigervnc source RPM missing BuildRequires for xmlto-tex
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tigervnc (Show other bugs)
6.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 17:26 EDT by Calvin Webster
Modified: 2014-05-23 08:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-23 08:14:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Calvin Webster 2012-10-16 17:26:23 EDT
Description of problem:

tigervnc source RPM is missing BuildRequires for xmlto-tex.

rpmbuild of the source RPM will not complain but fails when attempting to build docs.


Version-Release number of selected component (if applicable):

From base install:
tigervnc-1.0.90-0.17.20110314svn4359


How reproducible:
Always


Steps to Reproduce:

1. Ensure that the "xmlto-tex" pkg is not installed:

yum remove xmlto-tex

2. Attempt to build tigervnc source RPM in a properly setup rpmbuild build environment, resolving all cited build dependencies:

cd ~/rpmbuild
wget http://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/tigervnc-1.0.90-0.17.20110314svn4359.el6.src.rpm
rpmbuild --rebuild tigervnc-1.0.90-0.17.20110314svn4359.el6.src.rpm

  
Actual results:

Build fails while constructing docs, looking for "/usr/share/xmlto/format/docbook/../fo/pdf".

Excerpt from rpmbuild *without* xmlto-tex package installed:
------------------------------------------------------------
...
Making all in xml
make[2]: Entering directory `/home/cwebster/rpmbuild/BUILD/tigervnc-1.0.90-20110314svn4359/unix/xserver/doc/xml'
Making all in dtrace
make[3]: Entering directory `/home/cwebster/rpmbuild/BUILD/tigervnc-1.0.90-20110314svn4359/unix/xserver/doc/xml/dtrace'
/usr/bin/xmlto --searchpath /home/cwebster/rpmbuild/BUILD/tigervnc-1.0.90-20110314svn4359/unix/xserver/doc/xml  xhtml-nochunks Xserver-DTrace.xml
/usr/bin/xmlto --searchpath /home/cwebster/rpmbuild/BUILD/tigervnc-1.0.90-20110314svn4359/unix/xserver/doc/xml  --with-fop pdf Xserver-DTrace.xml
Making portrait pages on A4 paper (210mmx297mm)
sh: /usr/share/xmlto/format/docbook/../fo/pdf: No such file or directory
make[3]: *** [Xserver-DTrace.pdf] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/home/cwebster/rpmbuild/BUILD/tigervnc-1.0.90-20110314svn4359/unix/xserver/doc/xml/dtrace'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/cwebster/rpmbuild/BUILD/tigervnc-1.0.90-20110314svn4359/unix/xserver/doc/xml'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/cwebster/rpmbuild/BUILD/tigervnc-1.0.90-20110314svn4359/unix/xserver/doc'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.CgAq3z (%build)
------------------------------------------------------------


Expected results:

rpmbuild should result in production of 5 binary and 1 source RPMs:

Excerpt from rpmbuild *with* xmlto-tex package installed:
---------------------------------------------------------
...
Wrote: /home/cwebster/rpmbuild/SRPMS/tigervnc-1.0.90-0.17.20110314svn4359.0.1.el6.src.rpm
Wrote: /home/cwebster/rpmbuild/RPMS/i686/tigervnc-1.0.90-0.17.20110314svn4359.0.1.el6.i686.rpm
Wrote: /home/cwebster/rpmbuild/RPMS/i686/tigervnc-server-1.0.90-0.17.20110314svn4359.0.1.el6.i686.rpm
Wrote: /home/cwebster/rpmbuild/RPMS/i686/tigervnc-server-module-1.0.90-0.17.20110314svn4359.0.1.el6.i686.rpm
Wrote: /home/cwebster/rpmbuild/RPMS/noarch/tigervnc-server-applet-1.0.90-0.17.20110314svn4359.0.1.el6.noarch.rpm
Wrote: /home/cwebster/rpmbuild/RPMS/i686/tigervnc-debuginfo-1.0.90-0.17.20110314svn4359.0.1.el6.i686.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.Y9h6xv
+ umask 022
+ cd /home/cwebster/rpmbuild/BUILD
+ cd tigervnc-1.0.90-20110314svn4359
+ rm -rf /home/cwebster/rpmbuild/BUILDROOT/tigervnc-1.0.90-0.17.20110314svn4359.0.1.el6.i386
+ exit 0
---------------------------------------------------------


Additional info:

Patch for tigervnc.spec (between cut lines):

-----%<----------------------------------------------------
--- tigervnc.bad.spec	2011-11-09 12:06:56.000000000 -0500
+++ tigervnc.spec	2012-10-16 16:48:35.655936960 -0400
@@ -24,7 +24,7 @@
 BuildRequires:	mesa-libGL-devel, libXinerama-devel, ImageMagick
 BuildRequires:  freetype-devel, libXdmcp-devel, pam-devel
 BuildRequires:	desktop-file-utils, java-1.5.0-gcj-devel
-BuildRequires:	gnutls-devel
+BuildRequires:	gnutls-devel, xmlto-tex
 
 %ifarch %ix86 x86_64
 BuildRequires: nasm
-----%<----------------------------------------------------

After patching the spec file, rpmbuild properly raises a dependency error:

---------------------------------------------------------------
[cwebster@blackhole rpmbuild]$ rpmbuild -ba SPECS/tigervnc.spec 
error: Failed build dependencies:
	xmlto-tex is needed by tigervnc-1.0.90-0.17.20110314svn4359.el6.i686
[cwebster@blackhole rpmbuild]$ 
---------------------------------------------------------------

After installing the xmlto-tex package, rpmbuild results in an error-free build and complete set of RPMS, as indicated above.
Comment 2 Adam Tkac 2012-10-22 09:21:16 EDT
I assume that you have "doxygen" package installed. Since this pkg is not automatically installed in the minimal tigervnc build root, I'm able to build tigervnc successfully.

I think you can add "--without-doxygen" flag to xserver's ./configure to build tigervnc successfully without xmlto-tex dependency.

In any case, this is not a bug and I'm able to build tigervnc without doxygen pkg installed. Closing.
Comment 3 Calvin Webster 2012-10-26 13:30:48 EDT
Sorry, I was going on the assumption that if a source RPM should contain BuildRequires for whatever is required to build without error. This SRPM does not cite either doxygen or xmlto-tex as dependencies. 

In previous EL versions, this functionality was all contained within the "xmlto" package, which it seems gets installed with the basic developer tools. Not so with xmlto-tex because it was split off of the main package apparently in F10, according to "Ondrej Vasik" in comment #2 of bug 462553 (https://bugzilla.redhat.com/show_bug.cgi?id=462553#c1). 

I realize that your build environment for EL has everything it needs so this isn't a problem for Red Hat builds. Red Had doesn't gain much by fixing this so I understand. I was just trying to make you all aware that it will not build with currently stated build dependencies. This is not a demand, just FYI.
Comment 4 Ondrej Vasik 2012-10-27 11:18:46 EDT
Thanks for report - actually it would be good to fix the tigervnc spec file or configure script in Fedora to prevent such failures in future.

In fact, all build requires are present on the system - and documentation is not rebuilt on the build system for RHEL - as with minimal build root everything is fine - however with more packages installed - the tigervnc configure script checks only for xmlto and doxygen - and assumes that everything is fine for rebuilding documentation - and this is not true - and build fails.
Comment 5 Adam Tkac 2012-10-29 08:17:39 EDT
Ok, we can fix the tigervnc package to build fine when doxygen is installed and xmlto-tex isn't. Reopening.
Comment 7 RHEL Product and Program Management 2013-10-13 20:22:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 Tim Waugh 2014-05-23 08:14:54 EDT
This was fixed as part of 1.1.0-2, by adding "--disable-docs --disable-devel-docs" to the xserver configure line.

Note You need to log in before you can comment on or make changes to this bug.