Bug 867159 - Review Request: zabbix20 - Open-source monitoring solution for your IT infrastructure
Review Request: zabbix20 - Open-source monitoring solution for your IT infras...
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: Package Review (Show other bugs)
el6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
: 712921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 19:13 EDT by Volker Fröhlich
Modified: 2014-02-05 13:06 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-24 15:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mrunge: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Volker Fröhlich 2012-10-16 19:13:39 EDT
Spec URL: http://www.geofrogger.net/review/zabbix20.spec
SRPM URL: http://www.geofrogger.net/review/zabbix20-2.0.3-2.fc16.src.rpm
Description:

ZABBIX is software that monitors numerous parameters of a network and
the health and integrity of servers. ZABBIX uses a flexible
notification mechanism that allows users to configure e-mail based
alerts for virtually any event. This allows a fast reaction to server
problems. ZABBIX offers excellent reporting and data visualization
features based on the stored data. This makes ZABBIX ideal for
capacity planning.

ZABBIX supports both polling and trapping. All ZABBIX reports and
statistics, as well as configuration parameters are accessed through a
web-based front end. A web-based front end ensures that the status of
your network and the health of your servers can be assessed from any
location. Properly configured, ZABBIX can play an important role in
monitoring IT infrastructure. This is equally true for small
organizations with a few servers and for large companies with a
multitude of servers.

Fedora Account System Username: volter

This package shall go to EPEL 6. It already exists in Fedora and EPEL by the name of "zabbix". zabbix20 conflicts zabbix to be in-line with EPEL policy. This specfile shall serve Fedora and EPEL in the future. This greatly reduces maintenance work, compared to the current situation. In Fedora the name will remain "zabbix".

Different database implementations of the daemons are no longer in conflicting sub-packages. Much rather you can switch between them with Alternatives. This was demanded on an attempted review for 1.8:
https://bugzilla.redhat.com/show_bug.cgi?id=712921

The non-working Sqlite server/frontend subpackages are removed: https://bugzilla.redhat.com/show_bug.cgi?id=734514

PID and lockfile name are corrected:
https://bugzilla.redhat.com/show_bug.cgi?id=734394

Sysconfig configuration files are sourced:
https://bugzilla.redhat.com/show_bug.cgi?id=851009

The package also introduces a new system user to separate permissions for the two daemons. It seemed easiest to just put it in the same user group.

The general wish for 2.0 packages in EPEL 6 and Fedora:
https://bugzilla.redhat.com/show_bug.cgi?id=838037
https://bugzilla.redhat.com/show_bug.cgi?id=858091
https://bugzilla.redhat.com/show_bug.cgi?id=862987
Comment 1 Volker Fröhlich 2012-10-20 03:57:24 EDT
*** Bug 712921 has been marked as a duplicate of this bug. ***
Comment 2 Volker Fröhlich 2012-10-25 17:21:56 EDT
Spec URL: http://www.geofrogger.net/review/zabbix20.spec
SRPM URL: http://www.geofrogger.net/review/zabbix20-2.0.3-3.fc16.src.rpm

http://koji.fedoraproject.org/koji/taskinfo?taskID=4627056


- Correct capitalization in unit files, init scripts and package description
- Improve sysconfig sourcing in init scripts
- Correct post-script permissions and owner on rpmnew files
- Obsolete sqlite web and server sub-package
Comment 3 Matthias Runge 2012-11-03 16:57:25 EDT
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
[!]: Package does not generate any conflict.
     Note: Package contains Conflicts: tag(s) needing fix or justification.
See: http://fedoraproject.org/wiki/Packaging/Guidelines#Conflicts


===== MUST items =====

C/C++:
[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.
[x]: Changelog in prescribed format.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in %package
     proxy-mysql, %package proxy-sqlite3, %package web-pgsql, %package proxy-
     pgsql, %package web-mysql
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "GPL", "GPL (v2 or later)", "Unknown or generated", "zlib/libpng". 4
     files have unknown license. Detailed output of licensecheck in
     /home/mrunge/review/867159-zabbix20/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: No %config files under /usr.
[!]: Package does not generate any conflict.
     Note: Package contains Conflicts: tag(s) needing fix or justification.
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[x]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 440320 bytes in 10 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

Perl:
[x]: Package contains the mandatory BuildRequires and Reguires:.
     Note: Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo
     $version)) missing?
[x]: CPAN urls should be non-versioned.
     Note: Test run failed

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: Scriptlets must be sane, if used.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[!]: SourceX / PatchY prefixed with %{name}.
     Note: Source14 (zabbix-server-mysql.service) Source15 (zabbix-server-
     pgsql.service) Source16 (zabbix-fedora.README) Source10 (zabbix-
     agent.service) Source11 (zabbix-proxy-mysql.service) Source12 (zabbix-
     proxy-pgsql.service) Source13 (zabbix-proxy-sqlite3.service) Patch0
     (zabbix-2.0.2-config.patch) Patch1 (zabbix-2.0.3-fonts-config.patch)
     Patch2 (zabbix-2.0.1-no-flash.patch) Patch3 (zabbix-1.8.12-fping3.patch)
     Source2 (zabbix-server.init) Source3 (zabbix-agent.init) Source0
     (zabbix-2.0.3-free.tar.gz) Source1 (zabbix-web.conf) Source4 (zabbix-
     proxy.init) Source5 (zabbix-logrotate.in) Source9 (zabbix-tmpfiles.conf)
[x]: SourceX is a working URL.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Files in /run, var/run and /var/lock uses tmpfiles.d when appropriate
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: No rpmlint messages.
[x]: Spec file according to URL is the same as in SRPM.
[!]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
     Note: Arch-ed rpms have a total of 12748800 bytes in /usr/share 10240
     zabbix20-agent-2.0.3-3.el6.x86_64.rpm 409600
     zabbix20-2.0.3-3.el6.x86_64.rpm 3092480 zabbix20-proxy-
     mysql-2.0.3-3.el6.x86_64.rpm 3092480 zabbix20-server-
     mysql-2.0.3-3.el6.x86_64.rpm 92160 zabbix20-proxy-
     sqlite3-2.0.3-3.el6.x86_64.rpm 3010560 zabbix20-proxy-
     pgsql-2.0.3-3.el6.x86_64.rpm 20480 zabbix20-proxy-2.0.3-3.el6.x86_64.rpm
     3010560 zabbix20-server-pgsql-2.0.3-3.el6.x86_64.rpm 10240
     zabbix20-server-2.0.3-3.el6.x86_64.rpm


Rpmlint
-------
Checking: zabbix20-2.0.3-3.el6.src.rpm
          zabbix20-server-mysql-2.0.3-3.el6.x86_64.rpm
          zabbix20-debuginfo-2.0.3-3.el6.x86_64.rpm
          zabbix20-proxy-mysql-2.0.3-3.el6.x86_64.rpm
          zabbix20-proxy-sqlite3-2.0.3-3.el6.x86_64.rpm
          zabbix20-server-pgsql-2.0.3-3.el6.x86_64.rpm
          zabbix20-proxy-2.0.3-3.el6.x86_64.rpm
          zabbix20-web-2.0.3-3.el6.noarch.rpm
          zabbix20-web-mysql-2.0.3-3.el6.noarch.rpm
          zabbix20-2.0.3-3.el6.x86_64.rpm
          zabbix20-server-2.0.3-3.el6.x86_64.rpm
          zabbix20-agent-2.0.3-3.el6.x86_64.rpm
          zabbix20-web-pgsql-2.0.3-3.el6.noarch.rpm
          zabbix20-proxy-pgsql-2.0.3-3.el6.x86_64.rpm
zabbix20.src: W: spelling-error %description -l en_US Zabbix -> Zambia
zabbix20.src:45: W: macro-in-comment %{srcname}
zabbix20.src:45: W: macro-in-comment %{srcname}
zabbix20.src:45: W: macro-in-comment %{version}
zabbix20.src:500: W: macro-in-comment %{srcname}
zabbix20.src: W: invalid-url Source0: zabbix-2.0.3-free.tar.gz
zabbix20-server-mysql.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-server-mysql.x86_64: W: spelling-error %description -l en_US Zabbix -> Zambia
zabbix20-server-mysql.x86_64: W: no-documentation
zabbix20-server-mysql.x86_64: E: non-executable-script /usr/share/zabbix-mysql/upgrades/2.0/upgrade 0644L /bin/bash
zabbix20-server-mysql.x86_64: E: non-executable-script /usr/share/zabbix-mysql/upgrades/1.8/upgrade 0644L /bin/bash
zabbix20-server-mysql.x86_64: W: no-manual-page-for-binary zabbix_server_mysql
zabbix20-proxy-mysql.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-proxy-mysql.x86_64: W: no-documentation
zabbix20-proxy-mysql.x86_64: E: non-executable-script /usr/share/zabbix-mysql/upgrades/2.0/upgrade 0644L /bin/bash
zabbix20-proxy-mysql.x86_64: E: non-executable-script /usr/share/zabbix-mysql/upgrades/1.8/upgrade 0644L /bin/bash
zabbix20-proxy-mysql.x86_64: W: no-manual-page-for-binary zabbix_proxy_mysql
zabbix20-proxy-sqlite3.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-proxy-sqlite3.x86_64: W: no-documentation
zabbix20-proxy-sqlite3.x86_64: W: no-manual-page-for-binary zabbix_proxy_sqlite3
zabbix20-server-pgsql.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-server-pgsql.x86_64: W: spelling-error %description -l en_US Zabbix -> Zambia
zabbix20-server-pgsql.x86_64: W: no-documentation
zabbix20-server-pgsql.x86_64: W: no-manual-page-for-binary zabbix_server_pgsql
zabbix20-proxy.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-proxy.x86_64: W: non-standard-uid /var/lib/zabbixsrv/zabbix/externalscripts zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /var/lib/zabbixsrv/zabbix/externalscripts zabbix
zabbix20-proxy.x86_64: W: non-standard-uid /etc/zabbix/externalscripts zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /etc/zabbix/externalscripts zabbix
zabbix20-proxy.x86_64: E: incoherent-logrotate-file /etc/logrotate.d/zabbix-proxy
zabbix20-proxy.x86_64: W: non-standard-uid /var/lib/zabbixsrv/zabbix zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /var/lib/zabbixsrv/zabbix zabbix
zabbix20-proxy.x86_64: W: non-standard-gid /var/log/zabbix zabbix
zabbix20-proxy.x86_64: E: non-standard-dir-perm /var/log/zabbix 0775L
zabbix20-proxy.x86_64: W: non-standard-gid /var/run/zabbix zabbix
zabbix20-proxy.x86_64: E: non-standard-dir-perm /var/run/zabbix 0775L
zabbix20-proxy.x86_64: W: non-standard-uid /var/lib/zabbixsrv/zabbix/alertscripts zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /var/lib/zabbixsrv/zabbix/alertscripts zabbix
zabbix20-proxy.x86_64: W: non-standard-uid /var/lib/zabbixsrv zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /var/lib/zabbixsrv zabbix
zabbix20-proxy.x86_64: W: non-standard-uid /var/lib/zabbixsrv/externalscripts zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /var/lib/zabbixsrv/externalscripts zabbix
zabbix20-proxy.x86_64: W: non-standard-uid /var/lib/zabbixsrv/alertscripts zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /var/lib/zabbixsrv/alertscripts zabbix
zabbix20-proxy.x86_64: W: non-standard-uid /etc/zabbix_proxy.conf zabbixsrv
zabbix20-proxy.x86_64: W: non-standard-gid /etc/zabbix_proxy.conf zabbix
zabbix20-proxy.x86_64: E: non-readable /etc/zabbix_proxy.conf 0600L
zabbix20-proxy.x86_64: W: dangerous-command-in-%post chmod
zabbix20-proxy.x86_64: W: incoherent-init-script-name zabbix-proxy ('zabbix20-proxy', 'zabbix20-proxyd')
zabbix20-web.noarch: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-web.noarch: W: spelling-error %description -l en_US php -> pp, hp, pep
zabbix20-web.noarch: W: spelling-error %description -l en_US frontend -> fronted, front end, front-end
zabbix20-web.noarch: W: no-documentation
zabbix20-web.noarch: E: non-standard-dir-perm /etc/zabbix/web 0750L
zabbix20-web-mysql.noarch: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-web-mysql.noarch: W: spelling-error Summary(en_US) frontend -> fronted, front end, front-end
zabbix20-web-mysql.noarch: W: spelling-error %description -l en_US Zabbix -> Zambia
zabbix20-web-mysql.noarch: W: spelling-error %description -l en_US frontend -> fronted, front end, front-end
zabbix20-web-mysql.noarch: W: obsolete-not-provided zabbix20-web
zabbix20-web-mysql.noarch: W: no-documentation
zabbix20.x86_64: W: spelling-error %description -l en_US Zabbix -> Zambia
zabbix20-server.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-server.x86_64: W: spelling-error %description -l en_US Zabbix -> Zambia
zabbix20-server.x86_64: W: non-standard-uid /var/lib/zabbixsrv/zabbix/externalscripts zabbixsrv
zabbix20-server.x86_64: W: non-standard-gid /var/lib/zabbixsrv/zabbix/externalscripts zabbix
zabbix20-server.x86_64: W: non-standard-gid /var/run/zabbix zabbix
zabbix20-server.x86_64: E: non-standard-dir-perm /var/run/zabbix 0775L
zabbix20-server.x86_64: W: non-standard-uid /var/lib/zabbixsrv/externalscripts zabbixsrv
zabbix20-server.x86_64: W: non-standard-gid /var/lib/zabbixsrv/externalscripts zabbix
zabbix20-server.x86_64: W: non-standard-uid /var/lib/zabbixsrv/zabbix zabbixsrv
zabbix20-server.x86_64: W: non-standard-gid /var/lib/zabbixsrv/zabbix zabbix
zabbix20-server.x86_64: E: incoherent-logrotate-file /etc/logrotate.d/zabbix-server
zabbix20-server.x86_64: W: non-standard-gid /var/log/zabbix zabbix
zabbix20-server.x86_64: E: non-standard-dir-perm /var/log/zabbix 0775L
zabbix20-server.x86_64: W: non-standard-uid /etc/zabbix_server.conf zabbixsrv
zabbix20-server.x86_64: W: non-standard-gid /etc/zabbix_server.conf zabbix
zabbix20-server.x86_64: E: non-readable /etc/zabbix_server.conf 0400L
zabbix20-server.x86_64: W: non-standard-uid /var/lib/zabbixsrv zabbixsrv
zabbix20-server.x86_64: W: non-standard-gid /var/lib/zabbixsrv zabbix
zabbix20-server.x86_64: W: non-standard-uid /var/lib/zabbixsrv/zabbix/alertscripts zabbixsrv
zabbix20-server.x86_64: W: non-standard-gid /var/lib/zabbixsrv/zabbix/alertscripts zabbix
zabbix20-server.x86_64: W: non-standard-uid /var/lib/zabbixsrv/alertscripts zabbixsrv
zabbix20-server.x86_64: W: non-standard-gid /var/lib/zabbixsrv/alertscripts zabbix
zabbix20-server.x86_64: W: dangerous-command-in-%post chmod
zabbix20-server.x86_64: E: incoherent-subsys /etc/rc.d/init.d/zabbix-server zabbix
zabbix20-server.x86_64: W: incoherent-init-script-name zabbix-server ('zabbix20-server', 'zabbix20-serverd')
zabbix20-agent.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-agent.x86_64: W: non-standard-gid /var/run/zabbix zabbix
zabbix20-agent.x86_64: E: non-standard-dir-perm /var/run/zabbix 0775L
zabbix20-agent.x86_64: W: non-standard-uid /var/lib/zabbix zabbix
zabbix20-agent.x86_64: W: non-standard-gid /var/lib/zabbix zabbix
zabbix20-agent.x86_64: E: incoherent-logrotate-file /etc/logrotate.d/zabbix-agent
zabbix20-agent.x86_64: W: non-standard-gid /var/log/zabbix zabbix
zabbix20-agent.x86_64: E: non-standard-dir-perm /var/log/zabbix 0775L
zabbix20-agent.x86_64: W: no-manual-page-for-binary zabbix_agent
zabbix20-agent.x86_64: W: empty-%preun
zabbix20-agent.x86_64: E: preun-without-chkconfig /etc/rc.d/init.d/zabbix-agent
zabbix20-agent.x86_64: W: incoherent-init-script-name zabbix-agent ('zabbix20-agent', 'zabbix20-agentd')
zabbix20-web-pgsql.noarch: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-web-pgsql.noarch: W: spelling-error Summary(en_US) frontend -> fronted, front end, front-end
zabbix20-web-pgsql.noarch: W: spelling-error %description -l en_US Zabbix -> Zambia
zabbix20-web-pgsql.noarch: W: spelling-error %description -l en_US frontend -> fronted, front end, front-end
zabbix20-web-pgsql.noarch: W: no-documentation
zabbix20-proxy-pgsql.x86_64: W: spelling-error Summary(en_US) Zabbix -> Zambia
zabbix20-proxy-pgsql.x86_64: W: no-documentation
zabbix20-proxy-pgsql.x86_64: W: no-manual-page-for-binary zabbix_proxy_pgsql
14 packages and 0 specfiles checked; 18 errors, 88 warnings.





Requires
--------
zabbix20-server-mysql-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /usr/sbin/alternatives  
    /usr/sbin/update-alternatives  
    libOpenIPMI.so.0()(64bit)  
    libOpenIPMIposix.so.0()(64bit)  
    libc.so.6()(64bit)  
    libcrypto.so.10()(64bit)  
    libcurl.so.4()(64bit)  
    libiksemel.so.3()(64bit)  
    liblber-2.4.so.2()(64bit)  
    libldap-2.4.so.2()(64bit)  
    libm.so.6()(64bit)  
    libmysqlclient.so.16()(64bit)  
    libmysqlclient.so.16(libmysqlclient_16)(64bit)  
    libnetsnmp.so.20()(64bit)  
    libodbc.so.2()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    libssh2.so.1()(64bit)  
    rtld(GNU_HASH)  
    zabbix20 = 2.0.3-3.el6
    zabbix20-server = 2.0.3-3.el6

zabbix20-debuginfo-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    

zabbix20-proxy-mysql-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /usr/sbin/alternatives  
    /usr/sbin/update-alternatives  
    libOpenIPMI.so.0()(64bit)  
    libOpenIPMIposix.so.0()(64bit)  
    libc.so.6()(64bit)  
    libcrypto.so.10()(64bit)  
    libcurl.so.4()(64bit)  
    liblber-2.4.so.2()(64bit)  
    libldap-2.4.so.2()(64bit)  
    libm.so.6()(64bit)  
    libmysqlclient.so.16()(64bit)  
    libmysqlclient.so.16(libmysqlclient_16)(64bit)  
    libnetsnmp.so.20()(64bit)  
    libodbc.so.2()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    libssh2.so.1()(64bit)  
    rtld(GNU_HASH)  
    zabbix20-proxy = 2.0.3-3.el6

zabbix20-proxy-sqlite3-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /usr/sbin/alternatives  
    /usr/sbin/update-alternatives  
    libOpenIPMI.so.0()(64bit)  
    libOpenIPMIposix.so.0()(64bit)  
    libc.so.6()(64bit)  
    libcrypto.so.10()(64bit)  
    libcurl.so.4()(64bit)  
    liblber-2.4.so.2()(64bit)  
    libldap-2.4.so.2()(64bit)  
    libm.so.6()(64bit)  
    libnetsnmp.so.20()(64bit)  
    libodbc.so.2()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    libsqlite3.so.0()(64bit)  
    libssh2.so.1()(64bit)  
    rtld(GNU_HASH)  
    zabbix20-proxy = 2.0.3-3.el6

zabbix20-server-pgsql-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /usr/sbin/alternatives  
    /usr/sbin/update-alternatives  
    libOpenIPMI.so.0()(64bit)  
    libOpenIPMIposix.so.0()(64bit)  
    libc.so.6()(64bit)  
    libcrypto.so.10()(64bit)  
    libcurl.so.4()(64bit)  
    libiksemel.so.3()(64bit)  
    liblber-2.4.so.2()(64bit)  
    libldap-2.4.so.2()(64bit)  
    libm.so.6()(64bit)  
    libnetsnmp.so.20()(64bit)  
    libodbc.so.2()(64bit)  
    libpq.so.5()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    libssh2.so.1()(64bit)  
    rtld(GNU_HASH)  
    zabbix20 = 2.0.3-3.el6
    zabbix20-server = 2.0.3-3.el6

zabbix20-proxy-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /sbin/chkconfig  
    /sbin/service  
    config(zabbix20-proxy) = 2.0.3-3.el6
    fping  
    libc.so.6()(64bit)  
    libm.so.6()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    rtld(GNU_HASH)  
    shadow-utils  
    zabbix20 = 2.0.3-3.el6
    zabbix20-proxy-implementation = 2.0.3-3.el6

zabbix20-web-2.0.3-3.el6.noarch.rpm (rpmlib, GLIBC filtered):
    
    /bin/bash  
    config(zabbix20-web) = 2.0.3-3.el6
    dejavu-sans-fonts  
    php-bcmath  
    php-gd  
    php-gettext  
    php-mbstring  
    php-xml  
    zabbix20 = 2.0.3-3.el6
    zabbix20-web-database = 2.0.3-3.el6

zabbix20-web-mysql-2.0.3-3.el6.noarch.rpm (rpmlib, GLIBC filtered):
    
    php-mysql  
    zabbix20-web = 2.0.3-3.el6

zabbix20-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    config(zabbix20) = 2.0.3-3.el6
    libc.so.6()(64bit)  
    libm.so.6()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    logrotate  
    rtld(GNU_HASH)  

zabbix20-server-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /sbin/chkconfig  
    /sbin/service  
    config(zabbix20-server) = 2.0.3-3.el6
    fping  
    shadow-utils  
    traceroute  
    zabbix20 = 2.0.3-3.el6
    zabbix20-server-implementation = 2.0.3-3.el6

zabbix20-agent-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /sbin/chkconfig  
    /sbin/service  
    config(zabbix20-agent) = 2.0.3-3.el6
    libc.so.6()(64bit)  
    libcurl.so.4()(64bit)  
    liblber-2.4.so.2()(64bit)  
    libldap-2.4.so.2()(64bit)  
    libm.so.6()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    rtld(GNU_HASH)  
    shadow-utils  
    zabbix20 = 2.0.3-3.el6

zabbix20-web-pgsql-2.0.3-3.el6.noarch.rpm (rpmlib, GLIBC filtered):
    
    php-pgsql  
    zabbix20-web = 2.0.3-3.el6

zabbix20-proxy-pgsql-2.0.3-3.el6.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh  
    /usr/sbin/alternatives  
    /usr/sbin/update-alternatives  
    libOpenIPMI.so.0()(64bit)  
    libOpenIPMIposix.so.0()(64bit)  
    libc.so.6()(64bit)  
    libcrypto.so.10()(64bit)  
    libcurl.so.4()(64bit)  
    liblber-2.4.so.2()(64bit)  
    libldap-2.4.so.2()(64bit)  
    libm.so.6()(64bit)  
    libnetsnmp.so.20()(64bit)  
    libodbc.so.2()(64bit)  
    libpq.so.5()(64bit)  
    libresolv.so.2()(64bit)  
    librt.so.1()(64bit)  
    libssh2.so.1()(64bit)  
    rtld(GNU_HASH)  
    zabbix20-proxy = 2.0.3-3.el6



Provides
--------
zabbix20-server-mysql-2.0.3-3.el6.x86_64.rpm:
    
    zabbix20-server-implementation = 2.0.3-3.el6
    zabbix20-server-mysql = 2.0.3-3.el6
    zabbix20-server-mysql(x86-64) = 2.0.3-3.el6

zabbix20-debuginfo-2.0.3-3.el6.x86_64.rpm:
    
    zabbix20-debuginfo = 2.0.3-3.el6
    zabbix20-debuginfo(x86-64) = 2.0.3-3.el6

zabbix20-proxy-mysql-2.0.3-3.el6.x86_64.rpm:
    
    zabbix20-proxy-implementation = 2.0.3-3.el6
    zabbix20-proxy-mysql = 2.0.3-3.el6
    zabbix20-proxy-mysql(x86-64) = 2.0.3-3.el6

zabbix20-proxy-sqlite3-2.0.3-3.el6.x86_64.rpm:
    
    zabbix20-proxy-implementation = 2.0.3-3.el6
    zabbix20-proxy-sqlite3 = 2.0.3-3.el6
    zabbix20-proxy-sqlite3(x86-64) = 2.0.3-3.el6

zabbix20-server-pgsql-2.0.3-3.el6.x86_64.rpm:
    
    zabbix20-server-implementation = 2.0.3-3.el6
    zabbix20-server-pgsql = 2.0.3-3.el6
    zabbix20-server-pgsql(x86-64) = 2.0.3-3.el6

zabbix20-proxy-2.0.3-3.el6.x86_64.rpm:
    
    config(zabbix20-proxy) = 2.0.3-3.el6
    zabbix20-proxy = 2.0.3-3.el6
    zabbix20-proxy(x86-64) = 2.0.3-3.el6

zabbix20-web-2.0.3-3.el6.noarch.rpm:
    
    config(zabbix20-web) = 2.0.3-3.el6
    zabbix20-web = 2.0.3-3.el6

zabbix20-web-mysql-2.0.3-3.el6.noarch.rpm:
    
    zabbix20-web-database = 2.0.3-3.el6
    zabbix20-web-mysql = 2.0.3-3.el6

zabbix20-2.0.3-3.el6.x86_64.rpm:
    
    config(zabbix20) = 2.0.3-3.el6
    zabbix20 = 2.0.3-3.el6
    zabbix20(x86-64) = 2.0.3-3.el6

zabbix20-server-2.0.3-3.el6.x86_64.rpm:
    
    config(zabbix20-server) = 2.0.3-3.el6
    zabbix20-server = 2.0.3-3.el6
    zabbix20-server(x86-64) = 2.0.3-3.el6

zabbix20-agent-2.0.3-3.el6.x86_64.rpm:
    
    config(zabbix20-agent) = 2.0.3-3.el6
    zabbix20-agent = 2.0.3-3.el6
    zabbix20-agent(x86-64) = 2.0.3-3.el6

zabbix20-web-pgsql-2.0.3-3.el6.noarch.rpm:
    
    zabbix20-web-database = 2.0.3-3.el6
    zabbix20-web-pgsql = 2.0.3-3.el6

zabbix20-proxy-pgsql-2.0.3-3.el6.x86_64.rpm:
    
    zabbix20-proxy-implementation = 2.0.3-3.el6
    zabbix20-proxy-pgsql = 2.0.3-3.el6
    zabbix20-proxy-pgsql(x86-64) = 2.0.3-3.el6



MD5-sum check
-------------


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: epel-6-x86_64
Command line :/usr/bin/fedora-review -b 867159 --mock-config epel-6-x86_64


Package APPROVED
Comment 4 Volker Fröhlich 2012-11-03 17:52:21 EDT
Thanks a lot, Matthias!
Comment 5 Volker Fröhlich 2012-11-03 18:03:42 EDT
New Package SCM Request
=======================
Package Name: zabbix20
Short Description: Open-source monitoring solution for your IT infrastructure
Owners: volter sharkcz
Branches: el6
Comment 6 Gwyn Ciesla 2012-11-05 08:04:18 EST
Git done (by process-git-requests).
Comment 7 Fedora Update System 2012-11-05 14:55:59 EST
zabbix20-2.0.3-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/zabbix20-2.0.3-3.el6
Comment 8 Fedora Update System 2012-11-07 12:28:51 EST
zabbix20-2.0.3-3.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 9 Fedora Update System 2012-11-08 18:32:26 EST
zabbix20-2.0.3-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/zabbix20-2.0.3-4.el6
Comment 10 Fedora Update System 2012-11-24 15:01:09 EST
zabbix20-2.0.3-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Orion Poplawski 2012-12-27 12:28:05 EST
Why does zabbix20-agent have both of these?

/etc/zabbix/zabbix_agent.conf
/etc/zabbix/zabbix_agentd.conf

and

/etc/zabbix_agent.conf
/etc/zabbix_agentd.conf
Comment 12 Orion Poplawski 2012-12-27 12:29:51 EST
Same with server:

/etc/zabbix/zabbix_server.conf
/etc/zabbix_server.conf
Comment 13 Dan Horák 2012-12-27 12:33:51 EST
(In reply to comment #11)
> Why does zabbix20-agent have both of these?
> 
> /etc/zabbix/zabbix_agent.conf
> /etc/zabbix/zabbix_agentd.conf

^^^ these are compatibility symlinks, upstream moved the config files to /etc

> and
> 
> /etc/zabbix_agent.conf
> /etc/zabbix_agentd.conf
Comment 14 Orion Poplawski 2012-12-27 12:40:09 EST
These seem to be all over the place too:

/etc/zabbix/alertscripts
/etc/zabbix/externalscripts

/var/lib/zabbixsrv/alertscripts
/var/lib/zabbixsrv/externalscripts

/var/lib/zabbixsrv/zabbix/alertscripts
/var/lib/zabbixsrv/zabbix/externalscripts
Comment 15 Orion Poplawski 2012-12-27 12:40:45 EST
(In reply to comment #13)
> (In reply to comment #11)
> > Why does zabbix20-agent have both of these?
> > 
> > /etc/zabbix/zabbix_agent.conf
> > /etc/zabbix/zabbix_agentd.conf
> 
> ^^^ these are compatibility symlinks, upstream moved the config files to /etc

Ah, sorry, my backup system didn't make this obvious to me.
Comment 16 Volker Fröhlich 2012-12-27 12:42:54 EST
The last pair should not be there. I haven't found the cause yet.
Comment 17 Volker Fröhlich 2013-01-14 18:11:19 EST
Package Change Request
======================
Package Name: zabbix20
New Branches: el5
Owners: volter sharkcz
InitialCC:
Comment 18 Gwyn Ciesla 2013-01-15 06:57:55 EST
Git done (by process-git-requests).
Comment 19 Volker Fröhlich 2013-01-20 14:16:32 EST
(In reply to comment #14)
> These seem to be all over the place too:
> 
> /etc/zabbix/alertscripts
> /etc/zabbix/externalscripts
> 
> /var/lib/zabbixsrv/alertscripts
> /var/lib/zabbixsrv/externalscripts
> 
> /var/lib/zabbixsrv/zabbix/alertscripts
> /var/lib/zabbixsrv/zabbix/externalscripts

The latter two are finally sorted out in Rawhide now (2.0.4-4).
Comment 20 Fedora Update System 2013-01-22 11:01:32 EST
zabbix20-2.0.4-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/zabbix20-2.0.4-4.el5
Comment 21 Fedora Update System 2013-02-08 20:43:27 EST
zabbix20-2.0.4-4.el5 has been pushed to the Fedora EPEL 5 stable repository.
Comment 22 Volker Fröhlich 2014-02-05 12:02:07 EST
Please un-retire the EPEL7 branch. It is retired because zabbix20 is an EPEL-only package and the master branch was retired to avoid Fedora Rawhide builds.
Comment 23 Gwyn Ciesla 2014-02-05 13:06:22 EST
epel7 isn't retired.

Note You need to log in before you can comment on or make changes to this bug.