Bug 867314 - [whql][netkvm]NDISTest 6.0 - [1 Machine] - 1c_Mini6Send leads to BSOD [0X0000007E]-NDPort60.sys
[whql][netkvm]NDISTest 6.0 - [1 Machine] - 1c_Mini6Send leads to BSOD [0X0000...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
Regression
:
: 867312 (view as bug list)
Depends On:
Blocks: 946973
  Show dependency treegraph
 
Reported: 2012-10-17 05:55 EDT by Min Deng
Modified: 2014-07-11 02:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Do not document. This is MS test bug. We have errata for MS to pass HCK tests.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:59:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Analysis (32.82 KB, application/octet-stream)
2012-10-17 05:56 EDT, Min Deng
no flags Details
Dumpandlog (77.01 MB, application/x-zip-compressed)
2012-10-30 01:23 EDT, Min Deng
no flags Details
The same crash is observed on Windows Server 2012 with published indices off (42.53 MB, application/octet-stream)
2013-01-30 07:59 EST, Dmitry Fleytman
no flags Details

  None (edit)
Description Min Deng 2012-10-17 05:55:44 EDT
Description of problem:
The job named 1c_Mini6Send will lead to BSOD on windows 2008 64 bits.
Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-39
How reproducible:
2/2
Steps to Reproduce:
1.boot up guests with the following CLI
  a./usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k8-64-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:11:16:46:39:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:12:37:26:31:12,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:11:43:36:41:11,bus=pci.0,addr=0x6 -uuid 7bd2d095-af1e-40ae-8f62-862be9366555 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-32-nic1,server,nowait -mon chardev=111a,mode=readline -spice port=5931,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio
 b./usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k8-64-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:24:c5:39:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet1,mac=00:11:23:16:37:32,bus=pci.0,addr=0x5 -uuid e81473c1-43c9-4c41-b837-ff156bd49909 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111b,path=/tmp/monitor-win2k8-32-nic2,server,nowait -mon chardev=111b,mode=readline -spice port=5932,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio
2.submit jobs onto HCK
  
Actual results:
The job failed as BSOD issue
Expected results:
The job can pass without errors
Additional info:
Comment 1 Min Deng 2012-10-17 05:56:50 EDT
Created attachment 628634 [details]
Analysis
Comment 2 Min Deng 2012-10-17 06:04:30 EDT
*** Bug 867312 has been marked as a duplicate of this bug. ***
Comment 4 Yan Vugenfirer 2012-10-17 09:39:33 EDT
Please upload memory dump.

Thanks,
Yan.
Comment 5 Min Deng 2012-10-18 01:42:18 EDT
Created attachment 629169 [details]
Attach
Comment 6 Mike Cao 2012-10-19 03:30:51 EDT
Since We do not hit this issue on virtio-win-prewhql-35 ,So it is a virtio-win regression bug
Comment 7 Dmitry Fleytman 2012-10-26 04:29:10 EDT
I've run mini6send test on both build 39 and the latest source from repository. Both on Win2008 and WIn2008R2 64 bit.
No crashes occurred, all tests passed. It looks like a setup problem.

Please rerun on clean setup. In case crash still occurs, please, provide kernel memory dump (not a minidump) and HCK logs.
Comment 8 Ronen Hod 2012-10-28 10:26:02 EDT
Since it is a HCK issue, deferring to RHEL6.5
Comment 9 Min Deng 2012-10-30 01:08:36 EDT
(In reply to comment #7)
> I've run mini6send test on both build 39 and the latest source from
> repository. Both on Win2008 and WIn2008R2 64 bit.
> No crashes occurred, all tests passed. It looks like a setup problem.
> 
> Please rerun on clean setup. In case crash still occurs, please, provide
> kernel memory dump (not a minidump) and HCK logs.

 Unfortunately,I still can reproduce the issue on windows 2k8-64 OS via build 41  even if the image is new installed&updated.And I will provide the dump&hck log after a while.
Comment 10 Min Deng 2012-10-30 01:23:05 EDT
Created attachment 635330 [details]
Dumpandlog
Comment 12 Yan Vugenfirer 2012-10-31 06:59:07 EDT
Hello,

Please rerun the test with disabled "Init.UsePublishEvents" setting of the driver (please disable it on north adapters).

Thanks,
Yan.
Comment 16 Dmitry Fleytman 2013-01-30 07:59:52 EST
Created attachment 690369 [details]
The same crash is observed on Windows Server 2012 with published indices off
Comment 18 Mike Cao 2013-04-17 03:34:14 EDT
(In reply to comment #16)
> Created attachment 690369 [details]
> The same crash is observed on Windows Server 2012 with published indices off

I did not hit this issue on virito-win-prewhql-54
Comment 19 Yan Vugenfirer 2013-04-17 09:33:06 EDT
Please don't close this BZ yet. 

While we reduced the occurrence of the crash (probably there were several issues) - we still can reproduce it from time to time on our setup on Windows Server 2012.
Comment 20 Dmitry Fleytman 2013-05-16 02:07:00 EDT
We don't see this bug anymore on the latest code.
Please retest with build virtio-win-prewhql-0.1-61 (both on win2008/64 and win2012) and attach the crash dump(s) if BSOD appears again.

Thanks,
Dmitry
Comment 22 Min Deng 2013-05-27 23:02:20 EDT
Hi all,

   QE already re-test the bug via build 61,the test results is the following as below,
   Actual results,the job passed
   Expected results,the job will pass.

   So it should be fixed already,thanks.

Best Regards,
Min
Comment 23 Mike Cao 2013-05-27 23:13:44 EDT
Based on comment #22 ,Move status to VERIFIED.
Comment 29 errata-xmlrpc 2013-11-21 18:59:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html

Note You need to log in before you can comment on or make changes to this bug.