Bug 867364 - Self-heal checks skip pending counts that they shouldn't
Self-heal checks skip pending counts that they shouldn't
Status: CLOSED DUPLICATE of bug 867360
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified All
unspecified Severity high
: ---
: ---
Assigned To: Amar Tumballi
Sudhir D
:
Depends On: 865825
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 07:31 EDT by Vidya Sakar
Modified: 2013-12-18 19:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 865825
Environment:
Last Closed: 2012-10-19 00:24:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-10-17 07:31:29 EDT
+++ This bug was initially created as a clone of Bug #865825 +++

The afr_sh_has_*_pending pending functions, which were clearly copied from one another, all have the problem that if they get an error from dict_get_ptr they return immediately.  This means they won't check the pending counts for other peers, which should trigger self-heal if they're non-zero.  Failing to trigger self-heal when we should makes this a high-priority issue.
Comment 1 Amar Tumballi 2012-10-19 00:24:31 EDT
i see it as exact dup of 867360

*** This bug has been marked as a duplicate of bug 867360 ***

Note You need to log in before you can comment on or make changes to this bug.