Bug 867377 - ValueError: ('invalid size specification', '-1.000000 MB')
ValueError: ('invalid size specification', '-1.000000 MB')
Status: CLOSED DUPLICATE of bug 864766
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:e176f4e7df1a6f20f6003750e8c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 07:54 EDT by Richard Marko
Modified: 2016-01-31 21:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 15:09:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (641 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: anaconda-tb (186.70 KB, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: product (6 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: type (9 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: environ (764 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: storage.log (73.32 KB, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: version (11 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: program.log (17.61 KB, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: anaconda.log (6.61 KB, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: syslog (59.18 KB, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: cmdline_file (110 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details
File: release (24 bytes, text/plain)
2012-10-17 07:54 EDT, Richard Marko
no flags Details

  None (edit)
Description Richard Marko 2012-10-17 07:54:07 EDT
Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 79, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1081, in _save_right_side
:    % str(Size(spec="%f MB" % device.size)).upper())
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1525, in on_add_clicked
:    self._save_right_side(self._current_selector)
:ValueError: ('invalid size specification', '-1.000000 MB')
Comment 1 Richard Marko 2012-10-17 07:54:11 EDT
Created attachment 628725 [details]
File: ifcfg.log
Comment 2 Richard Marko 2012-10-17 07:54:13 EDT
Created attachment 628726 [details]
File: anaconda-tb
Comment 3 Richard Marko 2012-10-17 07:54:16 EDT
Created attachment 628727 [details]
File: product
Comment 4 Richard Marko 2012-10-17 07:54:19 EDT
Created attachment 628728 [details]
File: type
Comment 5 Richard Marko 2012-10-17 07:54:21 EDT
Created attachment 628729 [details]
File: environ
Comment 6 Richard Marko 2012-10-17 07:54:23 EDT
Created attachment 628730 [details]
File: storage.log
Comment 7 Richard Marko 2012-10-17 07:54:25 EDT
Created attachment 628731 [details]
File: version
Comment 8 Richard Marko 2012-10-17 07:54:28 EDT
Created attachment 628732 [details]
File: program.log
Comment 9 Richard Marko 2012-10-17 07:54:30 EDT
Created attachment 628733 [details]
File: anaconda.log
Comment 10 Richard Marko 2012-10-17 07:54:32 EDT
Created attachment 628734 [details]
File: syslog
Comment 11 Richard Marko 2012-10-17 07:54:34 EDT
Created attachment 628735 [details]
File: hashmarkername
Comment 12 Richard Marko 2012-10-17 07:54:36 EDT
Created attachment 628736 [details]
File: packaging.log
Comment 13 Richard Marko 2012-10-17 07:54:40 EDT
Created attachment 628737 [details]
File: cmdline_file
Comment 14 Richard Marko 2012-10-17 07:54:43 EDT
Created attachment 628738 [details]
File: release
Comment 15 Richard Marko 2012-10-17 08:05:39 EDT
Happens when trying to use LVM and checking Encrypt checkbox.
Comment 16 Adam Williamson 2012-11-05 15:09:11 EST
dlehman believes all these '-1.000000 MB' bugs are the same.

*** This bug has been marked as a duplicate of bug 864766 ***

Note You need to log in before you can comment on or make changes to this bug.