Bug 864766 - ValueError: ('invalid size specification', '-1.000000 MB')
ValueError: ('invalid size specification', '-1.000000 MB')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:7348c41eda69d519d73e1d62800...
:
: 867377 868278 869381 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 00:40 EDT by digimer
Modified: 2012-11-22 23:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 23:06:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (323.29 KB, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: product (6 bytes, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: type (9 bytes, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: storage.log (143.01 KB, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: version (11 bytes, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: environ (794 bytes, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: anaconda.log (7.63 KB, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: syslog (127.35 KB, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: packaging.log (2.35 KB, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: cmdline_file (127 bytes, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: release (24 bytes, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details
File: program.log (17.61 KB, text/plain)
2012-10-10 00:40 EDT, digimer
no flags Details

  None (edit)
Description digimer 2012-10-10 00:40:05 EDT
Description of problem:
Tried to set the size of the 'biosboot' partition to '1', but it seems to have interpretted it as '-1'.

Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 79, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 701, in _do_refresh
:    selector = page.addDevice(self._mountpointName(mountpoint) or device.format.name, Size(spec="%f MB" % device.size), mountpoint, self.on_selector_clicked)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1484, in on_add_clicked
:    self._do_refresh()
:ValueError: ('invalid size specification', '-1.000000 MB')
Comment 1 digimer 2012-10-10 00:40:10 EDT
Created attachment 624565 [details]
File: anaconda-tb
Comment 2 digimer 2012-10-10 00:40:12 EDT
Created attachment 624566 [details]
File: product
Comment 3 digimer 2012-10-10 00:40:14 EDT
Created attachment 624567 [details]
File: type
Comment 4 digimer 2012-10-10 00:40:16 EDT
Created attachment 624568 [details]
File: storage.log
Comment 5 digimer 2012-10-10 00:40:18 EDT
Created attachment 624569 [details]
File: version
Comment 6 digimer 2012-10-10 00:40:19 EDT
Created attachment 624570 [details]
File: environ
Comment 7 digimer 2012-10-10 00:40:22 EDT
Created attachment 624571 [details]
File: anaconda.log
Comment 8 digimer 2012-10-10 00:40:24 EDT
Created attachment 624572 [details]
File: syslog
Comment 9 digimer 2012-10-10 00:40:26 EDT
Created attachment 624573 [details]
File: hashmarkername
Comment 10 digimer 2012-10-10 00:40:27 EDT
Created attachment 624574 [details]
File: packaging.log
Comment 11 digimer 2012-10-10 00:40:29 EDT
Created attachment 624575 [details]
File: cmdline_file
Comment 12 digimer 2012-10-10 00:40:31 EDT
Created attachment 624576 [details]
File: release
Comment 13 digimer 2012-10-10 00:40:33 EDT
Created attachment 624577 [details]
File: program.log
Comment 14 Reartes Guillermo 2012-10-13 23:28:18 EDT
tried to create a biosboot partition, to avoid a /boot by using GPT (hoping that anaconda would use GPT when one request a biosboot partition, since the disk is unpartitioned yet -new guest-)




Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 15 David Lehman 2012-10-15 10:38:25 EDT
(In reply to comment #14)
> tried to create a biosboot partition, to avoid a /boot by using GPT (hoping
> that anaconda would use GPT when one request a biosboot partition, since the
> disk is unpartitioned yet -new guest-)

GPT is not required to avoid creating a separate /boot filesystem. As long as your root filesystem lies within the first 2TB of a disk you can just skip creating /boot. If you're on x86 or EFI you can skip making /boot even if your root filesystem is on lvm.

Anaconda will not change disklabel type based on requested partitions. If you want anaconda to create GPT disklabels by default, pass 'gpt' on the command line. I don't see why you would want to do this, though.
Comment 16 Adam Williamson 2012-11-05 15:09:11 EST
*** Bug 867377 has been marked as a duplicate of this bug. ***
Comment 17 Adam Williamson 2012-11-05 15:09:27 EST
*** Bug 868278 has been marked as a duplicate of this bug. ***
Comment 18 Adam Williamson 2012-11-05 15:09:31 EST
*** Bug 869381 has been marked as a duplicate of this bug. ***
Comment 19 Adam Williamson 2012-11-05 15:10:44 EST
David believes all these '-1.000000 MB' bugs are the same fundamental problem - despite people hitting them in different ways - and furthermore, that they all should be fixed by TC7. Can anyone who has a reliable reproducer for this please re-test with TC7 and confirm that this is fixed? Thanks!
Comment 20 Adam Williamson 2012-11-22 23:06:19 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.