Bug 867459 - remote-viewer crash (segfault) in main() right after start from the XPI plugin
remote-viewer crash (segfault) in main() right after start from the XPI plugin
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity urgent
: beta
: 6.4
Assigned To: Daniel Berrange
Virtualization Bugs
:
: 867725 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 10:44 EDT by David Jaša
Modified: 2013-02-21 04:34 EST (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-15.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:34:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-10-17 10:44:46 EDT
Description of problem:
remote-viewer crash (segfault) in main() right after start from the XPI plugin

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-12.el6.x86_64 and newer (-13 and -14)
spice-xpi-2.7-22.el6.x86_64
firefox-10.0.8-1.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. on a system with said versions, go to RHEV user portal, hit Console of some VM
2.
3.
  
Actual results:
r-v crashes

Expected results:
r-v runs

Additional info:
backtrace of -12:
Thread 1 (Thread 0x7fd32a231980 (LWP 11815)):
#0  0x000000000041e346 in main (argc=1, argv=0x7fff1ae3b788) at remote-viewer-main.c:267
        context = 0x1439e50
        error = 0x0
        ret = 1
        zoom = 100
        args = 0x0
        uri = 0x0
        title = 0x0
        verbose = 0
        debug = 0
        direct = 0
        viewer = 0x0
        controller = 1
        app = <value optimized out>
        options = {{long_name = 0x42364b "version", short_name = 86 'V', flags = 8, arg = G_OPTION_ARG_CALLBACK, arg_data = 0x41ea90, description = 0x423653 "Display version information", arg_description = 0x0}, {long_name = 0x41f35f "verbose", short_name = 118 'v', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b668, description = 0x42366f "Display verbose information", arg_description = 0x0}, {long_name = 0x423696 "title", short_name = 116 't', flags = 0, arg = G_OPTION_ARG_STRING, arg_data = 0x7fff1ae3b640, description = 0x42368b "Set window title", arg_description = 0x0}, {long_name = 0x42369c "direct", short_name = 100 'd', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b660, description = 0x423838 "Direct connection with no automatic tunnels", arg_description = 0x0}, {long_name = 0x4202ef "zoom", short_name = 122 'z', flags = 0, arg = G_OPTION_ARG_INT, arg_data = 0x7fff1ae3b66c, description = 0x423868 "Zoom level of window, in percentage", arg_description = 0x4236a3 "ZOOM"}, {long_name = 0x4236a8 "debug", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b664, description = 0x4236ae "Display debugging information", arg_description = 0x0}, {long_name = 0x4236cc "full-screen", short_name = 102 'f', flags = 32, arg = G_OPTION_ARG_CALLBACK, arg_data = 0x41e9f0, description = 0x423890 "Open in full screen mode (=<auto-conf>)", arg_description = 0x0}, {long_name = 0x4236d8 "spice-controller", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b65c, description = 0x4238b8 "Open connection using Spice controller communication", arg_description = 0x0}, {long_name = 0x420b1d "", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_STRING_ARRAY, arg_data = 0x7fff1ae3b648, description = 0x0, arg_description = 0x41f3a9 "URI"}, {long_name = 0x0, short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x0, description = 0x0, arg_description = 0x0}}


backtrace of -13:
Thread 1 (Thread 0x7fd32a231980 (LWP 11815)):
#0  0x000000000041e346 in main (argc=1, argv=0x7fff1ae3b788) at remote-viewer-main.c:267
        context = 0x1439e50
        error = 0x0
        ret = 1
        zoom = 100
        args = 0x0
        uri = 0x0
        title = 0x0
        verbose = 0
        debug = 0
        direct = 0
        viewer = 0x0
        controller = 1
        app = <value optimized out>
        options = {{long_name = 0x42364b "version", short_name = 86 'V', flags = 8, arg = G_OPTION_ARG_CALLBACK, arg_data = 0x41ea90, description = 0x423653 "Display version information", arg_description = 0x0}, {long_name = 0x41f35f "verbose", short_name = 118 'v', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b668, description = 0x42366f "Display verbose information", arg_description = 0x0}, {long_name = 0x423696 "title", short_name = 116 't', flags = 0, arg = G_OPTION_ARG_STRING, arg_data = 0x7fff1ae3b640, description = 0x42368b "Set window title", arg_description = 0x0}, {long_name = 0x42369c "direct", short_name = 100 'd', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b660, description = 0x423838 "Direct connection with no automatic tunnels", arg_description = 0x0}, {long_name = 0x4202ef "zoom", short_name = 122 'z', flags = 0, arg = G_OPTION_ARG_INT, arg_data = 0x7fff1ae3b66c, description = 0x423868 "Zoom level of window, in percentage", arg_description = 0x4236a3 "ZOOM"}, {long_name = 0x4236a8 "debug", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b664, description = 0x4236ae "Display debugging information", arg_description = 0x0}, {long_name = 0x4236cc "full-screen", short_name = 102 'f', flags = 32, arg = G_OPTION_ARG_CALLBACK, arg_data = 0x41e9f0, description = 0x423890 "Open in full screen mode (=<auto-conf>)", arg_description = 0x0}, {long_name = 0x4236d8 "spice-controller", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x7fff1ae3b65c, description = 0x4238b8 "Open connection using Spice controller communication", arg_description = 0x0}, {long_name = 0x420b1d "", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_STRING_ARRAY, arg_data = 0x7fff1ae3b648, description = 0x0, arg_description = 0x41f3a9 "URI"}, {long_name = 0x0, short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x0, description = 0x0, arg_description = 0x0}}
Comment 1 David Jaša 2012-10-17 10:46:18 EDT
forgot to add (for both revisions the same):

Core was generated by `remote-viewer --spice-controller'.
Program terminated with signal 11, Segmentation fault.
#0  0x000000000041e346 in main (argc=1, argv=0x7fff1ae3b788) at remote-viewer-main.c:267
267	        uri = g_strdup(args[0]);
Comment 2 David Jaša 2012-10-17 10:47:19 EDT
virt-viewer-0.5.2-11.el6.x86_64 works fine, everything else being equal.
Comment 3 Marc-Andre Lureau 2012-10-17 15:03:23 EDT
danpb, please cherry-pick cc0696f46f99055c042b47f3a36477719dc2580d

We currently block on you for package update, if I understand correctly.
Comment 4 Christophe Fergeau 2012-10-18 04:22:55 EDT
*** Bug 867725 has been marked as a duplicate of this bug. ***
Comment 7 Geyang Kong 2012-10-26 06:41:59 EDT
Verified pass on the following build:
virt-viewer-0.5.2-16.el6

Can be reproduced by following build:
virt-viewer-0.5.2-14.el6

Reproduce steps:
1. Install spice-xpi
2. Have a spice guest on RHEVM.
3. Try to launch remote-viewer through RHEVM web page.

Actual:
1. Remote-viewer launched normally and stayed operational.

So mark this bug as VERIFIED.
Comment 9 errata-xmlrpc 2013-02-21 04:34:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0361.html

Note You need to log in before you can comment on or make changes to this bug.