Bug 867725 - Cannot launch virt-viewer through spice-xpi
Cannot launch virt-viewer through spice-xpi
Status: CLOSED DUPLICATE of bug 867459
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 03:57 EDT by Geyang Kong
Modified: 2013-08-04 23:43 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 04:22:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geyang Kong 2012-10-18 03:57:46 EDT
Description of problem:
  Cannot launch virt-viewer through spice-xpi.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-14.el6.x86_64
spice-gtk-python-0.14-3.el6.x86_64
spice-glib-0.14-3.el6.x86_64
spice-gtk-0.14-3.el6.x86_64
spice-server-0.12.0-1.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-xpi-2.7-22.el6.x86_64
firefox-10.0.8-1.el6_3.x86_64

Reproduce steps:
1. Have a spice guest on RHEVM.
2. Login RHEVM and start the guest.
3. Click the Virtual Machines tab and choose the guest.
4. Click the "small green icon".

Actual results:
1. After step 4, remote-viewer didn't appear.
2. After step 4, fiefox frozen.

Expected results:
1. After step 4, remote-viewer launched and firefox keep alive.

Additional info:
1. When try to connect guest through spice-client. It will work well.
2. This issue cannot be reproduced by the following builds:
virt-viewer-0.5.2-11.el6.x86_64
spice-gtk-python-0.14-3.el6.x86_64
spice-glib-0.14-3.el6.x86_64
spice-gtk-0.14-3.el6.x86_64
spice-server-0.12.0-1.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-xpi-2.7-22.el6.x86_64
firefox-10.0.8-1.el6_3.x86_64
Comment 3 Christophe Fergeau 2012-10-18 04:22:55 EDT

*** This bug has been marked as a duplicate of bug 867459 ***

Note You need to log in before you can comment on or make changes to this bug.