Bug 867558 - add new mount point dialog offers /usr as option (and should not)
add new mount point dialog offers /usr as option (and should not)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 14:03 EDT by Matthew Miller
Modified: 2013-01-09 21:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 23:41:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-17 14:03:12 EDT
I'm using the F18 TC4 version of anaconda. When creating a custom partitioning scheme, I noticed that in the ADD A NEW MOUNT POINT (why the shouting, by the way?) dialog, the drop-down prefilled options are /usr and /var. But, as of http://fedoraproject.org/wiki/Features/UsrMove, we don't support /usr as a separate partition, so we should not offer that.

In fact, we should maybe find some way of telling people that this would break?

As a separate but related note, maybe we should provide options for common separate partitions /opt and /srv?
Comment 1 Jesse Keating 2012-10-17 17:55:01 EDT
I've sent a patch for not offering /usr (replaced it with /srv).

As for preventing somebody from creating a /usr/ mount that'd be a different bug (but I'm going to glance at seeing if this is a quick fix or already done).
Comment 2 Jesse Keating 2012-10-17 23:41:31 EDT
So, actually, reading that feature, /usr could be a separate filesystem.  In fact, offering /usr was added because of bug 815264

So if /usr as a mount point doesn't work, that should get filed as it's own bug and made to work.  I'm going to close this as NOTABUG in the mean time.
Comment 3 Matthew Miller 2012-10-18 08:33:51 EDT
Oh, good point. Thanks. :)

Note You need to log in before you can comment on or make changes to this bug.