Bug 867563 - server version is "Unknown" when registered to a katello/cfse/sam server
server version is "Unknown" when registered to a katello/cfse/sam server
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tom McKay
Tazim Kolhar
: Triaged
Depends On: 866995
Blocks: sam13-tracker 872333
  Show dependency treegraph
 
Reported: 2012-10-17 14:14 EDT by Tom McKay
Modified: 2016-04-25 20:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 866995
: 872333 (view as bug list)
Environment:
Last Closed: 2013-10-01 06:50:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-10-17 14:14:00 EDT
+++ This bug was initially created as a clone of Bug #866995 +++

Description of problem:
Please correct the product/component for this bug because I'm sure I got it wrong.

When a system is registered to a katello/cfse/sam server using subscription-manager, "subscription-manager version" will report the local rpm versions and the server version/type.  The server version is being reported as "Unknown".  I suspect that there is a katello api that is either blocked or not implemented to satisfy this function.


Version-Release number of selected component (if applicable):
CloudForms System Engine Version: 1.1.12-14.el6cf 
subscription-manager: 1.0.22-1.el5
python-rhsm: 1.0.10-1.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel59 ~]# subscription-manager register --username admin --serverurl=se-rhelbox.usersys.redhat.com/cfse/api --org Test_Org_1349760599 --env Dev --autosubscribe
Password: 
The system has been registered with id: 028ca17c-7469-4d43-a281-d2934281d3ba 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

[root@jsefler-rhel59 ~]# subscription-manager version
registered to: Unknown
server type: subscription management service
subscription-manager: 1.0.22-1.el5
python-rhsm: 1.0.10-1.el5



Actual results:
above; see the "registered to: Unknown"; expected something like: "1.1.12-14.el6cf"


Additional info:

--- Additional comment from bkearney@redhat.com on 2012-10-17 13:38:50 EDT ---

This is solely on the katello side.
Comment 2 Tom McKay 2012-10-25 08:50:20 EDT
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 52621d6a7109db428c37277b6923466a7b4fd415
      https://github.com/Katello/katello/commit/52621d6a7109db428c37277b6923466a7b4fd415
  Author: Lukas Zapletal <lzap+git@redhat.com>
  Date:   2012-10-25 (Thu, 25 Oct 2012)
Comment 3 Mike McCune 2012-10-31 13:56:48 EDT
moving to 2.0
Comment 4 Bryan Kearney 2013-06-07 14:19:38 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 5 Tazim Kolhar 2013-08-12 02:24:42 EDT
VERIFIED:

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch

# subscription-manager register --org="ACME_Corporation" --autosubscribe
Username: admin
Password: 
The system has been registered with id: 88a793ab-368c-4c72-8a47-c7923fa89570 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

# subscription-manager list
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69                       
Version:              	6.3                      
Arch:                 	x86_64                   
Status:               	Subscribed               
Starts:               	12/31/2012               
Expires:              	12/31/2013
Comment 7 errata-xmlrpc 2013-10-01 06:50:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.