Bug 867605 - NoSuchGroup: gnome-desktop
NoSuchGroup: gnome-desktop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:e35f600e124a17f304824b89197...
:
: 867414 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 16:17 EDT by Reartes Guillermo
Modified: 2013-01-09 21:25 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 01:56:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (251.41 KB, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: storage.log (95.47 KB, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: environ (764 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (7.56 KB, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: syslog (74.05 KB, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: packaging.log (3.29 KB, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details
File: program.log (28.24 KB, text/plain)
2012-10-17 16:17 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-17 16:17:02 EDT
Description of problem:
i was testing for 864737

Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 806, in environmentDescription
:    raise NoSuchGroup(environmentid)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 152, in status
:    return self.payload.environmentDescription(row[2])[0]
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 198, in _updateCompleteness
:    spoke.selector.set_property("status", spoke.status)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 262, in _update_spokes
:    self._updateCompleteness(spoke)
:NoSuchGroup: gnome-desktop
Comment 1 Reartes Guillermo 2012-10-17 16:17:10 EDT
Created attachment 629059 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-17 16:17:13 EDT
Created attachment 629060 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-17 16:17:15 EDT
Created attachment 629061 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-17 16:17:17 EDT
Created attachment 629062 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-17 16:17:21 EDT
Created attachment 629063 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-17 16:17:23 EDT
Created attachment 629064 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-17 16:17:25 EDT
Created attachment 629065 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-17 16:17:28 EDT
Created attachment 629066 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-17 16:17:31 EDT
Created attachment 629067 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-17 16:17:33 EDT
Created attachment 629068 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-17 16:17:36 EDT
Created attachment 629069 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-17 16:17:38 EDT
Created attachment 629070 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-17 16:17:40 EDT
Created attachment 629071 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-17 16:17:43 EDT
Created attachment 629072 [details]
File: program.log
Comment 15 Adam Williamson 2012-10-17 21:31:42 EDT
Booted the F18 Beta TC4 DVD, changed installation source to http://download.fedoraproject.org/pub/fedora/linux/development/18/x86_64/os/ , went back to the hub, waited for it to complete downloading metadata.

Package: anaconda-18.16
OS Release: Fedora release 18-Beta-TC4
Comment 16 Adam Williamson 2012-10-17 21:58:08 EDT
This doesn't seem to be an issue with the repos exactly, I think it's more in anaconda's handling of this case where you start out with the default DVD repo and switch to a remote repo. I just reproduced it simply by switching to 'nearest mirror'. It doesn't seem to happen if you pass repo=http://foo on the command line, or when using netinst - it's really to do with switching from the DVD repo to a remote repo interactively.
Comment 17 Adam Williamson 2012-10-17 22:03:21 EDT
though I found this doing the validation tests I don't think it's really a blocker, booting the DVD but installing from a remote repo is a somewhat unusual case, so I'm not nominating it as such.
Comment 18 Jesse Keating 2012-10-18 00:09:08 EDT
I think this has to do with some recent changes in whether the software or source spoke is ready.  I see other problems with this so I'm going to take it and try to make these all work.
Comment 19 Jesse Keating 2012-10-19 13:23:52 EDT
*** Bug 867414 has been marked as a duplicate of this bug. ***
Comment 20 Jesse Keating 2012-10-19 13:25:55 EDT
I cannot reproduce this with smoke11 which has anaconda-18.18.  We're going to wait for Test Compose 5 and see if we can still reproduce this.
Comment 21 Adam Williamson 2012-10-22 20:10:35 EDT
Couldn't reproduce this exactly with TC6, but there's still something odd. I change installation source to 'Closest mirror', go back to the hub, wait a bit, and it all clears up, no crash. Software Selection shows 'GNOME Desktop' with the warning triangle - this is correct, I've been told, and you have to go into the spoke and out again to shift it. Fine. I go into the spoke, I click Done, I'm back at the hub, and it still has the triangle. No matter how many times I try, still triangle. I have to switch to KDE and then back to GNOME to shift it. Still, this crash seems to be gone.
Comment 22 Adam Williamson 2012-10-22 20:12:10 EDT
I can still reproduce the crash with TC4, so something definitely changed between TC4 and TC6 that fixed this.
Comment 23 Jesse Keating 2012-10-26 01:56:00 EDT
This is fixed as of 18.19, please re-open if it doesn't work.

Note You need to log in before you can comment on or make changes to this bug.