Bug 867842 - Add abrt script to retrieve /proc/mdstat in case of crash
Add abrt script to retrieve /proc/mdstat in case of crash
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
:
: 868201 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 08:07 EDT by Jes Sorensen
Modified: 2012-11-23 02:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 21:48:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2012-10-18 08:07:36 EDT
Add abrt config script to retrieve and include /proc/mdstat in bug report
in case of mdadm/mdmon crashing
Comment 1 Fedora Update System 2012-10-18 11:39:18 EDT
mdadm-3.2.5-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-12.fc18
Comment 2 Fedora Update System 2012-10-18 11:44:49 EDT
mdadm-3.2.5-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-12.fc17
Comment 3 Fedora Update System 2012-10-18 18:25:13 EDT
Package mdadm-3.2.5-12.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.2.5-12.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16434/mdadm-3.2.5-12.fc17
then log in and leave karma (feedback).
Comment 4 nucleo 2012-10-18 20:02:40 EDT
There are no packages with such hard abrt dependency that was added in mdadm-3.2.5-12.fc17 and makes impossible to uninstall abrt.
Comment 5 Kevin Kofler 2012-10-18 20:21:05 EDT
+1 to what nucleo said, such dependency bloat is really unhelpful.
Comment 6 Kevin Kofler 2012-10-18 20:28:26 EDT
I guess the added script would be better placed in the ABRT package(s); nucleo pointed me to this existing example on IRC: http://koji.fedoraproject.org/koji/rpminfo?rpmID=3421091
Comment 7 Jes Sorensen 2012-10-19 04:22:45 EDT
I agree, requiring abrt is a little heavy. After some digging I notice that
it would be sufficient to just depend on the presence of libreport-filesystem.
Ie. you will end up with the 4 line script installed, but you can get rid of
abrt if you like[1].

Putting the script into the abrt package does not make sense. It means if a
script needs to be changed or enhanced, every package maintainer needs to
coordinate with the abrt package maintainer to get an update out. It is clearly
the intention of abrt for packages to provide their own scripts, since only the
package maintainers know what they look for.

Second, creating a sub-package doesn't make sense for a 4-line script. The
example you give for the xorg analyser is different, since it provides it's
own script to analyse the output as well.

I'll try and push this change out today.

Jes

1: That said, if you file a bug against mdadm, just make sure you send me
   *everything* I would get with the abrt script, or I will reserve the
   right to ignore your bug report.
Comment 8 Jes Sorensen 2012-10-19 05:29:16 EDT
*** Bug 868201 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2012-10-19 09:48:05 EDT
mdadm-3.2.5-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-12.fc17
Comment 10 Fedora Update System 2012-10-19 09:53:59 EDT
mdadm-3.2.5-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-13.fc17
Comment 11 Harald Reindl 2012-10-19 09:55:31 EDT
=============================================================================================================================
 Package                       Arch                   Version                          Repository                      Größe
=============================================================================================================================
Aktualisieren:
 mdadm                         x86_64                 3.2.5-12.fc17                    updates-testing                 336 k
Als Abhängigkeiten installiert:
 abrt                          x86_64                 2.0.16-1.fc17                    updates-testing                 223 k
 abrt-libs                     x86_64                 2.0.16-1.fc17                    updates-testing                  70 k
 btparser                      x86_64                 0.20-1.fc17                      updates-testing                 432 k
 elfutils-libs                 x86_64                 0.154-2.fc17                     updates                         185 k

Vorgangsübersicht
=============================================================================================================================
Installieren             ( 4 Dependent packages)
Upgrade       1 Package
Comment 12 Jes Sorensen 2012-10-19 10:11:52 EDT
-13 will show up shortly in updates-testing, if you cannot wait, you can get
it here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=361095

We all understand the problem here, no point in spamming the bz with it all
again.
Comment 13 Harald Reindl 2012-10-19 10:17:21 EDT
no spam - my bugreport was marked as duplicated with this here, i received a notify about the 3.2.5-12.fc17 build which should solve the problem and pinged back that it is not the case (not knowing that the same time the next build arrives)
Comment 14 Jes Sorensen 2012-10-19 10:40:28 EDT
(In reply to comment #13)
> no spam - my bugreport was marked as duplicated with this here, i received a
> notify about the 3.2.5-12.fc17 build which should solve the problem and
> pinged back that it is not the case (not knowing that the same time the next
> build arrives)

-13 was already announced in the system, but you still reported against -12.

In addition, please keep with the language of the BZ when you post.
Comment 15 Fedora Update System 2012-10-19 12:34:54 EDT
mdadm-3.2.5-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-14.fc17
Comment 16 Fedora Update System 2012-10-19 12:39:18 EDT
mdadm-3.2.5-14.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.5-14.fc18
Comment 17 Jes Sorensen 2012-10-19 12:40:56 EDT
Due to breakage in bodhi, the updates will be mdadm-3.2.5-14.fc1[78] - they
should show up in the updates-testing repositories within the next 24 hours
or so.
Comment 18 Fedora Update System 2012-10-19 19:54:09 EDT
Package mdadm-3.2.5-14.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.2.5-14.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16487/mdadm-3.2.5-14.fc17
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-10-26 04:31:25 EDT
mdadm-3.2.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-1.fc18
Comment 20 Fedora Update System 2012-10-26 04:39:26 EDT
mdadm-3.2.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mdadm-3.2.6-1.fc17
Comment 21 Fedora Update System 2012-11-14 21:48:44 EST
mdadm-3.2.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2012-11-23 02:13:40 EST
mdadm-3.2.6-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.