Bug 868201 - 3.2.5-12: please REMOVE the arbt-dep
3.2.5-12: please REMOVE the arbt-dep
Status: CLOSED DUPLICATE of bug 867842
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 05:17 EDT by Harald Reindl
Modified: 2012-10-19 05:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 05:29:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2012-10-19 05:17:14 EDT
* Thu Oct 18 2012 Jes Sorensen <Jes.Sorensen@redhat.com> - 3.2.5-12 - Add abrt script to retrieve /proc/mdstat output in case of crash - Resolves bz867842

you may add scripts BUT PLEASE do not "Requires: abrt"

why do people not understand that these are the things making it more and more difficult to get a tiny system - this dependency pulls other ones and the next time "btparser" adds it's own one (explicit or implicit) we are pulling it too

no i do not want arbt on any system
no i do not want a cross-dependency tree on tiny servers
yes i want LESSER dependencies

since it pulls 4 packages even on my desktop machine i am furstrated to see the road still go to a fater and fater distribution
________________________

Updating:
 mdadm                         x86_64                 3.2.5-12.fc17
Installing for dependencies:
 abrt                          x86_64                 2.0.16-1.fc17
 abrt-libs                     x86_64                 2.0.16-1.fc17
 btparser                      x86_64                 0.20-1.fc17
 elfutils-libs                 x86_64                 0.154-2.fc17
Comment 1 Jes Sorensen 2012-10-19 05:29:16 EDT
This is already addressed in -13

Now why do people not understand that package maintainers need proper bug
reports in order to be able to fix bugs....

*** This bug has been marked as a duplicate of bug 867842 ***
Comment 2 Harald Reindl 2012-10-19 05:35:29 EDT
the problem is that you need to report bugs which where intoduced while fixing things which ain't broken - another example how fedora comes more and more fat

https://bugzilla.redhat.com/show_bug.cgi?id=868208
Comment 3 Jes Sorensen 2012-10-19 05:43:28 EDT
I added the abrt feature because I have problems with incomplete bug reports
for mdadm, and I need that info in order to address the bug reports that I
receive.

This is a balance act, and it is impossible to keep everybody happy. It doesn't
mean one doesn't try.

I cannot speak for other package maintainers and why they add what they add,
you have to take that up with them.

Note You need to log in before you can comment on or make changes to this bug.