Bug 868064 - semanage -i throws an error
semanage -i throws an error
Status: CLOSED DUPLICATE of bug 836087
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 22:35 EDT by John Griffiths
Modified: 2012-10-20 14:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-20 14:14:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2012-10-18 22:35:47 EDT
Description of problem:
semanage -i of a file produced using semanage in Fedora 16 does not import and results in an error.

Version-Release number of selected component (if applicable):

policycoreutils-python-2.1.11-18.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. semanage -i /tmp/local.selinux
  
Actual results:
Traceback (most recent call last):
  File "/sbin/semanage", line 566, in <module>
    trans.finish()
  File "/usr/lib/python2.7/site-packages/seobject.py", line 285, in finish
    self.commit()
  File "/usr/lib/python2.7/site-packages/seobject.py", line 274, in commit
    semanage_set_reload(self.sh, self.reload)
TypeError: in method 'semanage_set_reload', argument 2 of type 'int'


Expected results:
Should set the contexts and booleans to what is in the file.

Additional info:
I tried using cat with a pipe to semanage and got the same result.

I do not know if the file being from a Fedora 16 system has anything to do with the problem. I just know that on a fresh Fedora 17 install I wanted to set the selinux contexts on the directories, etc, to what I was using under the previous installation.
Comment 1 John Griffiths 2012-10-20 14:14:29 EDT

*** This bug has been marked as a duplicate of bug 836087 ***

Note You need to log in before you can comment on or make changes to this bug.