Bug 836087 - [abrt] policycoreutils-python-2.1.11-18.fc17: seobject.py:274:commit:TypeError: in method 'semanage_set_reload', argument 2 of type 'int'
[abrt] policycoreutils-python-2.1.11-18.fc17: seobject.py:274:commit:TypeErro...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
abrt_hash:e6220ddbdb00713132c71ebb07d...
:
: 868064 (view as bug list)
Depends On:
Blocks: 848130
  Show dependency treegraph
 
Reported: 2012-06-28 01:30 EDT by Juan Orti
Modified: 2012-12-20 10:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Orti 2012-06-28 01:30:35 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -Es /sbin/semanage -S targeted -i -
executable:     /sbin/semanage
kernel:         3.3.7-1.fc17.x86_64
time:           dom 27 may 2012 20:45:39 CEST
uid:            0
username:       root

backtrace:
:seobject.py:274:commit:TypeError: in method 'semanage_set_reload', argument 2 of type 'int'
:
:Traceback (most recent call last):
:  File "/sbin/semanage", line 566, in <module>
:    trans.finish()
:  File "/usr/lib64/python2.7/site-packages/seobject.py", line 285, in finish
:    self.commit()
:  File "/usr/lib64/python2.7/site-packages/seobject.py", line 274, in commit
:    semanage_set_reload(self.sh, self.reload)
:TypeError: in method 'semanage_set_reload', argument 2 of type 'int'
:
:Local variables in innermost frame:
:self: <seobject.semanageRecords instance at 0x2747a28>
Comment 1 Miroslav Grepl 2012-06-29 05:16:20 EDT
Fixed in policycoreutils-2.1.11-19.1.fc17.x86_64
Comment 2 Miroslav Suchý 2012-10-19 10:23:50 EDT
Can you please release it via updates? This is cousing problem for us as well (Katello project).
Comment 3 Miroslav Grepl 2012-10-19 12:14:26 EDT
No idea why this is still opened. I apologize.
Comment 4 Miroslav Suchý 2012-10-20 14:14:26 EDT
You build that package in koji, but it has been garbage collected. Most probably because you did not associate it with update in bodhi.
Comment 5 John Griffiths 2012-10-20 14:14:29 EDT
*** Bug 868064 has been marked as a duplicate of this bug. ***
Comment 6 John Griffiths 2012-10-20 14:16:16 EDT
This is happening in i686 too; 3.6.2-4.fc17.i686.PAE
Comment 7 Fedora Update System 2012-10-24 09:04:38 EDT
policycoreutils-2.1.12-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/policycoreutils-2.1.12-4.fc17
Comment 8 Fedora Update System 2012-10-24 19:56:35 EDT
Package policycoreutils-2.1.12-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.12-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16848/policycoreutils-2.1.12-4.fc17
then log in and leave karma (feedback).
Comment 9 Miroslav Suchý 2012-10-30 02:22:10 EDT
I tested the new package and it gets further, but still failing. The error changed from:

Non-fatal POSTIN scriptlet failure in rpm package katello-selinux-1.1.2-1.fc17.noarch
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 566, in <module>
    trans.finish()
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 285, in finish
    self.commit()
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 274, in commit
    semanage_set_reload(self.sh, self.reload)
TypeError: in method 'semanage_set_reload', argument 2 of type 'int'

to:

Non-fatal POSTIN scriptlet failure in rpm package katello-selinux-1.1.2-1.fc17.noarch
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 568, in <module>
    process_args(mkargv(l))
  File "/usr/sbin/semanage", line 449, in process_args
    OBJECT.modify(target, value, use_file)
  File "/usr/lib64/python2.7/site-packages/seobject.py", line 2026, in modify
    name = selinux.selinux_boolean_sub(name)
AttributeError: 'module' object has no attribute 'selinux_boolean_sub'
Comment 10 Miroslav Grepl 2012-10-31 09:34:30 EDT
Fixed in policycoreutils-2.1.12-5.fc17
Comment 11 Miroslav Suchý 2012-10-31 10:45:34 EDT
Indeed.
Thanks.
Comment 12 Fedora Update System 2012-10-31 21:25:22 EDT
Package policycoreutils-2.1.12-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.12-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16848/policycoreutils-2.1.12-5.fc17
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-12-20 10:27:49 EST
policycoreutils-2.1.12-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.