Bug 868106 - virt-viewer cannot detect USB devices from host.
virt-viewer cannot detect USB devices from host.
Status: CLOSED DUPLICATE of bug 804187
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 00:57 EDT by Geyang Kong
Modified: 2013-08-04 23:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 04:26:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geyang Kong 2012-10-19 00:57:36 EDT
Description of problem:
  virt-viewer cannot detect USB devices from host.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-14.el6.x86_64
spice-gtk-0.14-3.el6.x86_64
spice-vdagent-0.12.0-2.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-server-0.12.0-1.el6.x86_64
spice-gtk-python-0.14-3.el6.x86_64
spice-glib-0.14-3.el6.x86_64


Reproduce steps:
1. Make sure there are some USB devices plugged into host.
2. Have a spice+qxl guest and make it ready for usb redirection.
3. Run virt-viewer $guestname
4. Click file->USB device seletion

Actual results:
1. After step 4, virt-viewer said No USB devices detected.

Expected results:
1. After step 4, virt-viewer could find USB devices normally.

Additional info:
1. This issue cannot be reproduced by the following builds:
virt-viewer-0.5.2-9.el6.x86_64
spice-server-0.10.1-10.el6.x86_64
spice-gtk-0.11-11.el6_3.1.x86_64
spice-glib-0.11-11.el6_3.1.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-gtk-python-0.11-11.el6_3.1.x86_64
Comment 1 Geyang Kong 2012-10-19 01:42:17 EDT
After upgrading to spice to following build, this bug has gone.

spice-gtk-debuginfo-0.14-4.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-server-0.12.0-1.el6.x86_64
spice-gtk-python-0.14-4.el6.x86_64
spice-gtk-0.14-4.el6.x86_64
spice-glib-0.14-4.el6.x86_64
spice-gtk-tools-0.14-4.el6.x86_64
Comment 2 Christophe Fergeau 2012-10-19 04:26:16 EDT
This was a bug in spice-gtk-0.14-3.el6.x86_64 which was fixed in spice-gtk-0.14-4.el6.x86_64

*** This bug has been marked as a duplicate of bug 804187 ***

Note You need to log in before you can comment on or make changes to this bug.