Bug 868577 - F18 anaconda: graphical buttons badly designed
F18 anaconda: graphical buttons badly designed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 18:39 EDT by Tom Lane
Modified: 2013-07-02 23:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 10:35:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2012-10-20 18:39:38 EDT
Description of problem:
I'd like to whine about some very poor UI choices in F18-beta anaconda:

1. The first screen presented, to select your keyboard layout, looks like a text entry box.  So one would expect pressing Return to choose the highlighted selection and move on.  But nothing happens.  After awhile, you might chance to notice the Continue button, which is away off in the lower right corner (very far from the dialog box, if your screen is large), and is the same color as the page background, with text only a very slightly different color.  A person with eyesight only a little worse than mine might never notice it at all, making this an accessibility failure.

2. The understated Continue button is repeated on subsequent pages ... except that on the network setup page (and maybe others, I've not gotten past bug 855526 yet), if you return to that page from the hub page, it's not there, instead there is a Done button in the upper left corner.  What is the point of this random inconsistency?

In short, the graphical buttons REALLY need to be more obvious, and more consistently placed, and a bit more attention to keyboard-only entry wouldn't be a bad thing either.

BTW, I also agree with Paolo Borelli's complaints in bug 868536 and bug 868537.
Overall it seems that F18's UI has been redesigned by someone with very little familiarity with UI design principles.

Version-Release number of selected component (if applicable):
anaconda-18.19-1.fc18
Comment 1 Chris Lumens 2012-10-21 19:47:12 EDT
Might I suggest you refrain from comments like:

"Overall it seems that F18's UI has been redesigned by someone with very little familiarity with UI design principles."?

It does not really do anything to help your cause, nor does it serve any real purpose in this bug report.

Note You need to log in before you can comment on or make changes to this bug.