Bug 868664 - DVD install overwrites MBR on disk not in install selection
DVD install overwrites MBR on disk not in install selection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 10:35 EDT by Flóki Pálsson
Modified: 2012-12-11 15:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 15:17:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/anaconda/anaconda.log (10.83 KB, text/plain)
2012-10-21 10:35 EDT, Flóki Pálsson
no flags Details
anaconda.storage.log (333.95 KB, text/plain)
2012-10-22 15:50 EDT, Flóki Pálsson
no flags Details
anaconda.program.log (223.31 KB, text/plain)
2012-10-22 15:53 EDT, Flóki Pálsson
no flags Details
[18.29.2] anaconda.log (11.28 KB, text/plain)
2012-11-27 16:15 EST, Steve Tyler
no flags Details
[18.29.2] anaconda.packaging.log (45.28 KB, text/plain)
2012-11-27 16:16 EST, Steve Tyler
no flags Details
[18.29.2] anaconda.program.log (46.31 KB, text/plain)
2012-11-27 16:16 EST, Steve Tyler
no flags Details
[18.29.2] anaconda.storage.log (140.84 KB, text/plain)
2012-11-27 16:17 EST, Steve Tyler
no flags Details
[18.29.2] syslog (67.17 KB, text/plain)
2012-11-27 16:20 EST, Steve Tyler
no flags Details
[18.29.2] anaconda-ks.cfg (854 bytes, text/plain)
2012-11-27 16:21 EST, Steve Tyler
no flags Details
screenshot showing grub "error: no such device" message and grub prompt (13.08 KB, image/png)
2012-11-27 23:40 EST, Steve Tyler
no flags Details
[18.29.2] anaconda.storage-1.log after reinstalling to Disk 2 (203.39 KB, text/plain)
2012-11-27 23:50 EST, Steve Tyler
no flags Details

  None (edit)
Description Flóki Pálsson 2012-10-21 10:35:55 EDT
Created attachment 630888 [details]
/var/log/anaconda/anaconda.log

Description of problem:
DVD install from Fedora-18-Beta-TC6-x86_64-DVD.iso changes MBR on disk outsite selected disks in installer. 


Version-Release number of selected component (if applicable):
$ rpm -qa | grep  anaconda
anaconda-yum-plugins-1.0-8.fc18.noarch



How reproducible:
always ( tow times )


Steps to Reproduce:
1. Install from DVD  Fedora-18-Beta-TC6-x86_64-DVD.iso
2. In installer select disk /dev/sda ( BIOS boots /dev/sdc )
3. Reboot
  
Actual results:
MBR on /dev/sdc is owerwritten

Expected results:
MBR wirte to /dev/sda not /dev/sdc

Additional info:
Bios is sett to boot form /dev/sdc.
Insalling live Fedora-18-Beta-TC6-x86_64-Live-Desktop.iso does not owerwrite MBR on /dev/sdc.
I have not seen this in previus F18 vertions.

# blkid
/dev/sda1: UUID="03caa5d1-e66b-4c05-b43e-35e72221e3db" TYPE="ext4" 
/dev/sda2: UUID="b2841259-e293-46b5-aca8-af9eb974f269" TYPE="swap" 
/dev/sda3: UUID="cc5ea8d7-e57b-4129-9842-1c883d1b1882" TYPE="ext4" 
/dev/sda5: UUID="c3f63379-f2ca-4410-99e9-211339220514" TYPE="ext4" 
/dev/sdb1: LABEL="tonl" UUID="ca6b045e-79a6-446f-877b-665065cf7736" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sdb5: LABEL="ymisl" UUID="2edca9a6-bd5d-4f53-be45-89de1c1badbf" TYPE="ext4" 
/dev/sdc1: UUID="8074264c-253e-470b-8542-c7c94421abef" TYPE="swap" 
/dev/sdc2: LABEL="F14" UUID="72a4b3b4-0192-4ab2-990c-f1d7de5b74dc" TYPE="ext4" 
/dev/sdc3: UUID="6160908b-a3ef-438f-87bc-ae58ed6e9745" TYPE="ext4" PTTYPE="dos" 
/dev/sdc5: LABEL="Fedora-13-x86_64" UUID="7ae5713c-a37d-4839-b745-d09bcad72068" TYPE="ext4" PTTYPE="dos" 
/dev/sdc6: LABEL="F15" UUID="857f46f6-4201-4c27-952f-4c71c236cbb9" TYPE="ext4" PTTYPE="dos" 
/dev/sdc7: LABEL="UB1104" UUID="38b20bcf-26f5-49d9-bb36-f1ce3bb7b558" TYPE="ext4" PTTYPE="dos" 
/dev/sdc8: UUID="15711116-8188-4f6f-b581-184811f97dce" TYPE="ext4" PTTYPE="dos" 
/dev/sdc9: LABEL="deb6" UUID="64b1e4d4-beea-40e9-97ba-15823f798cfc" TYPE="ext4" PTTYPE="dos" 
/dev/sdc10: LABEL="F18" UUID="271a9e52-a02a-4223-afd2-7d0780519e86" TYPE="ext4" PTTYPE="dos" 
/dev/sdc11: LABEL="F17" UUID="fe02c4e2-7dd9-4b45-bfac-08604cee23a6" TYPE="ext4" PTTYPE="dos" 
/dev/sdc12: LABEL="unity" UUID="0e85be6f-4c74-432e-aa35-d16dba2e991e" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sdc13: UUID="c93daa69-5aad-4e16-b0d9-bc24d62d30f7" TYPE="ext4" 
/dev/sdc14: UUID="00931646-9740-46ac-bf40-01d9dea44dd8" TYPE="ext4" 
[root@localhost ~]#
Comment 1 Chris Lumens 2012-10-22 11:21:39 EDT
Please attach /var/log/anaconda/storage.log and /var/log/anaconda/program.log.  We default to using the first disk, unless you tell us otherwise.
Comment 2 Flóki Pálsson 2012-10-22 15:50:40 EDT
Created attachment 631714 [details]
anaconda.storage.log
Comment 3 Flóki Pálsson 2012-10-22 15:53:13 EDT
Created attachment 631715 [details]
anaconda.program.log
Comment 4 Flóki Pálsson 2012-10-22 16:05:03 EDT
>Please attach /var/log/anaconda/storage.log and /var/log/anaconda/program.log.
done

> We default to using the first disk, unless you tell us otherwise.
There was no warnig or information that MBR would be writen to /dev/sdc which was not selected.  There was only /dev/sda which was selected to use fore insatation.  MBR is writen to /dev/sdc.
Comment 5 Paul Franklin (RHlists) 2012-11-13 20:08:44 EST
I would like to propose this as Final NTH.

It seems to me the user should have some control over
where -- or if -- a bootloader should be installed.

I used to install mine in sector-zero of the Fedora
partition, using the old anaconda UI, but I don't see
that possibility being offered in the new UI.

Nor do I see any option like "install no bootloader."

As the moment (Beta TC8) my main bootloader is in the
MBR of my first disk (sda) and luckily for me anaconda
is always installing its bootloader into the MBR of sdc
(my third disk, which is where I am installing F18).
So mine isn't being destroyed.

It seems to me it certainly violates the spirit, if not
the letter, of: "The installer must be able to create and
install to any workable partition layout using any file
system offered in a default installer configuration, LVM,
software, hardware or BIOS RAID, or combination of the above."

I don't see any release criteria talking about bootloaders,
directly, only in passing.  Perhaps it should be considered.

Thanks.
Comment 6 Steve Tyler 2012-11-27 16:05:56 EST
Reproduced with anaconda 18.29.2 and two disks:
Selecting Disk 1 in the BIOS results in Disk 2 being booted.
Selecting Disk 2 in the BIOS results in a hang with:
"Booting from Hard Disk..."

Detailed procedure:

Create two disc images with slightly different sizes so they can be unambiguously distinguished in the installer:
$ qemu-img create f18-test-1.img 11G
$ qemu-img create f18-test-2.img 12G

Start the installer with both disc images:
$ qemu-kvm -m 2048 -hda f18-test-1.img -hdb f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/Final/Fedora-18-Beta-x86_64-DVD.iso -usb -vga qxl -boot menu=on -usbdevice mouse

Install to f18-test-1.img:
1.  Boot from the installer disc.
2.  Set timezone to America/Los_Angeles.
3.  Select a minimal install.
4.  Click on Installation Destination.
5.  Click on the 11G disc image.
6.  Click Done.
7.  Click Begin Installation, set a root password.
8.  After installation is complete, reboot, select Disk 1 from the BIOS, login, and verify that the timezone is Pacific (PXT) by running "date".

Install to f18-test-2.img:
1.  Reboot from the installer disc.
2.  Set timezone to America/Denver.
3.  Select a minimal install.
4.  Click on Installation Destination.
5.  Click on the 12G disc image.
6.  Click Done.
7.  Click Begin Installation, set a root password.
8.  After installation is complete, reboot, select Disk 1 from the BIOS, login, and verify that the timezone is Mountain (MXT) by running "date".

Actual results:
It is not possible to boot from f18-test-1.img. Attempting to boot from Disk 2 in the BIOS results in a hang.

Expected results:
It is possible to boot from f18-test-1.img or f18-test-2.img by selecting one or the other in the BIOS.
Comment 7 Steve Tyler 2012-11-27 16:15:31 EST
Created attachment 653119 [details]
[18.29.2] anaconda.log
Comment 8 Steve Tyler 2012-11-27 16:16:15 EST
Created attachment 653122 [details]
[18.29.2] anaconda.packaging.log
Comment 9 Steve Tyler 2012-11-27 16:16:57 EST
Created attachment 653123 [details]
[18.29.2] anaconda.program.log
Comment 10 Steve Tyler 2012-11-27 16:17:41 EST
Created attachment 653124 [details]
[18.29.2] anaconda.storage.log
Comment 11 Steve Tyler 2012-11-27 16:20:35 EST
Created attachment 653126 [details]
[18.29.2] syslog
Comment 12 Steve Tyler 2012-11-27 16:21:13 EST
Created attachment 653127 [details]
[18.29.2] anaconda-ks.cfg
Comment 13 Steve Tyler 2012-11-27 16:23:58 EST
[snippet from attached anaconda.storage.log]
...
13:23:51,662 INFO storage: bootloader stage1 target device is sda
13:23:51,663 INFO storage: bootloader stage2 target device is sdb1
13:23:51,665 DEBUG storage: new default image: <pyanaconda.bootloader.LinuxBootLoaderImage object at 0x7f2e6e5477d0>
13:23:55,385 INFO storage: bootloader.py: used boot args: rd.lvm.lv=fedora/swap rd.lvm.lv=fedora00/root rd.dm=0 rd.lvm.lv=fedora00/swap $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.md=0 rd.luks=0 rhgb quiet
Comment 14 Steve Tyler 2012-11-27 17:00:24 EST
Flóki: I agree with Paul[1] that this bug should be an F18 blocker. If you agree, you can propose this bug as an F18 blocker by adding the F18Blocker bug alias[2] to the blocks list for this bug.

Release criteria that could apply:

F18 Final:[3]
8. The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above 
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

F18 Beta:
9. The installer must be able to complete an installation using automatic partitioning to a validly-formatted disk with sufficient empty space, using the empty space and installing a bootloader but leaving the pre-existing partitions and data untouched 
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria

F18 Alpha:
19. When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles 
https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria

[1] Comment 5.
[2] http://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers
[3] Thanks, Paul -- Comment 5.
Comment 15 Steve Tyler 2012-11-27 17:52:52 EST
(In reply to comment #5)
...
> It seems to me the user should have some control over
> where -- or if -- a bootloader should be installed.
...

Bug 867469 - f18b tc4 anaconda (graphical) there is no option to not to install a boot loader
Comment 16 Steve Tyler 2012-11-27 23:40:09 EST
Created attachment 653250 [details]
screenshot showing grub "error: no such device" message and grub prompt

If you reinstall to Disk 2, booting from Disk 1 fails with a grub error message:
error: no such device: <device UUID not transcribed>
Entering rescue mode...
grub rescue> _

Booting from Disk 2 succeeds, and the reinstalled system is booted.

Tip: When reinstalling, set the timezone to one not already used, so that the reinstalled system can be identified after it is booted.
Comment 17 Steve Tyler 2012-11-27 23:50:09 EST
Created attachment 653257 [details]
[18.29.2] anaconda.storage-1.log after reinstalling to Disk 2

[snippet from attached anaconda.storage-1.log]
...
22:06:53,243 INFO storage: bootloader stage1 target device is sdb
22:06:53,243 INFO storage: bootloader stage2 target device is sdb1
22:06:53,245 DEBUG storage: new default image: <pyanaconda.bootloader.LinuxBootLoaderImage object at 0x7f49b98a3f10>
22:06:56,389 INFO storage: bootloader.py: used boot args: rd.lvm.lv=fedora00/root rd.dm=0 rd.lvm.lv=fedora00/swap $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.md=0 rd.luks=0 rhgb quiet
Comment 18 Chris Lumens 2012-12-11 13:35:46 EST
I cannot reproduce this with the F18 Beta DVD plus an updates image containing everything done since beta.  Can you please retest with the next DVD image made and verify?  Thanks.
Comment 19 Flóki Pálsson 2012-12-11 15:16:03 EST
(In reply to comment #18)
> I cannot reproduce this with the F18 Beta DVD plus an updates image
> containing everything done since beta.  Can you please retest with the next
> DVD image made and verify?  Thanks.

Ok now.
Tried 
Fedora-18-TC1-x86_64-Live-Desktop.iso
Fedora-18-TC1-x86_64-DVD.iso
Comment 20 Chris Lumens 2012-12-11 15:17:06 EST
Great, thanks for retesting.

Note You need to log in before you can comment on or make changes to this bug.