Bug 872446 - ValueError: new size same as old size
ValueError: new size same as old size
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:b889774ec49b343fcdd654038fb...
:
: 868698 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-02 01:11 EDT by wagerrard
Modified: 2012-11-10 00:44 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-18.24-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:15:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (373.25 KB, text/plain)
2012-11-02 01:11 EDT, wagerrard
no flags Details
File: product (6 bytes, text/plain)
2012-11-02 01:11 EDT, wagerrard
no flags Details
File: type (9 bytes, text/plain)
2012-11-02 01:11 EDT, wagerrard
no flags Details
File: ifcfg.log (1.10 KB, text/plain)
2012-11-02 01:11 EDT, wagerrard
no flags Details
File: storage.log (138.45 KB, text/plain)
2012-11-02 01:11 EDT, wagerrard
no flags Details
File: version (2 bytes, text/plain)
2012-11-02 01:11 EDT, wagerrard
no flags Details
File: environ (780 bytes, text/plain)
2012-11-02 01:11 EDT, wagerrard
no flags Details
File: executable (14 bytes, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details
File: anaconda.log (9.13 KB, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details
File: syslog (109.70 KB, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details
File: packaging.log (2.83 KB, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details
File: cmdline_file (87 bytes, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details
File: release (24 bytes, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details
File: program.log (74.76 KB, text/plain)
2012-11-02 01:12 EDT, wagerrard
no flags Details

  None (edit)
Description wagerrard 2012-11-02 01:11:26 EDT
Description of problem:
Anaconda 18.23, in partitioning segment:  Highlighed existing partition and clicked on gears icon.

Version-Release number of selected component:
anaconda-18.23

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.5-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.23 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 355, in __init__
:    raise ValueError("new size same as old size")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1196, in resizeDevice
:    self.devicetree.registerAction(action_class(device, new_size))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1169, in _save_right_side
:    self.__storage.resizeDevice(device, size)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1929, in on_selector_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 195, in _onSelectorClicked
:    cb(selector)
:ValueError: new size same as old size
Comment 1 wagerrard 2012-11-02 01:11:29 EDT
Created attachment 636933 [details]
File: anaconda-tb
Comment 2 wagerrard 2012-11-02 01:11:31 EDT
Created attachment 636934 [details]
File: product
Comment 3 wagerrard 2012-11-02 01:11:33 EDT
Created attachment 636935 [details]
File: type
Comment 4 wagerrard 2012-11-02 01:11:35 EDT
Created attachment 636936 [details]
File: ifcfg.log
Comment 5 wagerrard 2012-11-02 01:11:56 EDT
Created attachment 636937 [details]
File: storage.log
Comment 6 wagerrard 2012-11-02 01:11:57 EDT
Created attachment 636938 [details]
File: version
Comment 7 wagerrard 2012-11-02 01:11:59 EDT
Created attachment 636939 [details]
File: environ
Comment 8 wagerrard 2012-11-02 01:12:01 EDT
Created attachment 636940 [details]
File: executable
Comment 9 wagerrard 2012-11-02 01:12:02 EDT
Created attachment 636941 [details]
File: anaconda.log
Comment 10 wagerrard 2012-11-02 01:12:04 EDT
Created attachment 636942 [details]
File: syslog
Comment 11 wagerrard 2012-11-02 01:12:06 EDT
Created attachment 636943 [details]
File: hashmarkername
Comment 12 wagerrard 2012-11-02 01:12:07 EDT
Created attachment 636944 [details]
File: packaging.log
Comment 13 wagerrard 2012-11-02 01:12:09 EDT
Created attachment 636945 [details]
File: cmdline_file
Comment 14 wagerrard 2012-11-02 01:12:11 EDT
Created attachment 636946 [details]
File: release
Comment 15 wagerrard 2012-11-02 01:12:12 EDT
Created attachment 636947 [details]
File: program.log
Comment 16 wagerrard 2012-11-02 01:23:53 EDT
Anaconda 18,23:  In "Manual Partitioning", clicked on name of existing partition.

Package: anaconda-18.23
OS Release: Fedora release 18
Comment 17 Jeffrey Moyer 2012-11-02 14:19:52 EDT
I chose to review/modify partition layout myself.  I then selected an existing /boot partition from a rhel6 install (that install was to partitions, no lvm involved).  It was when I made this selection that the unknown error dialog appeared.

Package: anaconda-18.23
OS Release: Fedora release 18
Comment 18 John Reiser 2012-11-02 14:20:20 EDT
UEFI boot full-install DVD.  Custom install to GPT disk that was pre-partitioned and formatted by gparted LiveCD: 50MiB fat16 EFI System Partition (boot flag), 500MiB ext4 /boot, 15GiB / (root), 4GiB swap.  Click on '+' to expand "Unknown", click on "EFI System Partition".  Traceback.

Package: anaconda-18.23
OS Release: Fedora release 18
Comment 19 Chris Lumens 2012-11-02 14:23:00 EDT
Yeah, trivially reproducible.  Sigh.
Comment 20 Adam Williamson 2012-11-02 15:31:24 EDT
With the number of people hitting this and how simple it sounds to reproduce, looks blocker-y. Technically 18.23 isn't in stable yet, but we should track this as we obviously need to ship something post-18.22.
Comment 21 Brian Lane 2012-11-02 19:40:34 EDT
*** Bug 868698 has been marked as a duplicate of this bug. ***
Comment 22 Adam Williamson 2012-11-02 20:08:41 EDT
whoops, nominated for final not beta by mistake.
Comment 23 Fedora Update System 2012-11-02 21:02:56 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 24 Fedora Update System 2012-11-03 15:27:29 EDT
Package anaconda-18.24-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.24-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17543/anaconda-18.24-1.fc18
then log in and leave karma (feedback).
Comment 25 Adam Williamson 2012-11-05 11:35:18 EST
Discussed at 2012-11-05 QA meeting acting as a blocker review meeting. Accepted as a blocker per criterion "The installer's custom partitioning mode must be capable of the following ... Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types."
Comment 26 Jeffrey Moyer 2012-11-05 13:27:12 EST
If you need testing, just point me to an install image that has the new anaconda and I'd be happy to give it a try.

Thanks!
Comment 27 Adam Williamson 2012-11-05 16:22:07 EST
Jeffrey: https://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC7/ has 18.24. Thanks!

Can anyone else who could reproduce this please test with 18.24 and confirm that it's fixed? Thanks!
Comment 28 Reartes Guillermo 2012-11-05 17:04:41 EST
booted a guest with a preexisting f18, selected the disk and entered manual partitioning
selected the /, changed it size to 500000 then to 0 and then back to 500000


Package: anaconda-18.24
OS Release: Fedora release 18-Beta-TC7
Comment 29 wagerrard 2012-11-05 17:25:54 EST
Burned a TC7 CD his morning. Booted it on a box with 3 physical drives. Deleted the existing partitions via the do-it-myself Reclaim Space option. Went to Manual Partition screen where, correctly, no partitions were visible. Clicked on "Automatic", which created /, /Boot, /Home, and swap. Resized /Home, /, and swap, then created a few other partitions.  Everything successful.

The partitioning made efficient and logical use of the drives, but, except for /Boot and / on the designated boot drive, I didn't see a way to identify or control which partitions went on which drives.
Comment 30 Adam Williamson 2012-11-05 18:26:09 EST
wagerrard: click the 'gears' button next to the + and - buttons, and you get a dialog that lets you pick what disk the partition goes on.
Comment 31 Adam Williamson 2012-11-05 18:29:45 EST
bcl, comment #28 indicates reartes managed to hit this even with 18.24. does that indicate a problem with the fix, or is his a corner case that wasn't covered? how worried are we?
Comment 32 Fedora Update System 2012-11-05 20:38:08 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 33 Fedora Update System 2012-11-06 21:10:08 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 34 Adam Williamson 2012-11-07 14:23:35 EST
David, can you take a look at this, re comment #31? Is the fix incomplete? how bad is it that this can still be reproduced with the method described in #28?
Comment 35 David Lehman 2012-11-07 14:25:23 EST
(In reply to comment #28)
> booted a guest with a preexisting f18, selected the disk and entered manual
> partitioning
> selected the /, changed it size to 500000 then to 0 and then back to 500000
> 
> 
> Package: anaconda-18.24
> OS Release: Fedora release 18-Beta-TC7

Please open a new bug report including all logs. Thanks.
Comment 36 Adam Williamson 2012-11-07 15:52:03 EST
as wagerrard reports the initial reproducer of this is fixed, and dlehman considers the comment #28 reproducer a separate bug, setting VERIFIED.
Comment 37 Fedora Update System 2012-11-07 22:24:22 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 38 Adam Williamson 2012-11-08 04:15:17 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken). Subsequent dupes of this are likely to be a different bug (see comment #35).
Comment 39 Jeffrey Moyer 2012-11-09 17:19:20 EST
I finally got around to testing this and it worked fine for me.
Comment 40 Adam Williamson 2012-11-10 00:44:18 EST
Thanks for the confirmation, Jeffrey.

Note You need to log in before you can comment on or make changes to this bug.